现货指标 一品操盘源码-仟家信公式 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 外汇现货>> 仟家信等>> 仟家信公式>>正文内容

365bet送体验金

具体源码如下:

STICKLINE(C>=O OR (C=O AND C>REF(C,1)),O,C,4,1),COLORRED;
STICKLINE((C>=O AND C<>H) OR (C=O AND C>REF(C,1)),C,H,0.1,0),COLORRED;
STICKLINE((C>=O AND L<>O) OR (C=O AND C>REF(C,1)),L,O,0.1,0),COLORRED;
STICKLINE(C<O OR (C=O AND C>REF(C,1)),O,C,4,0),COLORCYAN;
STICKLINE((C<O AND C<>H) OR (C=O AND C>REF(C,1)),C,H,0.1,1),COLORCYAN;
STICKLINE((C<O AND L<>O) OR (C=O AND C>REF(C,1)),L,O,0.1,1),COLORCYAN;
压力:HHV(MA((LOW+HIGH+CLOSE)/3,1),34),LINETHICK2,COLORGREEN;
支撑:LLV(MA((LOW+HIGH+CLOSE)/3,1),34),LINETHICK2,COLORRED;
RV:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
RG:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
VA1:=SMA(RV,3,1);
VA2:=SMA(VA1,3,1);
ZZ:=EMA(SMA(RG,3,1),2);
XX:=SMA(ZZ,3,1);
DRAWICON(CROSS(VA1,VA2) AND CROSS(ZZ,XX),L,1);
DRAWICON(CROSS(VA2,VA1) AND CROSS(XX,ZZ),H,2);

 

 

源码解析:

当满足条件收盘价>=OOR(收盘价=OANDC>昨收)时,在开盘价和收盘价位置之间画柱状线,宽度为4,1不为0则画空心柱.,画红色
当满足条件(收盘价>=OANDC<>最高价)OR(收盘价=OANDC>昨收)时,在收盘价和最高价位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,画红色
当满足条件(收盘价>=OANDL<>开盘价)OR(收盘价=OANDC>昨收)时,在最低价和开盘价位置之间画柱状线,宽度为0.1,0不为0则画空心柱.,画红色
当满足条件收盘价<OOR(收盘价=OANDC>昨收)时,在开盘价和收盘价位置之间画柱状线,宽度为4,0不为0则画空心柱.,画青色
当满足条件(收盘价<OANDC<>最高价)OR(收盘价=OANDC>昨收)时,在收盘价和最高价位置之间画柱状线,宽度为0.1,1不为0则画空心柱.,画青色
当满足条件(收盘价<OANDL<>开盘价)OR(收盘价=OANDC>昨收)时,在最低价和开盘价位置之间画柱状线,宽度为0.1,1不为0则画空心柱.,画青色
输出压力:34日内(最低价+最高价+收盘价)/3的1日简单移动平均的最高值,线宽为2,画绿色
输出支撑:34日内(最低价+最高价+收盘价)/3的1日简单移动平均的最低值,线宽为2,画红色
RV赋值:(收盘价-27日内最低价的最低值)/(27日内最高价的最高值-27日内最低价的最低值)*100
RG赋值:(收盘价-5日内最低价的最低值)/(5日内最高价的最高值-5日内最低价的最低值)*100
VA1赋值:RV的3日[1日权重]移动平均
VA2赋值:VA1的3日[1日权重]移动平均
ZZ赋值:RG的3日[1日权重]移动平均的2日指数移动平均
XX赋值:ZZ的3日[1日权重]移动平均
当满足条件VA1上穿VA2ANDCROSS(ZZ,XX)时,在最低价位置画1号图标
当满足条件VA2上穿VA1ANDCROSS(XX,ZZ)时,在最高价位置画2号图标

 

 

如果以上指标公式不适用于您常用的行情软件

或者您想改编成选股公式,以便快速选出某种形态个股的话,

可以联系我们相关技术人员 QQ: 262069696  点击在线交流进行 有偿 改编!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容