第一密码图指标源码-倚天版公式 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 外汇现货>> 倚天财经>> 倚天版公式>>正文内容

365bet送体验金

第一密码图H1:EMA(CLOSE,8);
H2:EMA(第一密码图H1,20);
LH:EMA(CLOSE,240),COLORRED;
VAR1:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR2:=SMA(VAR1,5,1);
VAR3:=SMA(VAR2,8,1);
VAR4:=CROSS(VAR2,VAR3) AND VAR3<20;
VAR5:=CLOSE>LLV(CLOSE,60)+0.3*LLV(CLOSE,60) AND VAR4;
VAR6:=IF(CLOSE>1000,VAR4,VAR5);
DRAWICON(CROSS(第一密码图H1,H2) AND CLOSE<EMA(CLOSE,60),LOW,1);
DRAWICON(VAR6,H,2);
STICKLINE(第一密码图H1>H2,第一密码图H1,H2,1,1),COLORYELLOW;
STICKLINE(第一密码图H1<H2,第一密码图H1,H2,1,1),COLORBLUE;

 

源码解析:

输出第一密码图H1:收盘价的8日指数移动平均
输出H2:第一密码图H1的20日指数移动平均
输出LH:收盘价的240日指数移动平均,画红色
VAR1赋值:(36日内最高价的最高值-收盘价)/(36日内最高价的最高值-36日内最低价的最低值)*100
VAR2赋值:VAR1的5日[1日权重]移动平均
VAR3赋值:VAR2的8日[1日权重]移动平均
VAR4赋值:VAR2上穿VAR3 AND VAR3<20
VAR5赋值:收盘价>60日内收盘价的最低值+0.3*60日内收盘价的最低值 AND VAR4
VAR6赋值:如果收盘价>1000,返回VAR4,否则返回VAR5
当满足条件第一密码图H1上穿H2ANDCLOSE<收盘价的60日指数移动平均时,在最低价位置画1号图标
当满足条件VAR6时,在最高价位置画2号图标
当满足条件第一密码图H1>H2时,在第一密码图H1和H2位置之间画柱状线,宽度为1,1不为0则画空心柱.,画黄色
当满足条件第一密码图H1<H2时,在第一密码图H1和H2位置之间画柱状线,宽度为1,1不为0则画空心柱.,画蓝色
 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 262069696  点击在线交流进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容