均线模型源码-365bet送体验金财经公式 -程序化交易(grahamobil.com) - 365bet送体验金

365bet送体验金

  • 咨询内容:

    买入条件1   B1:= REF(C>MA(C,10),1);

    卖出条件1   S1:= REF(C<MA(C,10),1);

     

    买入条件2   B2:= REF(C>MA(C,30),1);

    卖出条件2   S2:= REF(C<MA(C,30),1);

     

    系统的规则如下:

    1.当目前无因B1/S1条件的持仓,首次满足条件B1或S1信号时,买入或卖出1手;之后再有相同的信号忽略掉直至遇到与之对应的相反信号,才平掉原来的仓位并建反方向的仓位1手。

    2.当目前无因B2/S2条件的持仓,首次满足条件B2或S2信号时,买入或卖出1手;之后再有相同的信号忽略掉直至遇到与之对应的相反信号,才平掉原来的仓位并建反方向的仓位1手。

     

    象这样的系统怎么编程实现?

    (不想分成两个系统,因为模组数不够用了)

     

    以上,谢谢!

     

     

  • 赢顺技术人员:

    您的意思基本上已经理解,不过有一个问题还请您解释一下,如果先满足B1条件,开了1手多仓,然后在出现s1前又出现了B2,这时是否开仓呢?

     

  • 赢顺客服: 以下是引用空之境界在2012-7-3 13:03:00的发言:

    您的意思基本上已经理解,不过有一个问题还请您解释一下,如果先满足B1条件,开了1手多仓,然后在出现s1前又出现了B2,这时是否开仓呢?

    开仓。

    1和2之间可以认为是独立的。

     

  • 网友回复:

    B1:REF(CROSS(C,MA(C,10)),1);
    B2:REF(CROSS(C,MA(C,30)),1);
    S1:REF(CROSS(MA(C,10),C),1);
    S2:REF(CROSS(MA(C,30),C),1);
    B1&&BARSLAST(S1)<BARSLAST(B1),BPK;
    B2&&BARSLAST(S2)<BARSLAST(B2),BPK;
    S1&&BARSLAST(B1)<BARSLAST(S1),SPK;
    S2&&BARSLAST(B2)>BARSLAST(S2),SPK;

    模型仅供参考

     

  • 网友回复: 以下是引用空之境界在2012-7-3 13:59:00的发言:

    B1:REF(CROSS(C,MA(C,10)),1);
    B2:REF(CROSS(C,MA(C,30)),1);
    S1:REF(CROSS(MA(C,10),C),1);
    S2:REF(CROSS(MA(C,30),C),1);
    B1&&BARSLAST(S1)<BARSLAST(B1),BPK;
    B2&&BARSLAST(S2)<BARSLAST(B2),BPK;
    S1&&BARSLAST(B1)<BARSLAST(S1),SPK;
    S2&&BARSLAST(B2)>BARSLAST(S2),SPK;

    模型仅供参考

    非常感谢!

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 262069696  点击在线交流进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容