365bet送体验金与开拓者通用的dual thrust系统策略源码-365bet送体验金财经公式 -程序化交易(grahamobil.com) - 365bet送体验金

365bet送体验金

  • dual thrust系统原形



    开拓者TB源码:
    1. Inputs: K1(.5),K2(.5),Mday(1),Nday(1);
    2. Vars: BuyRange(0), SellRange(0);
    3. Vars: BuyTrig(0),SellTrig(0);
    4. Vars: HH(0),LL(0),HC(0),LC(0);
    5. //程序化交易 www.grahamobil.com
    6. If CurrentBar > 1 Then Begin
    7. HH = Highest(High,Mday);
    8. HC = Highest(Close,Mday);
    9. LL = Lowest(Low,Mday);
    10. LC = Lowest(Close,Mday);
    11.  
    12. If (HH - LC) >= (HC - LL) Then Begin
    13. SellRange = HH - LC;
    14. End Else Begin
    15. SellRange = HC - LL;
    16. End;
    17.  
    18. HH = Highest(High,Nday);
    19. HC = Highest(Close,Nday);
    20. LL = Lowest(Low,Nday);
    21. LC = Lowest(Close,Nday);
    22.  
    23. If (HH - LC) >= (HC - LL) Then Begin
    24. BuyRange = HH - LC;
    25. End Else Begin
    26. BuyRange = HC - LL;
    27. End;
    28.  
    29. BuyTrig = K1*BuyRange;
    30. SellTrig = K2*SellRange;
    31.  
    32. If MarketPosition = 0 Then Begin
    33. Buy at Open of next bar + BuyTrig Stop;
    34. Sell at Open of next bar - SellTrig Stop;
    35. End;
    36.  
    37. If MarketPosition = -1 Then Begin
    38. Buy at Open of next bar + Buytrig Stop;
    39. End;
    40.  
    41. If MarketPosition = 1 Then Begin
    42. Sell at Open of next bar - SellTrig Stop;
    43. End;
    44.  
    45. End;

     

     

     

     

     

     

     

  • 365bet送体验金财经源码

     

    M:=1;
    M1:=1;
    K1:=0.5;
    K2:=0.5;
    N:=BARSLAST(DATE<>REF(DATE,1))+1;
    OO:=VALUEWHEN(DATE<>REF(DATE,1),O);
    HH1:=REF(HHV(H,N*M),N);
    LL1:=REF(LLV(L,N*M),N);
    HC1:=REF(HHV(C,N*M),N);
    LC1:=REF(LLV(C,N*M),N);
    HH2:=REF(HHV(H,N*M1),N);
    LL2:=REF(LLV(L,N*M1),N);
    HC2:=REF(HHV(C,N*M1),N);
    LC2:=REF(LLV(C,N*M1),N);
    SELLR:=IFELSE((HH1-LC1)>=(HC1-LL1),HH1-LC1,HC1-LL1);
    BUYR:=IFELSE((HH2-LC2)>=(HC2-LL2),HH2-LC2,HC2-LL2);
    BT:=K1*BUYR;
    ST:=K2*SELLR;
    BUYP:=OO+BT;
    SELLP:=OO-ST;
    //程序化交易 www.grahamobil.com
    H>=BUYP&&C>=MAX(O,BUYP),BPK;
    L<=SELLP&&C<=MIN(O,SELLP),SPK;
    AUTOFILTER;



     

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 262069696  点击在线交流进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容