daul thrust交易系统源码-365bet送体验金财经公式 -程序化交易(grahamobil.com) - 365bet送体验金

365bet送体验金

daul thrust交易系统源码

 

M:=1;
M1:=1;
K1:=0.5;
K2:=0.5;
N:=BARSLAST(DATE<>REF(DATE,1))+1;
OO:=VALUEWHEN(DATE<>REF(DATE,1),O);
HH1:=REF(HHV(H,N*M),N);
LL1:=REF(LLV(L,N*M),N);
HC1:=REF(HHV(C,N*M),N);// www.grahamobil.com
LC1:=REF(LLV(C,N*M),N);
HH2:=REF(HHV(H,N*M1),N);
LL2:=REF(LLV(L,N*M1),N);
HC2:=REF(HHV(C,N*M1),N);
LC2:=REF(LLV(C,N*M1),N);
SELLR:=IFELSE((HH1-LC1)>=(HC1-LL1),HH1-LC1,HC1-LL1);
BUYR:=IFELSE((HH2-LC2)>=(HC2-LL2),HH2-LC2,HC2-LL2);
BT:=K1*BUYR;// www.grahamobil.com
ST:=K2*SELLR;
BUYP:=OO+BT;
SELLP:=OO-ST;
H>=BUYP&&C>=MAX(O,BUYP),BPK;
L<=SELLP&&C<=MIN(O,SELLP),SPK;
AUTOFILTER;

 

 

 

源码解析

 

M赋值:1
M1赋值:1
K1赋值:0.5
K2赋值:0.5
N赋值:上次日期不等于1日前的日期距今天数+1
OO赋值:如果日期不等于1日前的日期,返回开盘价,否则返回上个输出值
HH1赋值:N日前的N*M日内最高价的最高值
LL1赋值:N日前的N*M日内最低价的最低值
HC1赋值:N日前的N*M日内收盘价的最高值
LC1赋值:N日前的N*M日内收盘价的最低值
HH2赋值:N日前的N*M1日内最高价的最高值
LL2赋值:N日前的N*M1日内最低价的最低值
HC2赋值:N日前的N*M1日内收盘价的最高值
LC2赋值:N日前的N*M1日内收盘价的最低值
SELLR赋值:IFELSE((HH1-LC1)>=(HC1-LL1),HH1-LC1,HC1-LL1)
BUYR赋值:IFELSE((HH2-LC2)>=(HC2-LL2),HH2-LC2,HC2-LL2)
BT赋值:K1*BUYR
ST赋值:K2*SELLR
BUYP赋值:OO+BT
SELLP赋值:OO-ST
最高价>=BUYP并且收盘价>=开盘价和BUYP的较大值,BPK
最低价<=SELLP并且收盘价<=开盘价和SELLP的较小值,SPK
自动过滤交易信号
 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 1145508240  点击这里给我发消息进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容