日内5分实战模型源码-365bet送体验金财经公式 -程序化交易(grahamobil.com) - 365bet送体验金

365bet送体验金

N1:=6;
N2:=21;
N3:=25;
TR := MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
ATR := EMA(TR,N1);
EF:=(HHV(CLOSE,N2)-LLV(CLOSE,N2))/SUM(ABS(CLOSE-REF(CLOSE,1)),N2);
RSV:=(CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10))*100;
BACKGROUNDSTYLE(1);
K:=SMA(RSV,30,1);// www.grahamobil.com 
D:=SMA(K,30,1);
J:=3*K-2*D;// www.grahamobil.com 
TR>MAX(ATR*(1.5-(EF-0.5)*(N3/10)),ATR)&&HIGH>REF(HIGH,1)&&CLOSE>OPEN&&TIME>0905&&TIME<1455,BPK;
TR>MAX(ATR*(1.5-(EF-0.5)*(N3/10)),ATR)&&LOW<REF(LOW,1)&&CLOSE<OPEN&&TIME>0905&&TIME<1455,SPK;
EXIST(J<10,5)&&J<D&&COUNT(J>REF(J,1),1)=1,BP;
EXIST(J>90,5)&&J>D&&COUNT(J<REF(J,1),1)=1,SP;
TIME>1455,BP;// www.grahamobil.com 
TIME>1455,SP;
AUTOFILTER;

 

 

源码解析:

N1赋值:6
N2赋值:21
N3赋值:25
赋值: (最高价-最低价)和1日前的收盘价-最高价的绝对值的较大值和1日前的收盘价-最低价的绝对值的较大值
赋值: 真实波幅的N1日指数移动平均
EF赋值:(N2日内收盘价的最高值-N2日内收盘价的最低值)/收盘价-1日前的收盘价的绝对值的N2日累和
RSV赋值:(收盘价-10日内最低价的最低值)/(10日内最高价的最高值-10日内最低价的最低值)*100
BACKGROUNDSTYLE(1)
K赋值:RSV的30日[1日权重]移动平均
D赋值:K的30日[1日权重]移动平均
J赋值:3*K-2*D // www.grahamobil.com 
真实波幅>真实波幅*(1.5-(EF-0.5)*(N3/10))和真实波幅的较大值并且最高价>1日前的最高价并且收阳线并且时间(时分)>0905并且时间(时分)<1455,BPK
真实波幅>真实波幅*(1.5-(EF-0.5)*(N3/10))和真实波幅的较大值并且最低价<1日前的最低价并且收阴线并且时间(时分)>0905并且时间(时分)<1455,SPK
最近5日存在J<10并且J<D并且1日中满足J>1日前的J的天数=1,BP
最近5日存在J>90并且J>D并且1日中满足J<1日前的J的天数=1,SP
时间(时分)>1455,BP
时间(时分)>1455,SP
自动过滤交易信号
 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 1145508240  点击这里给我发消息进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容