365bet送体验金峰波峰波谷指标-365bet送体验金财经公式 -程序化交易(grahamobil.com) - 365bet送体验金

365bet送体验金

 

源码:

TY:=C;
A1:=REF(TY,10)=HHV(TY,2*10+1);
B1:=FILTER(A1,10);
C1:=BACKSET(B1,10+1);
HD:=FILTER(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1);
B2:=FILTER(A2,10);
C2:=BACKSET(B2,10+1);
LD:=FILTER(C2,10);
AZ1:=REF(C,BARSLAST(HD));
B:=REF(C,BARSLAST(LD));
T1:=BARSLAST(HD);//WWW.grahamobil.com
T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);
波峰:IF(T1,AZ1,AZ1),POINTDOT,COLOR0000FF,LINETHICK3;
STICKLINE(T1,AZ1,AZ1,9,0),COLOR0000FF,LINETHICK2;
波谷:IF(T2,B,B),COLOR80FF00,POINTDOT,LINETHICK3;
STICKLINE(T2,B,B,9,0),COLOR80FF00,LINETHICK2;

 

解析:

TY赋值:收盘价
A1赋值:10日前的TY=2*10+1日内TY的最高值
B1赋值:A1的10日过滤
C1赋值:若B1则将最近10+1周期置为1
HD赋值:C1的10日过滤
A2赋值:10日前的TY=2*10+1日内TY的最低值
B2赋值:A2的10日过滤
C2赋值:若B2则将最近10+1周期置为1
LD赋值:C2的10日过滤
AZ1赋值:上次HD距今天数日前的收盘价
B赋值:上次LD距今天数日前的收盘价
T2赋值:上次HD距今天数>上次LD距今天数 AND 取反
输出波峰:如果T1,返回AZ1,否则返回AZ1,POINTDOT,COLOR0000FF,线宽为3
当满足条件T1时,在AZ1和AZ1位置之间画柱状线,宽度为9,0不为0则画空心柱.,COLOR0000FF,线宽为2
输出波谷:如果T2,返回B,否则返回B,COLOR80FF00,POINTDOT,线宽为3
当满足条件T2时,在B和B位置之间画柱状线,宽度为9,0不为0则画空心柱.,COLOR80FF00,线宽为2
 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 1145508240  点击这里给我发消息进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容