W百变K线指标公式-其他软件公式 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 股票公式>> 其他>> 其他软件公式>>正文内容

365bet送体验金

相关标签:飞狐节气k线公式 、 飞狐趋势线指标公式 、 慧眼k线指标公式 、 阳光k线指标公式 、 机构k线指标公式 、 反k线指标公式 、 四维k线指标公式 、 成交量k线指标公式 、 k线w底选股公式 、 飞狐k线源码 、 飞狐箱体k线 、 飞狐k线附图 、 k线显示板块指标公式 、 经传慧眼k线指标公式 、 底部异动k线指标公式 、

 

DRAWutf-8(CLOSE>0,COLORRGB(1,777,777),COLORRGB(1,222,444),1);J5:MA(CLOSE,5),colorCCFFFF;J10:MA(CLOSE,10),colorFFFF;J20:MA(CLOSE,20),colorF00FF0;J30:MA(CLOSE,30),colorFF00;J60:MA(CLOSE,60),colorFFAA00;J120:MA(CLOSE,120),color9900;J250:MA(CLOSE,250),colorFF0000;STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,8,0),color9900FF;STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,7,0),colorCC00FF;STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,6,0),colorFF00FF;STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,4,0),colorFF66FF;STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,2,0),colorFF99FF;STICKLINE(CLOSE>=OPEN,HIGH,LOW,1,0),colorFFCCFF;STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,8,0),colorFF0033;STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,7,0),colorFF3333;STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,6,0),colorFF6633;STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,4,0),colorFF9933;STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,2,0),colorFFCC33;STICKLINE(CLOSE<=OPEN,HIGH,LOW,1,0),colorFFFF33;AA:=SYSPARAM(1);CC:=SYSPARAM(2);DD:=AA-CC;IF DD=1 THEN BEGINDRAWutf-8(DD=1,COLORRGB(255,125,0),COLORRGB(255,255,0),1);STICKLINE(OPEN>=CLOSE,OPEN,CLOSE,9,0),colorAAAAAA;STICKLINE(OPEN>=CLOSE,OPEN,CLOSE,6,0),colorBBBBBB;STICKLINE(OPEN>=CLOSE,OPEN,CLOSE,2.4,0),colorCCCCCC;STICKLINE(OPEN>=CLOSE,OPEN,CLOSE,1.1,0),colorDDDDDD;STICKLINE(CLOSE>OPEN,OPEN,CLOSE,9,0),color6666CC;STICKLINE(CLOSE>OPEN,OPEN,CLOSE,6,0),color7777DD;STICKLINE(CLOSE>OPEN,OPEN,CLOSE,2.4,0),color8888EE;STICKLINE(CLOSE>OPEN,OPEN,CLOSE,1.1,0),color9999FF;STICKLINE(CLOSE>OPEN,OPEN,LOW,0.5,0),color1199FF;STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.5,0),color1199FF;STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0.5,0),colorCCCCCC;STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0.5,0),colorCCCCCC;FH:=HIGH;FL:=LOW;SELL:=0*FH;BUY:=SELL;SIGNAL:=SELL;BOXH:SELL,LINETHICK0;BOXL:SELL,LINETHICK0;VARIABLE:HC=0,LC=0,BT=FH[1],BB=FH[1];FOR I=1 TO DATACOUNT DO BEGINIF HC>1 THEN BEGINIF LC>2 AND BT<=FH[I] THEN BEGINBUY[I]:=1;FOR J=I-1 DOWNTO I-HC DO BEGINBOXH[J]:FH[I-HC],LINETHICK0;BOXL[J]:FL[I-LC],LINETHICK0;END;HC:=0;LC:=0;END;IF BT>FH[I] THEN BEGINIF LC>2 THEN BEGINIF BB>=FL[I] THEN BEGINSELL[I]:=1;FOR J=I-1 DOWNTO I-HC DO BEGINBOXH[J]:FH[I-HC],LINETHICK0;BOXL[J]:FL[I-LC],LINETHICK0;END;HC:=-1;LC:=0;END;ELSE BEGINBOXH[I]:FH[I-HC],LINETHICK0;BOXL[I]:FL[I-LC],LINETHICK0;END;END;HC:=HC+1;IF LC>1 THEN BEGINIF BB<FL[I] THEN BEGINLC:=LC+1;IF LC=3 THEN BEGINSIGNAL[I-HC+1]:=1;FOR J=I DOWNTO I-HC+1 DO BEGINBOXH[J]:FH[I-HC+1],LINETHICK0;BOXL[J]:FL[I-LC+1],LINETHICK0;END;END;END;ELSELC:=0;END;ELSEIF LC=1 THEN BEGINIF BB<FL[I] THEN BEGINLC:=LC+1;END;ELSELC:=0;END;IF LC=0 AND HC>1 THEN BEGINBB:=FL[I];LC:=LC+1;END;END;ELSE BEGINHC:=0;LC:=0;END;END;ELSEIF HC=1 THEN BEGINIF BT>FH[I] THENHC:=HC+1;ELSE BEGINHC:=0;LC:=0;END;END;IF HC=0 THEN BEGINBT:=FH[I];HC:=HC+1;END;END;PARTLINE(BOXH AND BOXH=REF(BOXH,1),BOXH),colorFFFF;PARTLINE(BOXL AND BOXL=REF(BOXL,1),BOXL),colorFFFF;STICKLINE((SIGNAL OR REFX(BUY OR SELL,1)) AND BOXH,BOXH,BOXL,0.1,0),colorFFFF;DRAWICON(BUY,LOW*0.98,4);DRAWICON(SELL,HIGH*1.02,5);END;IF DD=2 THEN BEGINDRAWutf-8(DD=2,COLORRGB(1,888,888),COLORRGB(1,222,444),1);MA3:MA(CLOSE,3);MA5:MA(CLOSE,5),colorFFFF;MA21:MA(CLOSE,21);AA:=REF(HIGH,12)=HHV(HIGH,2*12+1);BB:=BACKSET(AA,12+1);CC:=FILTER(BB,12) AND HIGH=HHV(HIGH,12+1);DRAWICON(CC AND ISLASTBAR=1,HIGH*1.01,10);AA2:=REF(LOW,12)=LLV(LOW,2*12+1);BB2:=BACKSET(AA2,12+1);CC2:=FILTER(BB2,12) AND LOW=LLV(LOW,12+1);DRAWICON(CC2 AND ISLASTBAR=1,LOW*0.998,11);GG:=ISLASTBAR=1 AND REF(CC,BARSLAST(CC));HH:=BACKSET(GG,BARSLAST(CC)+1);II:=HH>REF(HH,1);JJ:=REF(BARSLAST(CC),1);KK:=BACKSET(II,JJ+2);LL:=KK>REF(KK,1);DRAWLINE(LL,HIGH,II,HIGH,1),colorFF;GG2:=ISLASTBAR=1 AND REF(CC2,BARSLAST(CC2));HH2:=BACKSET(GG2,BARSLAST(CC2)+1);II2:=HH2>REF(HH2,1);JJ2:=REF(BARSLAST(CC2),1);KK2:=BACKSET(II2,JJ2+2);LL2:=KK2>REF(KK2,1);DRAWLINE(LL2,LOW,II2,LOW,1),colorFF00;LA1:=LLVBARS(LOW,30);LA2:=BACKSET(ISLASTBAR,LA1+1);LA:=FILTER(LA2,30);DRAWICON(LA,LOW,10);LB1:=LLVBARS(LOW,60);LB2:=BACKSET(ISLASTBAR,LB1+1);LB:=FILTER(LB2,60);DRAWICON(LB,LOW,10);LC1:=LLVBARS(LOW,120);LC2:=BACKSET(ISLASTBAR,LC1+1);LC:=FILTER(LC2,120);DRAWICON(LC,LOW,10);LD1:=LLVBARS(LOW,250);LD2:=BACKSET(ISLASTBAR,LD1+1);LD:=FILTER(LD2,250);DRAWICON(LD,LOW,10);LINEVALUE(LD,LOW,LC,LOW,0,0),colorFFFF;LINEVALUE(LC,LOW,LB,LOW,0,0),colorFF9000;LINEVALUE(LB,LOW,LA,LOW,0,0),colorFF00;VAR1:=(2*CLOSE+HIGH+LOW)/4;VAR2:=MA(VAR1,5);VAR3:=MA(VAR1,21);VAR4:=MA(VAR1,60);STICKLINE(VAR1>=VAR2,CLOSE,OPEN,6,0),colorFF00FF;STICKLINE(VAR1>=VAR2,HIGH,LOW,0,0),colorFF00FF;STICKLINE(VAR1<VAR2,CLOSE,OPEN,6,0),colorFFFFFF;STICKLINE(VAR1<VAR2,HIGH,LOW,0,0),colorFFFFFF;STICKLINE(VAR1<=VAR3 AND VAR1>OPEN,CLOSE,OPEN,6,0),colorFFFF;STICKLINE(VAR1<=VAR3 AND VAR1>OPEN,HIGH,LOW,0,0),colorFFFF;STICKLINE(VAR1>=VAR4 AND VAR1>OPEN,CLOSE,OPEN,6,0),colorFF;STICKLINE(VAR1>=VAR4 AND VAR1>OPEN,HIGH,LOW,0,0),colorFF;STICKLINE(VAR1>=VAR4 AND VAR1<OPEN,CLOSE,OPEN,6,0),color646464;STICKLINE(VAR1>=VAR4 AND VAR1<OPEN,HIGH,LOW,0,0),color646464;A3:=BARSLAST(REF(CROSS("MACD.DIFF","MACD.DEA"),1));B3:=REF(CLOSE,A3+1)>CLOSE AND REF("MACD.DIFF",A3+1)<"MACD.DIFF" AND CROSS("MACD.DIFF","MACD.DEA");DRAWTEXT(FILTER(B3>0,5),LOW-0.38,'MACD底背'),colorFF00;C3:=BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1));D3:=REF(CLOSE,C3+1)>CLOSE AND REF("KDJ.K",C3+1)<"KDJ.K" AND CROSS("KDJ.K","KDJ.D");DRAWTEXT(FILTER(D3>0,5),LOW-0.39,'KDJ底背'),colorFFFF;短线2:=BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1));短线1:=REF(CLOSE,短线2+1)>CLOSE AND REF("RSI.RSI1",短线2+1)<"RSI.RSI1" AND CROSS("RSI.RSI1","RSI.RSI2");DRAWTEXT(FILTER(短线1>0,5),LOW,'RSI底背'),colorFFFF00;MA10:=BARSLAST(REF(CROSS("MACD.DEA","MACD.DIFF"),1));VARA:=REF(CLOSE,MA10+1)<CLOSE AND REF("MACD.DIFF",MA10+1)>"MACD.DIFF" AND CROSS("MACD.DEA","MACD.DIFF");DRAWTEXT(FILTER(VARA>0,5),HIGH+0.08,'MACD顶背'),colorFFFFFF;VARB:=BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1));VARC:=REF(CLOSE,VARB+1)<CLOSE AND REF("KDJ.K",VARB+1)>"KDJ.K" AND CROSS("KDJ.D","KDJ.K");DRAWTEXT(FILTER(VARC>0,5),HIGH+0.32,'KDJ顶背'),colorFFFFFF;VAR5:=BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1));VAR6:=REF(CLOSE,VAR5+1)<CLOSE AND REF("RSI.RSI1",VAR5+1)>"RSI.RSI1" AND CROSS("RSI.RSI2","RSI.RSI1");DRAWTEXT(FILTER(VAR6>0,5),HIGH+0.1,'RSI顶背'),colorFF00FF;END;IF DD=3 THEN BEGINDRAWutf-8(CLOSE<=OPEN,COLORRGB(1,50,50),COLORRGB(5,1,150),1);DRAWutf-8(CLOSE>OPEN,COLORRGB(0,11,150),COLORRGB(55,50,100),1);STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,8,0),colorA8;STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,7,0),colorC0;STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,6,0),colorD0;STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,4,0),colorE0;STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,3,0),colorF0;STICKLINE(CLOSE>=OPEN,HIGH,LOW,1,0),color3366FF;STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,8,0),color8800;STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,7,0),color9900;STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,6,0),colorAA00;STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,4,0),colorBB00;STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,3,0),colorCC00;STICKLINE(CLOSE<=OPEN,HIGH,LOW,1,0),colorDD00;RSI1:=EMA(EMA(EMA(CLOSE,3),3),3)-REF(EMA(EMA(EMA(CLOSE,3),3),3),1)+EMA(EMA(EMA(CLOSE,3),3),3);走低:HHV(RSI1,3),LINETHICK2,colorFF6633;趋势:RSI1,LINETHICK2,colorFFFF;RSI2:=EMA(EMA(EMA(CLOSE,3),3),3)-REF(EMA(EMA(EMA(CLOSE,3),3),3),1)+EMA(EMA(EMA(CLOSE,3),3),3);支撑:MA(RSI2,10),colorFF00FF;MA5:MA(CLOSE,5),colorFFFF;BIAS3:=MA(CLOSE,10);短线:=MA(EMA(EMA(EMA(CLOSE,3),3),3)-REF(EMA(EMA(EMA(CLOSE,3),3),3),1)+EMA(EMA(EMA(CLOSE,3),3),3),10);VAR1:=SLOPE(EMA(CLOSE,2),5)*15+CLOSE;VAR2:=EMA(VAR1,5);VAR11:=EMA(EMA(EMA(EMA(EMA(EMA(EMA(EMA(VAR2,5),5),5),5),5),5),5),5);VARA12:=BARSLAST(CROSS(CLOSE,VAR11));底部线:=BARSLAST(CROSS(VAR11,CLOSE));MA3:MA(CLOSE,3);VAR3:=REF(CLOSE,2)*0.865;VAR4:=REF(CLOSE,13)*0.772;获利比例:=MIN(VAR3,VAR4);VAR12:=100*VOL/CAPITAL;VAR13:=(SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1))/(SMA(ABS(CLOSE-REF(CLOSE,1)),6,1))*100;VAR14:=(SMA(MAX(CLOSE-REF(CLOSE,1),0),12,1))/(SMA(ABS(CLOSE-REF(CLOSE,1)),12,1))*100;VAR15:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;VAR16:=VAR15<-13 AND VAR13<15 AND MA(CLOSE,5)<0.9*MA(CLOSE,20) AND CLOSE<MA(CLOSE,13)*0.98;VAR17:=CROSS(VAR13,20) AND COUNT(VAR16=1,3)>=1;VAR18:=MA(CLOSE,80)-MA(CLOSE,10)/3;D:=MA(CLOSE,80)-MA(CLOSE,10)/3;VAR19:=WINNER(CLOSE)*100;A5:=MA(VAR19,5);A30:=MA(VAR19,30);VAR21:=(EMA(CLOSE,4)+EMA(CLOSE,8)+EMA(CLOSE,16))/3;VAR22:=(EMA(CLOSE,8.8)+EMA(CLOSE,17.6)+EMA(CLOSE,35.2))/3;VAR23:=(EMA(CLOSE,22.4)+EMA(CLOSE,44.8)+EMA(CLOSE,89.6))/3;VAR24:=(VAR21+VAR22+VAR23)/3;VARA1:=EMA(VAR24,10);VARB1:=CROSS(CLOSE,VARA1);VARC1:=CLOSE>OPEN AND CLOSE>REF(CLOSE,1) AND VOL>REF(VOL,1);VARD1:=IF(VAR21>VAR22,VAR21,VAR22);VARE1:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;VARF1:=VARE1+3*STD(VARE1,10);VARG1:=VARE1-3*STD(VARE1,10);VARH1:=(VARF1-VARG1)/VARE1<0.035;TODAY:=IF(VAR22>VAR23,VAR22,VAR23);TODAYZ:=IF(VARD1>TODAY,VARD1,TODAY);CB:=IF(VAR21<VAR22,VAR21,VAR22);TR:=IF(VAR22<VAR23,VAR22,VAR23);ATR:=IF(CB<TR,CB,TR);HZ3:=(TODAYZ-ATR)/MA(CLOSE,4)<=0.06;TZ:=COUNT(VARB1,3)=1 AND VARC1 AND HZ3 AND CLOSE>MA(CLOSE,7) AND VARF1>REF(VARF1,1) AND A5>=A30 AND VAR19<45 AND HIGH-CLOSE<CLOSE-OPEN AND CLOSE/VARF1<1.03;VARD:=TZ AND REF(VARH1,1)<0.035 AND REF(BARSLAST(TZ),1)>8;STICKLINE(CLOSE<=VAR18 AND COUNT(CLOSE<=VAR18,8)=1,CLOSE,CLOSE,100,0),LINETHICK2,colorBBBBBB;STICKLINE(CLOSE>VAR11 AND CLOSE>REF(CLOSE,VARA12),REF(CLOSE,VARA12),BIAS3,1,0),color6699CC;STICKLINE(CLOSE<VAR11 AND CLOSE<REF(CLOSE,底部线),REF(CLOSE,底部线),BIAS3,1,0),colorFFCC99;STICKLINE(CLOSE>VAR11 AND CLOSE<REF(CLOSE,VARA12),REF(CLOSE,VARA12),MA5,1,0),colorFFFF;上涨:STICKLINE(CLOSE>VAR11,REF(CLOSE,VARA12),REF(CLOSE,VARA12),1,0),LINETHICK2,colorFF66FF;洗盘:STICKLINE(CLOSE>VAR11 AND CLOSE<REF(CLOSE,VARA12),REF(CLOSE,VARA12),REF(CLOSE,VARA12),1,0),LINETHICK2,colorFFFF;下跌:STICKLINE(CLOSE<VAR11,REF(CLOSE,底部线),REF(CLOSE,底部线),1,0),LINETHICK2,colorFFCC99;END;IF DD=4 THEN BEGINDRAWutf-8(DD=4,COLORRGB(665,155,155),COLORRGB(155,155,155),1);DRAWutf-8(CLOSE<=OPEN,COLORRGB(10,160,0),COLORRGB(25,15,0),1);DRAWutf-8(CLOSE>OPEN,COLORRGB(0,11,150),COLORRGB(55,55,100),1);DRAWBKBMP(CLOSE>OPEN,'pxl');DRAWTEXT(SYSPARAM(2)=BARPOS,CLOSE,'泉鑫指标VARE:=SYSPARAM(2)=BARPOS;VARF:=SYSPARAM(4);VAR10:=VARF;CYC5:=MAX(MAX(HIGH-LOW,ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));CYC13:=MA(CYC5,13);VAR1:=REF(CLOSE,1)-REF(CYC13,1);泉鑫线:HHV(VAR1,13),colorFF00;CYC34:=SMA(AMOUNT,15,6)-REF(SMA(AMOUNT,15,6),61);CYC无穷:=LLV(LOW,2);SMA(DMA(CYC无穷,CYC34),8,4);SMA(DMA(CYC无穷,CYC34),7,4);SMA(DMA(CYC无穷,CYC34),6,4);QQ:SMA(DMA(CYC无穷,CYC34),5,4);DRAWICON(QQ/REF(QQ,1)<0.97 AND REF(QQ,2)=REF(QQ,13),LOW,4);底部线:=AMOUNT/VOL/100;VAR1A:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;VAR1B:=SUM(AMOUNT,5)/底部线/100;VAR1C:=SUM(AMOUNT,13)/底部线/100;VAR1D:=SUM(AMOUNT,34)/底部线/100;VAR16:=SUM(AMOUNT,209)/底部线/100;VAR21:=REF(VOL,1)+REF(VOL,2)+REF(VOL,3)+REF(VOL,4);VAR22:=VAR21/CAPITAL;VAR23:=VOL/CAPITAL*VAR1A+VAR22*REF(底部线,1);VAR1E:=IF(DATE<1500501,DMA(VAR1A,VOL/VAR1B),0);VAR1F:=IF(DATE<1500501,DMA(VAR1A,VOL/VAR1C),0);VAR20:=IF(DATE<1500501,DMA(VAR1A,VOL/VAR1D),0);VAR25:=IF(DATE<1500501,DMA(VAR1A,VOL/CAPITAL),0);VAR24:=100*(CLOSE-VAR1E)/VAR1E;VARA1:=100*(CLOSE-VAR1F)/VAR1F;VARB1:=100*(CLOSE-VAR20)/VAR20;VARC1:=100*(CLOSE-VAR25)/VAR25;VARD1:=MA(CLOSE,13);VAR26:=100*(VARD1-REF(VARD1,1))/REF(VARD1,1);VAR27:=CLOSE-LOW;VAR28:=HIGH-LOW;VAR29:=CLOSE-HIGH;VAR2A:=IF(CLOSE>=0,(VAR27/VAR28+VAR29/VAR28)*VOL,(VAR29/VAR28+VAR27/VAR28)*VOL);VAR2B:=SUM(VAR2A,10)/10000;VAR2C:=100*(VAR1F-REF(VAR1F,1))/REF(VAR1F,1);VARE1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;VARF1:=SMA(VARE1,3,1);VARG1:=SMA(VARF1,3,1);VARH1:=3*VARF1-2*VARG1;VAR2D:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;VAR2E:=SMA(VAR2D,5,1);VAR2F:=SMA(VAR2E,10,1);VAR30:=CROSS(VAR2F,VAR2E);RSI:=VAR2F>80 OR VAR2E>80;VARJ:=VAR30 AND RSI;BIAS18:=VAR26>0 AND VAR2C>0 AND VAR2B>0;VAR7:=VAR26<0 OR VAR2C<0 OR VAR2B<0 OR VARA1<0;A7:=CLOSE;SK:=OPEN;SD:=HIGH;ZX:=LOW;持股:STICKLINE(BIAS18,A7,SK,6,0),colorFF;STICKLINE(BIAS18 AND CLOSE<OPEN,A7,SK,6,1),colorFF;持币:STICKLINE(VAR7,A7,SK,6,0),colorFF0000;STICKLINE(VAR7 AND CLOSE<OPEN,A7,SK,6,1),colorFF0000;大顶:STICKLINE(VARJ,SD,ZX,6,0),colorFFFF;STICKLINE(BIAS18,SD,MAX(A7,SK),0,1),colorFF;STICKLINE(BIAS18,MIN(A7,SK),ZX,0,1),colorFF;STICKLINE(VAR7,SD,MAX(A7,SK),0,1),colorFF0000;STICKLINE(VAR7,MIN(A7,SK),ZX,0,1),colorFF0000;END;IF DD=5 THEN BEGINDRAWutf-8(DD=5,COLORRGB(1,8888,8888),COLORRGB(1,3333,6666),3);LC:=REF(CLOSE,1);V2:=(SMA(MAX(CLOSE-LC,0),16,1))/(SMA(ABS(CLOSE-LC),16,1))*100;STICKLINE(CLOSE>OPEN OR CLOSE=OPEN AND CLOSE>REF(CLOSE,1),LOW,HIGH,0.1,1),colorFF;STICKLINE(CLOSE>OPEN OR CLOSE=OPEN AND CLOSE>REF(CLOSE,1),OPEN,CLOSE,8,1),colorFF;STICKLINE(CLOSE<OPEN OR CLOSE=OPEN AND CLOSE<=REF(CLOSE,1),LOW,HIGH,0.1,0),colorFFFF00;STICKLINE(CLOSE<OPEN OR CLOSE=OPEN AND CLOSE<=REF(CLOSE,1),OPEN,CLOSE,8,0),colorFFFF00;STICKLINE(V2<50,LOW,HIGH,0.1,0),colorFF00;STICKLINE(V2<50,LOW,HIGH,8,0),colorFF00;STICKLINE(V2>50,LOW,HIGH,0.1,1),colorFF;STICKLINE(V2>50,LOW,HIGH,8,1),colorFF;VAR1:=EMA(EMA(EMA(CLOSE,3),3),3);中线:EMA(CLOSE,34),LINETHICK1,colorFFFFFF;短线:VAR1-REF(VAR1,1)+VAR1,colorF00FF0;中短:MA(短线,10),colorFF00;STICKLINE(短线>中短,中短,短线,0.1,1),LINETHICK1,colorFF;STICKLINE(中短>短线,短线,中短,0.1,1),LINETHICK1,colorFF00;DRAWTEXT(CROSS(短线,中短),中短-0.2,'↑'),colorFFFF;VAR11:=AMOUNT/VOL/100;VARA12:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;底部线:=SUM(AMOUNT,7)/VAR11/100;VAR1A:=DMA(VARA12,VOL/底部线);VAR1B:=(CLOSE-VAR1A)/VAR1A*100;VAR1C:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;V3:=MA(VAR1B,20)+STD(VAR1B,20);FD:=(CLOSE-MA(CLOSE,18))/MA(CLOSE,18)*100;K:=SMA(VAR1C,3,1);顶:STICKLINE(REF(FD,1)>=5 AND CROSS(V3,VAR1B) AND K>79,MA(CLOSE,25)*(1-6/100),MA(LOW,30)*(1-15/100),5,0);END;IF DD=6 THEN BEGINDRAWutf-8(DD=6,COLORRGB(665,155,155),COLORRGB(155,155,155),1);A5:MA(CLOSE,5);A10:MA(CLOSE,10);A20:MA(CLOSE,20);A30:MA(CLOSE,30);A60:MA(CLOSE,60);A120:MA(CLOSE,120);A250:MA(CLOSE,250);STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0),colorFF;STICKLINE(CLOSE>OPEN,LOW,HIGH,1,0),colorFF;STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,8,0),colorFF00;STICKLINE(CLOSE<=OPEN,LOW,HIGH,1,0),colorFF00;END;IF DD=7 THEN BEGINDRAWutf-8(DD=7,COLORRGB(1,50,50),COLORRGB(150,50,1),1);STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0),colorFF;STICKLINE(CLOSE>OPEN,LOW,HIGH,1,0),colorFF;STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,8,0),colorFF00;STICKLINE(CLOSE<=OPEN,LOW,HIGH,1,0),colorFF00;VAR1:=(CLOSE+LOW+HIGH)/3;VAR2:=EMA(VAR1,6);VAR3:=EMA(VAR2,5);VAR4:=EMA(VAR3,12);获利比例:=EMA(VAR4,5);获利卖出线:VAR3+2.488*STD(CLOSE,26),colorDD00;生命线:EMA(VAR3,30),POINTDOT,colorFF;势:EMA(VAR1,5),colorFFFFFF;STICKLINE(VAR2>=VAR3,VAR2,VAR3,0.1,0),LINETHICK2,color99FF;STICKLINE(VAR2<VAR3,VAR2,VAR3,0.1,0),LINETHICK2,colorFF0000;STICKLINE(VAR4>=获利比例,VAR4,获利比例,0.1,0),LINETHICK2,colorFF;STICKLINE(VAR4<获利比例,VAR4,获利比例,0.1,0),LINETHICK2,colorFF00;A3:=CROSS(VAR2,VAR3) AND CLOSE>OPEN;DRAWTEXT(A3,LOW*0.98,'☆'),colorFFFF;C3:=CROSS(VAR4,获利比例) AND CLOSE>OPEN;DRAWTEXT(C3,LOW*0.98,''),colorFFFFFF;DRAWICON(CLOSE>=生命线,生命线,10);DRAWICON(CLOSE<生命线,生命线,11);END;IF DD=8 THEN BEGINDRAWutf-8(DD=8,COLORRGB(255,255,5),COLORRGB(255,155,0),1);A:MA((HIGH+LOW+CLOSE)/3,8);B:MA((HIGH+LOW+CLOSE)/3,21);VAR1:=EMA((OPEN+CLOSE)/2,26);VAR2:=MA(COST(30),3);平均成本:MA(COST(50),3);VAR3:=MA(COST(80),3);VAR4:=(HIGH+LOW+CLOSE)/3;获利比例:=EMA((OPEN+HIGH+LOW+CLOSE)/4,233);VAR12:=获利比例+获利比例*6/100;严冬:STICKLINE(VAR4>0.1,HIGH,LOW,0.5,0),colorFFFF00;早春:STICKLINE(VAR4<平均成本 AND VAR4>B OR VAR4<获利比例 AND VAR4>B OR VAR4>B AND VAR1>B,HIGH,LOW,0.5,0),colorFF00;初夏:STICKLINE(VAR4>平均成本 AND VAR4>VAR1 AND VAR4>获利比例 AND VAR2>REF(VAR2,1) OR VAR4>VAR2 AND VAR4>VAR1 AND VAR4>获利比例 AND VAR2>REF(VAR2,1),HIGH,LOW,0.5,0),colorFF00FF;深秋:STICKLINE(VAR4>VAR12 AND VAR4>VAR3 AND A>B AND VAR1>REF(VAR1,1),HIGH,LOW,0.5,0),colorFF;STICKLINE(VAR4>0.1 AND CLOSE<OPEN,OPEN,CLOSE,8,0),colorFFFF00;STICKLINE(VAR4>0.1 AND CLOSE>=OPEN,OPEN,CLOSE,8,1),colorFFFF00;STICKLINE(VAR4<平均成本 AND VAR4>B AND CLOSE<OPEN OR VAR4<获利比例 AND VAR4>B AND CLOSE<OPEN OR VAR4>B AND VAR1>B AND CLOSE<OPEN,OPEN,CLOSE,8,0),colorFF00;STICKLINE(VAR4<平均成本 AND VAR4>B AND CLOSE>OPEN OR VAR4<获利比例 AND VAR4>B AND CLOSE>OPEN OR VAR4>B AND VAR1>B AND CLOSE>=OPEN,OPEN,CLOSE,8,1),colorFF00;STICKLINE(VAR4>平均成本 AND VAR4>VAR1 AND VAR4>获利比例 AND VAR2>REF(VAR2,1) AND CLOSE<OPEN OR VAR4>VAR2 AND VAR4>VAR1 AND VAR4>获利比例 AND VAR2>REF(VAR2,1) AND CLOSE<OPEN,OPEN,CLOSE,8,0),colorFF00FF;STICKLINE(VAR4>平均成本 AND VAR4>VAR1 AND VAR4>获利比例 AND VAR2>REF(VAR2,1) AND CLOSE>OPEN OR VAR4>VAR2 AND VAR4>VAR1 AND VAR4>获利比例 AND VAR2>REF(VAR2,1) AND CLOSE>=OPEN,OPEN,CLOSE,8,1),colorFF00FF;STICKLINE(VAR4>VAR12 AND VAR4>VAR3 AND A>B AND VAR1>REF(VAR1,1) AND CLOSE<OPEN,OPEN,CLOSE,8,0),colorFF00FF;STICKLINE(VAR4>VAR12 AND VAR4>VAR3 AND A>B AND VAR1>REF(VAR1,1) AND CLOSE>=OPEN,OPEN,CLOSE,8,1),colorFF;END;IF DD=9 THEN BEGINDRAWutf-8(DD=9,COLORRGB(665,155,155),COLORRGB(155,155,155),1);DRAWutf-8(CLOSE<=OPEN,COLORRGB(10,160,0),COLORRGB(25,15,0),1);STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0),colorFF;STICKLINE(CLOSE>OPEN,LOW,HIGH,1,0),colorFF;STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,8,0),colorFF00;STICKLINE(CLOSE<=OPEN,LOW,HIGH,1,0),colorFF00;JJ:=(CLOSE+HIGH+LOW)/3;A:EMA(JJ,10);B:REF(A,1);终极黄金:STICKLINE(A>B,A,B,5,0),colorFFFF;一卸千里:STICKLINE(A<B,A,B,5,0),colorFFB97A;M1:EMA(CLOSE,3);M2:EMA(CLOSE,8);M3:EMA(M2,13);M4:EMA(M2,55);VAR1:=EMA(M3,55);M5:EMA(M4,81);M6:EMA(VAR1,144),colorFF;VAR2:=(REF(HIGH,1)+REF(LOW,1))/2;VAR3:=MA(CLOSE,20)+2*STD(CLOSE,20);DRAWICON(CROSS(VAR2,VAR3),HIGH*1.035,1);DRAWTEXT(CROSS(VAR2,VAR3),HIGH*1.02,'卖出1'),colorFF00;VAR4:=REF(CLOSE,1);获利比例:=(SMA(MAX(CLOSE-VAR4,0),7,1))/(SMA(ABS(CLOSE-VAR4),7,1))*100;VAR12:=CROSS(79,获利比例);OPEN1:=FILTER(VAR12,4);DRAWICON(OPEN1,HIGH*1.035,1);DRAWTEXT(OPEN1,HIGH*1.02,'卖出2'),colorFF00;OPEN3:=(2*CLOSE+HIGH+LOW)/4;VAR1D:=LLV(LOW,34);VAR16:=HHV(HIGH,34);OPEN2:=EMA((OPEN3-VAR1)/(VAR2-VAR1)*100,7);CLOSE1:=EMA(0.667*REF(OPEN2,1)+0.333*OPEN2,5);DRAWTEXT(IF((COUNT(CLOSE<REF(CLOSE,1),8))/8>6/10 AND VOL>=1.5*MA(VOL,5) AND COUNT(OPEN2>=CLOSE1,3) AND REF(LOW,1)=LLV(LOW,120),1,0),LOW,'●买进1'),color99FF;DRAWTEXT(IF((COUNT(CLOSE<REF(CLOSE,1),13))/13>6/10 AND COUNT(OPEN2>CLOSE1,6) AND REF(LOW,5)=LLV(LOW,120) AND REF(CLOSE>=OPEN,4) AND REF(CLOSE>OPEN,3) AND REF(CLOSE>OPEN,2) AND REF(OPEN>CLOSE,1) AND OPEN>REF(CLOSE,1),1,0),LOW,'●买进2'),colorFFFF;D:=MA(CLOSE,80)-MA(CLOSE,10)/3;DRAWTEXT(IF(CLOSE<D AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW,'●抄底'),colorFFFF;END;IF DD=10 THEN BEGINDRAWutf-8(DD>0,COLORRGB(1,777,666),COLORRGB(1,444,666),1);STICKLINE(OPEN>=CLOSE,OPEN,CLOSE,9,0),colorAAAAAA;STICKLINE(OPEN>=CLOSE,OPEN,CLOSE,6,0),colorBBBBBB;STICKLINE(OPEN>=CLOSE,OPEN,CLOSE,2.4,0),colorCCCCCC;STICKLINE(OPEN>=CLOSE,OPEN,CLOSE,1.1,0),colorDDDDDD;STICKLINE(CLOSE>OPEN,OPEN,CLOSE,9,0),color6666CC;STICKLINE(CLOSE>OPEN,OPEN,CLOSE,6,0),color7777DD;STICKLINE(CLOSE>OPEN,OPEN,CLOSE,2.4,0),color8888EE;STICKLINE(CLOSE>OPEN,OPEN,CLOSE,1.1,0),color9999FF;STICKLINE(CLOSE>OPEN,OPEN,LOW,0.5,0),color1199FF;STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.5,0),color1199FF;STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0.5,0),colorCCCCCC;STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0.5,0),colorCCCCCC;MID:MA(CLOSE,26),colorFF;UPPER:MID+2*STD(CLOSE,26),colorFF0000;LOWER:MID-2*STD(CLOSE,26),colorFFFF33;END;IF DD=11 THEN BEGINDRAWutf-8(DD=11,COLORRGB(665,155,155),COLORRGB(155,155,155),1);DRAWutf-8(CLOSE>0,COLORRGB(1,8888,8888),COLORRGB(1,3333,6666),3);VAR1:=(2*CLOSE+HIGH+LOW)/4*1;VAR4:=(2*CLOSE+HIGH+LOW)/4;成本:EMA(VAR4,90)*0.995,LINETHICK2,colorFF00;伏击:EMA(VAR4,142)*0.998,LINETHICK2,colorFF00FF;长底:EMA(VAR4,250)*0.885,LINETHICK2,colorFFFF;阻击:IF(DATE<1330608,EMA(VAR1,99)*0.91*1,3),LINETHICK2,colorFF;DRAWICON(CLOSE>=MA(CLOSE,55),MA(CLOSE,55),10);DRAWICON(CLOSE<MA(CLOSE,55),MA(CLOSE,55),11);CG:MA(CLOSE,17),colorFF00;FL3:HHV(CG,9),LINETHICK2,colorFF;FS3:IF(CG<FL3,CG-(FL3-CG),FL3),LINETHICK2,colorFF;A3:=MA(CLOSE,20);CLOSE3:=REF(A3,20/2+1);LIFE:(EMA(CLOSE,60)+EMA(CLOSE,90))/2,LINETHICK0;VAR1:=(2*CLOSE+HIGH+LOW)/4;SNOOK:EMA(VAR1,99)*0.91,LINETHICK0;STICKLINE(CLOSE>CLOSE3,HIGH,LOW,1,0),colorFFFF;STICKLINE(CLOSE>CLOSE3 AND CLOSE>=LIFE,OPEN,CLOSE,8,0),colorFF;STICKLINE(CLOSE>CLOSE3 AND CLOSE<=SNOOK,OPEN,CLOSE,8,0),color808080;STICKLINE(CLOSE>CLOSE3 AND CLOSE>SNOOK AND CLOSE<LIFE,OPEN,CLOSE,8,0),colorFF00FF;STICKLINE(CLOSE>CLOSE3,OPEN,CLOSE,2,0),colorFFFFFF;A3:=MA(CLOSE,20);CLOSE3:=REF(A3,20/2+1);LIFE1:(EMA(CLOSE,60)+EMA(CLOSE,90))/2,LINETHICK0,colorCC33FF;VAR1:=(2*CLOSE+HIGH+LOW)/4;SNOOK1:EMA(VAR1,99)*0.91,LINETHICK0,colorFF0000;STICKLINE(CLOSE<CLOSE3,HIGH,LOW,1,0),colorFFFF;STICKLINE(CLOSE<CLOSE3 AND CLOSE<=LIFE1,OPEN,CLOSE,8,0),colorFF0000;STICKLINE(CLOSE<CLOSE3 AND CLOSE>=SNOOK1,OPEN,CLOSE,8,0),colorFF00;STICKLINE(CLOSE<CLOSE3 AND CLOSE<SNOOK1 AND CLOSE>LIFE,OPEN,CLOSE,8,0),color808080;STICKLINE(CLOSE<CLOSE3,OPEN,CLOSE,2,0),colorFFFFFF;END;IF DD=12 THEN BEGINDRAWutf-8(DD=12,COLORRGB(665,155,155),COLORRGB(155,155,155),1);DRAWutf-8(CLOSE>0,COLORRGB(1,8888,8888),COLORRGB(1,3333,6666),3);CLOSE2:=MA(HIGH,3)*1.03;DFZD:=MA(LOW,3)*0.97;小通道上:FFT(CLOSE2,30);小通道下:FFT(DFZD,30);C3:=小通道上-REF(小通道上,1);短线2:=小通道下-REF(小通道下,1);PARTLINE(C3>0,小通道上),LINETHICK2,colorFF;PARTLINE(C3=0,小通道上),LINETHICK2,colorFFFFFF;PARTLINE(C3<0,小通道上),LINETHICK2,colorFFFF;PARTLINE(短线2>0,小通道下),LINETHICK2,colorFF;PARTLINE(短线2=0,小通道下),LINETHICK2,colorFFFFFF;PARTLINE(短线2<0,小通道下),LINETHICK2,colorFFFF;MID:MA(CLOSE,20),colorFF;WQS1:=(HIGH-LOW)/3;KFZD:=OPEN>WQS1*2+LOW;QSXS:=OPEN<WQS1+LOW;QSXX:=NOT(KFZD OR QSXS);WQS2:=CLOSE>WQS1*2+LOW;ZTDL:=CLOSE<WQS1+LOW;FTDL:=NOT(WQS2 OR ZTDL);ZTDL2:=WQS2 OR QSXS AND FTDL;FTDL2:=QSXX AND FTDL;MFI1:=NOT(ZTDL2 OR FTDL2);MFI2:=(HIGH+LOW)/2;ZMFI1:=MFI2>REF(HIGH,1);ZMFI2:=MFI2<REF(LOW,1);ZMFI:=NOT(ZMFI1 OR ZMFI2);FMFI:=VOL>REF(VOL,1)*1.1 OR AMOUNT>REF(AMOUNT,1)*1.5;ST:=VOL<REF(VOL,1)*0.7 OR AMOUNT<REF(AMOUNT,1)*0.5;WZ:=FMFI AND ST<1;QF:=ST AND FMFI<1;A4:=(HIGH-LOW)/(VOL/10000);C4:=(HIGH-LOW)/(AMOUNT/1000000);XHWZ1:=A4>REF(A4,1);XHWZ2:=C4>REF(C4,1);XHWZ3:=XHWZ1 OR XHWZ2;XHWZ4:=NOT(XHWZ3);LD:=WZ AND XHWZ3;S4:=QF AND XHWZ4;S5:=QF AND XHWZ3;S6:=WZ AND XHWZ4;A3:=REF(HIGH,2);C3:=FILTER(HHV(HIGH,5)=A3,2);短线2:=BACKSET(C3,3);S7:=IF(FILTER(短线2,2),HIGH,0);A5:SUM(S7,3);MA10:=REF(LOW,2);VARB:=FILTER(LLV(LOW,5)=MA10,2);VAR5:=BACKSET(VARB,3);覃华中国龙A:=IF(FILTER(VAR5,2),LOW,0);覃华中国龙B:=SUM(覃华中国龙A,3);覃华中国龙收盘价:=HIGH*1.003;四度空间SS01:=LOW*0.998;SS02:=IF(ZMFI2,四度空间SS01,IF(ZMFI1,覃华中国龙收盘价,IF(ZTDL2,覃华中国龙收盘价,四度空间SS01)));SS03:=IF(MFI2<REF(MFI2,1),四度空间SS01,覃华中国龙收盘价);SS04:=ZTDL2 AND ZMFI1;SS05:=MFI1 AND ZMFI2;SS06:=ZTDL2 AND ZMFI2;SS07:=MFI1 AND ZMFI1;SS08:=ZTDL2 AND ZMFI;SS09:=MFI1 AND ZMFI;SS10:=FTDL2 AND (ZMFI1 OR ZMFI2 OR ZMFI);STICKLINE(1,LOW,HIGH,0.5,0),colorFFFF;STICKLINE(SS05,CLOSE,OPEN,7,0),colorFF2020;STICKLINE(SS04,CLOSE,OPEN,7,0),color2020FF;STICKLINE(SS06,CLOSE,OPEN,7,0),colorFFFF;STICKLINE(SS07,CLOSE,OPEN,7,0),colorFFFF00;STICKLINE(SS08,CLOSE,OPEN,7,0),colorFF00FF;STICKLINE(SS09,CLOSE,OPEN,7,0),colorFF00;STICKLINE(SS10,CLOSE,OPEN,7,0),color808080;STICKLINE(1,CLOSE,OPEN,2,0),colorFFFFFF;STICKLINE(LD,SS02,SS02*0.999,3,0),colorFF00;STICKLINE(S4,SS02,SS02*0.999,3,0),colorFF00FF;STICKLINE(S5,SS02,SS02*0.999,3,0),colorFFFF;STICKLINE(S6,SS02,SS02*0.999,3,0),colorFF;STICKLINE(A5>0.1,A5,A5*1.0001,6,0);STICKLINE(覃华中国龙B>0.1,覃华中国龙B,覃华中国龙B*1.0001,6,0);VAR1:=(OPEN+LOW+HIGH+CLOSE)/4;支撑1:EMA(VAR1,5),colorFFFFFF;压力1:HHV(支撑1,13),colorCCCC00;压力2:HHV(支撑1,60),colorFF0000;支撑2:LLV(支撑1,13),colorFF00;支撑3:LLV(LOW,60)*1.02,colorFF;压力3:HHV(HIGH,60)*0.98,colorFF00;PARTLINE(支撑1>REF(支撑1,1),支撑1),LINETHICK2,colorFF;PARTLINE(支撑2>REF(支撑2,1),支撑2),LINETHICK1,colorFFFF;PARTLINE(压力1>REF(压力1,1),压力1),LINETHICK2,colorFF00FF;PARTLINE(压力2>REF(压力2,1),压力2),LINETHICK2,colorFFFF;PARTLINE(支撑2=REF(支撑2,1),支撑2),colorFF;PARTLINE(压力1=REF(压力1,1),压力1),colorFF;PARTLINE(压力2=REF(压力2,1),压力2),colorFF;PARTLINE(压力3=REF(压力3,1),压力3),colorFF;STICKLINE(1,VAR1,VAR1,6,0),colorFFFFFF;END;IF DD=13 THEN BEGINDRAWutf-8(DD=13,COLORRGB(665,155,155),COLORRGB(155,155,155),1);SS11:=EMA(CLOSE,48);SS12:=MA(CLOSE,8);SS13:=MA(CLOSE,8);STICKLINE(SS11>MA(CLOSE,8),SS11,MA(CLOSE,8),48,1),color8000;STICKLINE(SS11<MA(CLOSE,8),SS11,MA(CLOSE,8),48,1),colorFF;DRAWICON(CLOSE>=MA(CLOSE,55),MA(CLOSE,55),10);DRAWICON(CLOSE<MA(CLOSE,55),MA(CLOSE,55),11);SS14:=LOW;SS15:=HIGH;SS16:=TIME;SD01:=LOW;SD02:=LOW;SD03:=LOW;SD04:=LOW;SD05:=LOW;SD06:=LOW;SD07:=LOW;SD08:=LOW;SD09:=LOW;SD10:=LOW;SD11:=LOW;SD12:=LOW;SD13:=LOW;SD14:=LOW;SD15:=LOW;SD16:=LOW;AA1:=LOW;AA3:=LOW;ZZ:=LOW;RSV:=LOW;RSV12:=LOW;K12:=LOW;J12:=LOW;RSV24:=LOW;K24:=LOW;D24:=LOW;J24:=LOW;U2L:=LOW;L2L:=LOW;RH4:=HHV(HIGH,100);AA2:=HHV(HIGH,8);RH42:=(RH4-AA2)/10;STICKLINE(ISLASTBAR,AA2,AA2+RH42,12,0),color8888FF;DRAWTEXT(ISLASTBAR=1,AA2+RH42,'H');STICKLINE(ISLASTBAR,AA2+RH42,AA2+2*RH42,12,0),colorBBBBBB;DRAWTEXT(ISLASTBAR=1,AA2+2*RH42,'G'),colorFF;STICKLINE(ISLASTBAR,AA2+2*RH42,AA2+3*RH42,12,0),colorFF00FF;DRAWTEXT(ISLASTBAR=1,AA2+3*RH42,'F');STICKLINE(ISLASTBAR,AA2+3*RH42,AA2+4*RH42,12,0),colorFFFF;DRAWTEXT(ISLASTBAR=1,AA2+4*RH42,'E');STICKLINE(ISLASTBAR,AA2+4*RH42,AA2+5*RH42,12,0),colorFFBBFF;DRAWTEXT(ISLASTBAR=1,AA2+5*RH42,'D');STICKLINE(ISLASTBAR,AA2+5*RH42,AA2+6*RH42,12,0),color8800;DRAWTEXT(ISLASTBAR=1,AA2+6*RH42,'C'),colorFFBBFF;STICKLINE(ISLASTBAR,AA2+6*RH42,AA2+7*RH42,12,0),colorCCCC44;DRAWTEXT(ISLASTBAR=1,AA2+7*RH42,'B');STICKLINE(ISLASTBAR,AA2+7*RH42,AA2+8*RH42,12,0),colorFF;DRAWTEXT(ISLASTBAR=1,AA2+8*RH42,'A');STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,7,0),colorFF;STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,4,0),colorB0B0FF;STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,2,0),colorFFFF;STICKLINE(CLOSE>=OPEN,HIGH,LOW,0,0),colorFFFF;STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,7,0),colorFF2020;STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,4,0),colorFF6600;STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,2,0),colorFFFF00;STICKLINE(CLOSE<=OPEN,HIGH,LOW,0,0),colorFFFF00;END;IF DD=14 THEN BEGINDRAWutf-8(DD=14,COLORRGB(1,666,666),COLORRGB(1,222,444),1);STICKLINE(OPEN>=CLOSE,OPEN,CLOSE,9,0),colorAAAAAA;STICKLINE(OPEN>=CLOSE,OPEN,CLOSE,6,0),colorBBBBBB;STICKLINE(OPEN>=CLOSE,OPEN,CLOSE,2.4,0),colorCCCCCC;STICKLINE(OPEN>=CLOSE,OPEN,CLOSE,1.1,0),colorDDDDDD;STICKLINE(CLOSE>OPEN,OPEN,CLOSE,9,0),color6666CC;STICKLINE(CLOSE>OPEN,OPEN,CLOSE,6,0),color7777DD;STICKLINE(CLOSE>OPEN,OPEN,CLOSE,2.4,0),color8888EE;STICKLINE(CLOSE>OPEN,OPEN,CLOSE,1.1,0),color9999FF;STICKLINE(CLOSE>OPEN,OPEN,LOW,0.5,0),color1199FF;STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.5,0),color1199FF;STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0.5,0),colorCCCCCC;STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0.5,0),colorCCCCCC;LL:SYSPARAM(5),colorFF00;HH:SYSPARAM(4),colorFF0000;RL1:=SYSPARAM(3);LL+(HH-LL)*0.875,colorFF0000;LL+(HH-LL)*0.75,colorFF0000;LL+(HH-LL)*0.667,colorFF0000;LL+(HH-LL)*0.625,colorFF0000;LL+(HH-LL)*0.5,colorFFFFFF;LL+(HH-LL)*0.375,colorFF00;LL+(HH-LL)*0.333,colorFF00;LL+(HH-LL)*0.25,colorFF00;LL+(HH-LL)*0.125,colorFF00;DRAWNUMBER(SYSPARAM(3)=BARPOS,HH,HH,2),ALIGN2,colorFFFF;DRAWNUMBER(SYSPARAM(3)=BARPOS,LL+(HH-LL)*0.875,LL+(HH-LL)*0.875,2),ALIGN2,colorFFFF;DRAWNUMBER(SYSPARAM(3)=BARPOS,LL+(HH-LL)*0.75,LL+(HH-LL)*0.75,2),ALIGN2,colorFFFF;DRAWNUMBER(SYSPARAM(3)=BARPOS,LL+(HH-LL)*0.667,LL+(HH-LL)*0.667,2),ALIGN2,colorFFFF;DRAWNUMBER(SYSPARAM(3)=BARPOS,LL+(HH-LL)*0.625,LL+(HH-LL)*0.625,2),ALIGN2,colorFFFF;DRAWNUMBER(SYSPARAM(3)=BARPOS,LL+(HH-LL)*0.5,LL+(HH-LL)*0.5,2),ALIGN2,colorFFFF;DRAWNUMBER(SYSPARAM(3)=BARPOS,LL+(HH-LL)*0.375,LL+(HH-LL)*0.375,2),ALIGN2,colorFFFF;DRAWNUMBER(SYSPARAM(3)=BARPOS,LL+(HH-LL)*0.333,LL+(HH-LL)*0.333,2),ALIGN2,colorFFFF;DRAWNUMBER(SYSPARAM(3)=BARPOS,LL+(HH-LL)*0.25,LL+(HH-LL)*0.25,2),ALIGN2,colorFFFF;DRAWNUMBER(SYSPARAM(3)=BARPOS,LL+(HH-LL)*0.125,LL+(HH-LL)*0.125,2),ALIGN2,colorFFFF;DRAWNUMBER(SYSPARAM(3)=BARPOS,LL,LL,2),ALIGN2,colorFFFF;DRAWTEXT(SYSPARAM(2)=BARPOS,HH,'100%'),ALIGN1,colorFFFF;DRAWTEXT(SYSPARAM(2)=BARPOS,LL+(HH-LL)*0.825,'82.5%'),ALIGN1,colorFFFF;DRAWTEXT(SYSPARAM(2)=BARPOS,LL+(HH-LL)*0.75,'75.0%'),ALIGN1,colorFFFF;DRAWTEXT(SYSPARAM(2)=BARPOS,LL+(HH-LL)*0.667,'66.7%'),ALIGN1,colorFFFF;DRAWTEXT(SYSPARAM(2)=BARPOS,LL+(HH-LL)*0.625,'62.5%'),ALIGN1,colorFFFF;DRAWTEXT(SYSPARAM(2)=BARPOS,LL+(HH-LL)*0.5,'50.0%'),ALIGN1,colorFFFF;DRAWTEXT(SYSPARAM(2)=BARPOS,LL+(HH-LL)*0.375,'37.5%'),ALIGN1,colorFFFF;DRAWTEXT(SYSPARAM(2)=BARPOS,LL+(HH-LL)*0.333,'33.3%'),ALIGN1,colorFFFF;DRAWTEXT(SYSPARAM(2)=BARPOS,LL+(HH-LL)*0.25,'25.0%'),ALIGN1,colorFFFF;DRAWTEXT(SYSPARAM(2)=BARPOS,LL+(HH-LL)*0.125,'12.5%'),ALIGN1,colorFFFF;DRAWTEXT(SYSPARAM(2)=BARPOS,LL,'0%'),ALIGN1,colorFFFF;END;IF DD=15 THEN BEGINDRAWutf-8(CLOSE>0,COLORRGB(1,8888,8888),COLORRGB(1,3333,6666),3);STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0),colorFF;STICKLINE(CLOSE>OPEN,LOW,HIGH,1,0),colorFF;STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,8,0),colorFF00;STICKLINE(CLOSE<=OPEN,LOW,HIGH,1,0),colorFF00;RL4:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;K:=SMA(RL4,3,1);D:=SMA(K,3,1);J:=3*K-2*D;RL42:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;CD:=SMA(RL42,3,1);DIFF1:=SMA(CD,3,1);DEA1:=3*CD-2*DIFF1;RSV1:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;RSV2:=SMA(RSV1,3,1);RSVK:=SMA(RSV2,3,1);RSVD:=3*RSV2-2*RSVK;支撑位:IF(CROSS(J,RSVD),LOW,REF(LOW,BARSLAST(CROSS(J,RSVD)))),LINETHICK2,colorFFFF;压力位:IF(CROSS(RSVD,J),HIGH,REF(HIGH,BARSLAST(CROSS(RSVD,J)))),LINETHICK2,colorFF;RSVJ:=IF(CLOSE>=MA(CLOSE,20),80,50);VARQS222:=IF(CLOSE>=MA(CLOSE,20),50,20);VARQS223:=IF(J<RSVJ AND REF(J,1)>=RSVJ,HHV(REF(HIGH,1),BARSLAST(J>=RSVJ AND REF(J,1)<RSVJ)-1),REF(HHV(REF(HIGH,1),BARSLAST(J>=RSVJ AND REF(J,1)<RSVJ)-1),BARSLAST(J<RSVJ AND REF(J,1))));VARQS224:=IF(HIGH>VARQS223,LOW,REF(LOW,BARSLAST(HIGH>VARQS223)));VARQS225:=IF(HIGH>VARQS223,J,REF(J,BARSLAST(HIGH>VARQS223)));RH5:IF(HIGH>VARQS224 AND J<VARQS225 AND J<RSVD,HIGH,REF(HIGH,BARSLAST(HIGH>VARQS224 AND J<VARQS225 AND J<RSVD))),colorAAFF00;VARQS226:=IF(J>VARQS222 AND REF(J,1)<=VARQS222,LLV(REF(LOW,1),BARSLAST(J<=VARQS222 AND REF(J,1)>VARQS222)-1),REF(LLV(REF(LOW,1),BARSLAST(J<=VARQS222 AND REF(J,1)>VARQS222)-1),BARSLAST(J>VARQS222 AND REF(J,1))));VARQS227:=IF(LOW<VARQS226,HIGH,REF(HIGH,BARSLAST(LOW<VARQS226)));VARQS228:=IF(LOW<VARQS226,J,REF(J,BARSLAST(LOW<VARQS226)));RL5:IF(LOW<VARQS227 AND J>VARQS228 AND J>RSVD,LOW,REF(LOW,BARSLAST(LOW<VARQS227 AND J>VARQS228 AND J>RSVD))),colorF00FF0;VAR10:=AMOUNT/VOL/100;VARQS229:=VAR10>HIGH OR VAR10<LOW;END;IF DD=16 THEN BEGINDRAWutf-8(CLOSE>0,COLORRGB(1,8888,8888),COLORRGB(1,3333,6666),3);STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,7,0),colorFF;STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,4,0),colorB0B0FF;STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,2,0),colorFFFF;STICKLINE(CLOSE>=OPEN,HIGH,LOW,0,0),colorFFFF;STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,7,0),colorFF2020;STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,4,0),colorFF6600;STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,2,0),colorFFFF00;STICKLINE(CLOSE<=OPEN,HIGH,LOW,0,0),colorFFFF00;VARQS230:=EMA(CLOSE,4)-EMA(CLOSE,10);VARQS231:=EMA(VARQS230,5);DIFF:VARQS230*4.5+EMA(CLOSE,4)*0.85,colorFFFFFF;DEA:VARQS231*4.5+EMA(CLOSE,5)*0.85,colorFFFF;STICKLINE(DIFF>DEA,DIFF,DEA,3,0),colorFF;UPPERL:MA(HIGH,30)*1.13,colorFF00FF;UPPERS:MA(HIGH,5)*1.03,colorFF00;LOWERS:MA(LOW,5)*0.97,colorFF9900;LOWERL:MA(LOW,30)*0.85,colorFFFF00;END;IF DD=17 THEN BEGINDRAWutf-8(CLOSE>0,COLORRGB(1,6666,6666),COLORRGB(1,2222,4444),3);UPPERL:MA(HIGH,30)*1.13,colorFF00FF;LOWERL:MA(LOW,30)*0.85,colorFFFF00;UPPERS:MA(HIGH,5)*1.03,colorFF00;LOWERS:MA(LOW,5)*0.97,colorFF9900;VARQS232:=(CLOSE-LLV(LOW,6))/(HHV(HIGH,6)-LLV(LOW,6));VARQS233:=(VARQS232-0.5)/5*EMA(CLOSE,20);VARQS234:=SMA(VARQS233,3,1);VARQS235:=SMA(VARQS234,3,1);VARQS236:=VARQS234*3-VARQS235*2;K:VARQS234+EMA(CLOSE,20),colorFFFFFF;D:VARQS235+EMA(CLOSE,20),colorFFFF;J:VARQS236+EMA(CLOSE,20),colorFF00FF;STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,7,0),colorFF;STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,4,0),colorB0B0FF;STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,2,0),colorFFFF;STICKLINE(CLOSE>=OPEN,HIGH,LOW,0,0),colorFFFF;STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,7,0),colorFF2020;STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,4,0),colorFF6600;STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,2,0),colorFFFF00;STICKLINE(CLOSE<=OPEN,HIGH,LOW,0,0),colorFFFF00;END;
{程序化交易 www.grahamobil.com }

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  有需要帮忙请点击这里留言!!!进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容