[求助]帮忙修改公式-365bet送体验金财经知识 -程序化交易(grahamobil.com) - 365bet送体验金

365bet送体验金

  • 咨询内容: [求助]老师帮忙修改公式:应用在365bet送体验金财经软件,要求:背景图和K线使用365bet送体验金财经背景图和K线颜色,谢谢
     公式效果图:

    .公式源码

    N:=107;

    {背景}

    DRAWutf-8(O>0,RGB(33,47,58),RGB(0,0,0),0,༾#39,0);

    高:REFDATE(HHV(H,N),DATE); 

    低:REFDATE(LLV(L,N),DATE);

    H1:=高-(高-低)*1.000;

    H2:=高-(高-低)*0.875;

    H3:=高-(高-低)*0.750;

    H4:=高-(高-低)*0.666;

    H5:=高-(高-低)*0.625;

    H6:=高-(高-低)*0.500;

    H7:=高-(高-低)*0.375;

    H8:=高-(高-低)*0.333;

    H9:=高-(高-低)*0.250;

    H10:=高-(高-低)*0.125;

    H11:=高-(高-低)*0.000;

    STICKLINE(CURRBARSCOUNT=15,高,高,100,1),COLORGREEN;

    STICKLINE(CURRBARSCOUNT=15,H1,H1,100,1),COLORCYAN;

    STICKLINE(CURRBARSCOUNT=15,H2,H2,100,1),COLORRED;

    DRAWTEXT(CURRBARSCOUNT=2,H1,Ɔ000',COLORCYAN;

    DRAWTEXT(CURRBARSCOUNT=2,H2,Ɔ125 ┄ 1/8',COLORMAGENTA;

    DRAWTEXT(CURRBARSCOUNT=2,H3,'0.25 ┄ 1/4',COLORGREEN;

    DRAWTEXT(CURRBARSCOUNT=2,H4,'0.333┄ 1/3',COLOR808080;

    DRAWTEXT(CURRBARSCOUNT=2,H5,'0.375┄ 3/8',COLOR808080;

    DRAWTEXT(CURRBARSCOUNT=2,H6,'0.50┄ 1/2',COLORMAGENTA;

    DRAWTEXT(CURRBARSCOUNT=2,H7,'0.625┄ 5/8',COLOR808080;

    DRAWTEXT(CURRBARSCOUNT=2,H8,'0.666┄2/3',COLOR808080;

    DRAWTEXT(CURRBARSCOUNT=2,H9,'0.75┄ 3/4',COLORGREEN;

    DRAWTEXT(CURRBARSCOUNT=2,H10,'0.875┄ 7/8',COLORMAGENTA;

    DRAWTEXT(CURRBARSCOUNT=2,H11,'1.000',COLORGREEN;

    {比例坐标}

    STICKLINE(CURRBARSCOUNT=15,H3,H3,100,1),COLORGREEN;

    STICKLINE(CURRBARSCOUNT=15,H4,H4,100,1),COLOR808080;

    STICKLINE(CURRBARSCOUNT=15,H6,H6,100,1),COLORGREEN;

    STICKLINE(CURRBARSCOUNT=15,H5,H5,100,1),COLOR808080;

    STICKLINE(CURRBARSCOUNT=15,低,低,100,1),COLORRED;

    STICKLINE(CURRBARSCOUNT=15,H7,H7,100,1),COLOR808080;

    STICKLINE(CURRBARSCOUNT=15,H8,H8,100,1),COLOR808080;

    STICKLINE(CURRBARSCOUNT=15,H9,H9,100,1),COLORGREEN;

    STICKLINE(CURRBARSCOUNT=15,H10,H10,100,1),COLORRED;

    {价格坐标}

    DRAWTEXT(CURRBARSCOUNT=30,高*0.997,CON2STR(高,2)),COLORGREEN;

    DRAWTEXT(CURRBARSCOUNT=30,H10,CON2STR(H10,2)),COLORLIRED;

    DRAWTEXT(CURRBARSCOUNT=30,H9,CON2STR(H9,2)),COLORMAGENTA;

    DRAWTEXT(CURRBARSCOUNT=30,H8,CON2STR(H8,2)),COLORRED;

    DRAWTEXT(CURRBARSCOUNT=30,H1,CON2STR(H1,2)),COLORCYAN;

    DRAWTEXT(CURRBARSCOUNT=30,H2,CON2STR(H2,2)),COLORRED;

    DRAWTEXT(CURRBARSCOUNT=30,H3,CON2STR(H3,2)),COLORYELLOW;

    DRAWTEXT(CURRBARSCOUNT=30,H6,CON2STR(H6,2)),COLORGREEN;

    DRAWTEXT(CURRBARSCOUNT=30,H4,CON2STR(H4,2)),COLORLIRED;

    DRAWTEXT(CURRBARSCOUNT=30,H5,CON2STR(H5,2)),COLORMAGENTA;

    DRAWTEXT(CURRBARSCOUNT=30,H7,CON2STR(H7,2)),COLORRED;

    DRAWTEXT(CURRBARSCOUNT=30,低*1.00,CON2STR(低,2)),COLORGREEN;

    {变色K线}

    STICKLINE(C>REF(C,1),H,L,0,0),COLOR0099FF;

    STICKLINE(C>REF(C,1),C,O,3.2,0),COLOR0000AA;

    STICKLINE(C>REF(C,1),C,O,2.7,0),COLOR0000DD;

    STICKLINE(C>REF(C,1),C,O,2.1,0),COLOR0022FF;

    STICKLINE(C>REF(C,1),C,O,1.5,0),COLOR0066FF;

    STICKLINE(C>REF(C,1),C,O,0.9,0),COLOR0099FF;

    STICKLINE(C>REF(C,1),C,O,0.3,0),COLOR00DDFF;

    STICKLINE(C

    STICKLINE(C

    STICKLINE(C

    STICKLINE(C

    STICKLINE(C

    STICKLINE(C

    STICKLINE(C

    STICKLINE(C=REF(C,1),H,L,0,1),COLORFFFFFF;

    STICKLINE(C=REF(C,1),C,O,3.2,0),COLOR555555;

    STICKLINE(C=REF(C,1),C,O,2.7,0),COLOR777777; 

    STICKLINE(C=REF(C,1),C,O,2.1,0),COLOR999999;

    STICKLINE(C=REF(C,1),C,O,1.5,0),COLORBBBBBB;

    STICKLINE(C=REF(C,1),C,O,0.9,0),COLORDDDDDD;

    STICKLINE(C=REF(C,1),C,O,0.3,0),COLORFFFFFF;

     

     来源:程序化99

  • 365bet送体验金技术人员: 不同软件的函数编写机制不同,改写后可能会存在细微的效果差异,这个是正常的,
    另外,您指标中含不支持修改的函数,CON2STR 函数, 其余部分给您修改了一下,请参考:  

    N:=107;

    //{背景}

    DRAWutf-8(O>0,RGB(33,47,58),RGB(0,0,0),0);

    高:REFX1(HHV(H,N),10000);

    低:REFX1(LLV(L,N),10000);

    H1:=高-(高-低)*1.000;

    H2:=高-(高-低)*0.875;

    H3:=高-(高-低)*0.750;

    H4:=高-(高-低)*0.666;

    H5:=高-(高-低)*0.625;

    H6:=高-(高-低)*0.500;

    H7:=高-(高-低)*0.375;

    H8:=高-(高-低)*0.333;

    H9:=高-(高-低)*0.250;

    H10:=高-(高-低)*0.125;

    H11:=高-(高-低)*0.000;
    CURRBARSCOUNT:=DATACOUNT-BARPOS+1;
    STICKLINE(CURRBARSCOUNT=15,高,高,100,1),COLORGREEN;

    STICKLINE(CURRBARSCOUNT=15,H1,H1,100,1),COLORCYAN;

    STICKLINE(CURRBARSCOUNT=15,H2,H2,100,1),COLORRED;

    DRAWTEXT(CURRBARSCOUNT=2,H1,'000'),COLORCYAN;

    DRAWTEXT(CURRBARSCOUNT=2,H2,'125 ┄ 1/8'),COLORMAGENTA;

    DRAWTEXT(CURRBARSCOUNT=2,H3,'0.25 ┄ 1/4'),COLORGREEN;

    DRAWTEXT(CURRBARSCOUNT=2,H4,'0.333┄ 1/3'),COLOR808080;

    DRAWTEXT(CURRBARSCOUNT=2,H5,'0.375┄ 3/8'),COLOR808080;

    DRAWTEXT(CURRBARSCOUNT=2,H6,'0.50┄ 1/2'),COLORMAGENTA;

    DRAWTEXT(CURRBARSCOUNT=2,H7,' 0.625┄ 5/8'),COLOR808080;

    DRAWTEXT(CURRBARSCOUNT=2,H8,' 0.666┄2/3'),COLOR808080;

    DRAWTEXT(CURRBARSCOUNT=2,H9,' 0.75┄ 3/4'),COLORGREEN;

    DRAWTEXT(CURRBARSCOUNT=2,H10,' 0.875┄ 7/8'),COLORMAGENTA;

    DRAWTEXT(CURRBARSCOUNT=2,H11,' 1.000'),COLORGREEN;


    STICKLINE(CURRBARSCOUNT=15,H3,H3,100,1),COLORGREEN;

    STICKLINE(CURRBARSCOUNT=15,H4,H4,100,1),COLOR808080;

    STICKLINE(CURRBARSCOUNT=15,H6,H6,100,1),COLORGREEN;

    STICKLINE(CURRBARSCOUNT=15,H5,H5,100,1),COLOR808080;

    STICKLINE(CURRBARSCOUNT=15,低,低,100,1),COLORRED;

    STICKLINE(CURRBARSCOUNT=15,H7,H7,100,1),COLOR808080;

    STICKLINE(CURRBARSCOUNT=15,H8,H8,100,1),COLOR808080;

    STICKLINE(CURRBARSCOUNT=15,H9,H9,100,1),COLORGREEN;

    STICKLINE(CURRBARSCOUNT=15,H10,H10,100,1),COLORRED;

    //{价格坐标}

    /*DRAWTEXT(CURRBARSCOUNT=30,高*0.997,CON2STR(高,2)),COLORGREEN;

    DRAWTEXT(CURRBARSCOUNT=30,H10,CON2STR(H10,2)),COLORLIRED;

    DRAWTEXT(CURRBARSCOUNT=30,H9,CON2STR(H9,2)),COLORMAGENTA;

    DRAWTEXT(CURRBARSCOUNT=30,H8,CON2STR(H8,2)),COLORRED;

    DRAWTEXT(CURRBARSCOUNT=30,H1,CON2STR(H1,2)),COLORCYAN;

    DRAWTEXT(CURRBARSCOUNT=30,H2,CON2STR(H2,2)),COLORRED;

    DRAWTEXT(CURRBARSCOUNT=30,H3,CON2STR(H3,2)),COLORYELLOW;

    DRAWTEXT(CURRBARSCOUNT=30,H6,CON2STR(H6,2)),COLORGREEN;

    DRAWTEXT(CURRBARSCOUNT=30,H4,CON2STR(H4,2)),COLORLIRED;

    DRAWTEXT(CURRBARSCOUNT=30,H5,CON2STR(H5,2)),COLORMAGENTA;

    DRAWTEXT(CURRBARSCOUNT=30,H7,CON2STR(H7,2)),COLORRED;

    DRAWTEXT(CURRBARSCOUNT=30,低*1.00,CON2STR(低,2)),COLORGREEN;
    */

     

    STICKLINE1(C>REF(C,1),H,L,0,0),COLOR0099FF;

    STICKLINE1(C>REF(C,1),C,O,3.2,0),COLOR0000AA;

    STICKLINE1(C>REF(C,1),C,O,2.7,0),COLOR0000DD;

    STICKLINE1(C>REF(C,1),C,O,2.1,0),COLOR0022FF;

    STICKLINE1(C>REF(C,1),C,O,1.5,0),COLOR0066FF;

    STICKLINE1(C>REF(C,1),C,O,0.9,0),COLOR0099FF;

    STICKLINE1(C>REF(C,1),C,O,0.3,0),COLOR00DDFF;

    STICKLINE1(C=REF(C,1),H,L,0,1),COLORFFFFFF;

    STICKLINE(C=REF(C,1),C,O,3.2,0),COLOR555555;

    STICKLINE1(C=REF(C,1),C,O,2.7,0),COLOR777777;

    STICKLINE1(C=REF(C,1),C,O,2.1,0),COLOR999999;

    STICKLINE1(C=REF(C,1),C,O,1.5,0),COLORBBBBBB;

    STICKLINE1(C=REF(C,1),C,O,0.9,0),COLORDDDDDD;

    STICKLINE1(C=REF(C,1),C,O,0.3,0),COLORFFFFFF;

     

     

     来源: WWW.CXH99.COM

  • 365bet送体验金客服:  谢谢,老师

     

  • 网友回复:  老师:再次麻烦你,语法检测 第21行,是无法识别的类型


    文件名:qq截图20180615135634.png

     

  • 网友回复:

    重新拷贝下2楼的源码,

     

    单引号在拷贝的过程中乱码了

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  点击这里给我发消息进行 有偿 编写!不贵!点击查看价格!


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容