Shy 请帮忙改下这个指标,谢谢-博易大师知识 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 期货公式>> 博易大师>> 博易大师知识>>正文内容

365bet送体验金

咨询内容:

Shy 请帮忙改下这个指标,谢谢

J1:MA(C,7),colorwhite;
J2:MA(C,21);
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
DRAWICON(B1>0,L-0.20,5);
DRAWTEXT(B1,L-0.30,'MACD底背'),colorwhite;
DRAWICON(B2>0,L-0.20,4);
DRAWTEXT(B2,L-0.30,'KDJ底背'),COLORFF00FF;
DRAWICON(B3>0,L-0.20,3);
DRAWTEXT(B3,L-0.30,'RSI底背'),coloryellow;
DRAWICON(CROSS(DIFF,DEA) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),L-0.20,6);
DRAWTEXT(CROSS(DIFF,DEA) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),L-0.30,'金叉共振'),COLOR0099FF;

 

 来源:程序化99网( WWW.grahamobil.com )

博易技术人员: 如果在博易云上运行,则只需要在费用指标结果时,采用STKINDI函数就好
 
STKINDI(Code,Period,'IDX.LINE',P1,P2,…) 
引用指定品种的IDX指标的LINE输出结果。 
Code为品种代码,当代码为常量时,可以动态更新该品种数据,否则只能使用本地最近保存的数据。
Period为周期类型,取值参考DATAPERIOD;
IDX为指标名称,LINE为指定输出,可以省略,默认引用第一条输出;
P1之后为指标参数,最多16个,可以省略,默认使用指标公式对应周期的参数。
当Code=''时引用当前品种,Period=0时引用当前周期类型。  
例如:
 STKINDI('',0,'MACD'),表示引用当前品种当前周期MACD指标的DIF输出。
 STKINDI('600000.SH',8,'MA.MA1',5,20,40),表示引用浦发银行的日线MA指标的MA1输出,指标前三个参数分别为5、20、40,其余参数使用系统设置值。 你能够直接帮我改下上面指标吗,我不会的,错误指向KDJ.K RSI.RSI1 RSI.RSI2这些,谢谢 来源 程序化久久网

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  点击这里给我发消息进行 有偿 编写!不贵!点击查看价格!


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容