牛年好运牛运趋势线指标公式-其他软件公式 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 股票公式>> 其他>> 其他软件公式>>正文内容

365bet送体验金

相关标签:macd指标公式 、 量比指标公式 、 短线指标公式 、 成交量指标公式 、 换手率指标公式 、 分时指标公式 、 365bet送体验金指标公式 、 金蜘蛛指标公式 、 麟龙指标公式 、 波段指标公式 、 趋势指标公式 、

 

 

原理解析:


 

 来源:程序化99( WWW.grahamobil.com )

源码:

 

{牛年好运}
A:=AMOUNT/V/100;
VARA:=EMA((((A-EMA(A,13))/EMA(A,13))*(0-100)),5);
操盘线:=EMA(((VARA/10)+EMA(A,10)),3);行情线:=EMA(A,3);
重心:=(C+0.618*REF(C,1)+0.382*REF(C,2)+0.236*REF(C,3)+0.146*REF(C,4))/2.382;
趋势线:=EMA(((SLOPE(C,22)*20)+C),55),COLORYELLOW,LINETHICK2;
红升:DRAWICON(重心>=趋势线,趋势线,10),COLORRED,LINETHICK2;
蓝降:DRAWICON(重心<趋势线,趋势线,11),COLORBLUE,LINETHICK2;
持股线:=EMA(CLOSE,26),Colorff00ff,LINETHICK2;
Var1:=(4*CLOSE+HIGH+LOW)/6;
Var2:=LLV(LOW,34);
Var3:=HHV(HIGH,34);
dif:= EMA((Var1-Var2)/(Var3-Var2)*100,13);
dea:= EMA(0.667*REF(dif,1)+0.333*dif,2);
多头:STICKLINE(dif>dea,CLOSE,OPEN,8,0),color0000ff;
STICKLINE(dif>dea,HIGH,LOW,0,0),color0000ff;
空头:STICKLINE(dif<=dea,CLOSE,OPEN,8,0),color00ff00;
STICKLINE(dif<=dea,HIGH,LOW,0,0),color00ff00;
关注:STICKLINE(dif>dea and c<持股线,CLOSE,OPEN,8,0),color00ffff;
STICKLINE(dif>dea and c<持股线,HIGH,LOW,0,0),color00ffff;
回踩:STICKLINE(dif<dea and c>持股线,CLOSE,OPEN,8,0),colorff0066;
STICKLINE(dif<dea and c>持股线,HIGH,LOW,0,0),colorff0066;
压力:MA(REF(HHV(C,30),1),2),COLOR9DFFFF;
支撑:MA(REF(LLV(C,30),1),2),COLORABFF46;LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
抓大牛:=CROSS(RSI,11);
DRAWTEXT(抓大牛,L-0.3,'抓大牛'),COLORRED;
VAR7:=EMA(AMOUNT/VOL/100,3);
VAR8:=EMA(VAR7,88);
VAR9:=EMA(VAR7,88)*0.85;
VARA:=VAR9*0.87;
VARB:=LOW<VARA AND CLOSE>REF(CLOSE,1)*1.02;
DRAWTEXT(FILTER(VARB,6),L-0.05,'牛动'),COLORFF00FF;
VARF:=(2*CLOSE+HIGH+LOW)/4;
VA4:=LLV(LOW,34);
VA5:=HHV(HIGH,34);
VA6:=EMA((VARF-VA4)/(VA5-VA4)*100,6);
VA7:=EMA(0.667*REF(VA6,1)+0.333*VA6,4);
DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(VA6>VA7,3) AND REF(LOW,1)=LLV(LOW,120) AND
CLOSE>OPEN,1,0),L-0.05,'牛好运'),COLORYELLOW;
A:=(3*CLOSE+LOW+OPEN+HIGH)/6;
D1:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)
+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/211;
D2:=EMA(D1,2);
D3:=EMA(D2,2);
K1:=EMA(D3,2);
DRAWTEXT(CROSS(D1,K1),L-0.05,'牛买入'),COLOR0099FF;
多方趋势:=7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)
-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
,3,1),2,1);
天线:=78.89;
DRAWTEXT(CROSS(天线,多方趋势),H*1.01,'牛回头'),COLOR00FF00;A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
牛运线:=EMA(A51,5);A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
趋势线:=(MA(3*SMA(A54,6,1)-2*SMA(SMA(A54,5,1),5,1),2));
DRAWTEXT(CROSS(趋势线,0)AND 牛运线<40,(HIGH*0.97),'▲牛起'),COLORYELLOW;

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  有需要帮忙请点击这里留言!!!进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容