家红MACD副图指标公式源码-同花顺公式 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 股票公式>> 同花顺>> 同花顺公式>>正文内容

365bet送体验金

相关标签:macd背离指标公式源码 、 富力macd副图指标公式 、 同花顺主图指标源码 、 红黄柱线副图指标源码 、 同花顺主图公式源码 、 同花顺macd背离公式 、 同花顺变色macd公式 、 同花顺macd计算公式 、 同花顺macd选股公式 、 同花顺macd公式大全 、 macd 指标 公式 源码 、 365bet送体验金macd指标公式源码 、 macd最优指标公式源码 、 超前macd指标公式源码 、

 

指标颜色提示进行买卖

 

 

原理解析:


 

 来源:程序化99( WWW.grahamobil.com )

源码:

 



DIFF:EMA(C,SHORT)-EMA(C,LONG);
DEA:EMA(DIFF,M);
MACD:=2*(DIFF-DEA);
STICKLINE(MACD>=0,0,MACD,4,0),colorred;
STICKLINE(MACD<=0,0,MACD,4,0),colorblue;
STICKLINE(MACD>=0 AND MACD<REF(MACD,1),0,MACD,4,0),color000088;
STICKLINE(MACD<=0 AND MACD>REF(MACD,1),0,MACD,4,0),colorcyan;
VAR1:=(C-EMA(C,6))/EMA(C,6)*100;
VAR2:=(C-MA(C,24))/MA(C,24)*100;
VAR3:=(C-MA(C,32))/MA(C,32)*100;
VAR4:=(VAR1+VAR2+VAR3)/3;
KX:=EMA(VAR4,3);
DX:=EMA(KX,3);
MCD:=EMA(EMA(VAR1,3),3)*2;
VAR5:=EMA(100*(C-LLV(C,34))/(HHV(H,34)-LLV(L,34)),5)-20;
VAR8:=LLV(VAR5,3)<VAR5;
VAR9:=KX>DX AND DX<7;
必杀①:=VAR8>=1 AND VAR9 AND REF(KX<DX,1);
STICKLINE(必杀①,0,MACD/1.5,5,0),colorff00ff;
BN:=20;
C2:=MA(C,2);
MA20:=MA(C2,BN);
BOLL:=MA20;
UPPER:=BOLL+1.618*STD(C2,BN);
LOWER:=BOLL-1.618*STD(C2,BN);
AA:=CROSS(C2,LOWER);
STICKLINE(AA,0,MACD/3,6,0),color990066;
BB:=CROSS(UPPER,C2);
STICKLINE(BB,0,MACD/1.5,4,0),color226644;
V1:=MA(C,3)=HHV(MA(C,3),7);
V2:=MA(C,3)>MA(C,5);
V3:=MA(V,5)>MA(V,10)*1.01;
V4:=COUNT(MA(C,1)>REF(C,1),2)=2;
注意风险:=V1 AND V2 AND V3 AND V4;
STICKLINE(注意风险,0,MACD/1.3,4,0),color2299FF;
VAR4:=(LOW+HIGH+CLOSE)/3;
操作:=MA(VAR4,5);
A1:=EMA(C,14);
A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW;
STICKLINE(CROSS(A1X,0) AND C>=操作,0,MACD/10,10,0),colorFFFFFF;
工作线:=操作;
放心持股:IF(C>=工作线 AND EMA(C,14)>=EMA(C,25),DIFF,DRAWNULL), colorFF00FF,LINETHICK1;
TIPTEXT(ISNULL(REFX(&CLOSE,1)),0,' WWW.grahamobil.com '),colorred;
TIPTEXT(ISNULL(REF(CLOSE,1)),0,'同花顺程序化交易');

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 1145508240  点击这里给我发消息进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容