金兰十全十美版多指标公式综合看盘-其他软件公式 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 股票公式>> 其他>> 其他软件公式>>正文内容

365bet送体验金

相关标签:主图趋势看盘指标公式 、 智能看盘指标公式 、 飞狐指标公式 、 飞狐macd实战指标公式 、 飞狐筹码指标公式 、 飞狐高控盘指标公式 、 飞狐均线流指标公式 、 飞狐共振指标公式 、 飞狐指标公式分时主图 、 飞狐指标公式合集 、 飞狐财务指标公式 、 独家指标十全十美 、

 

{金兰十全十美 飞狐版 多指标综合看盘}

 

原理解析:


 

 来源:程序化99( WWW.grahamobil.com )

源码:

 


{N1:=3;N2:=5;N3:=8;N4:=13;N5:=21;N6:=34; }//这都不想输入
input:N1(3,1,100),N2(5,1,100),N3(9,1,100),N4(13,1,100),N5(21,1,100),
N6(34,1,100);
DIFF:=EMA(CLOSE,N3)-EMA(CLOSE,N4);
DEA:=EMA(DIFF,N2);
DRAWICON(DIFF>DEA,1,4);
DRAWICON(DIFF<DEA,1,5);
DRAWTEXT(ISLASTBAR=1,1,'.MACD'),COLORFFFFFF;
A1:=DIFF>DEA;
RSV1:=(CLOSE-LLV(LOW,N3))/(HHV(HIGH,N3)-LLV(LOW,N3))*100;
K:=SMA(RSV1,N1,1);
D:=SMA(K,N1,1);
DRAWICON(K>D,2,4);
DRAWICON(K<D,2,5);
DRAWTEXT(ISLASTBAR=1,2,'.KDJ'),COLORFFFFFF;
A2:=K>D;
LC:=REF(CLOSE,1);
RSI1:=(SMA(MAX(CLOSE-LC,0),N2,1))/(SMA(ABS(CLOSE-LC),N2,1))*100;
RSI2:=(SMA(MAX(CLOSE-LC,0),N4,1))/(SMA(ABS(CLOSE-LC),N4,1))*100;
DRAWICON(RSI1>RSI2,3,4);
DRAWICON(RSI1<RSI2,3,5);
DRAWTEXT(ISLASTBAR=1,3,'.RSI'),COLORFFFFFF;
A3:=RSI1>RSI2;
RSV:=-(HHV(HIGH,N4)-CLOSE)/(HHV(HIGH,N4)-LLV(LOW,N4))*100;
LWR1:=SMA(RSV,N1,1);
LWR2:=SMA(LWR1,N1,1);
DRAWICON(LWR1>LWR2,4,4);
DRAWICON(LWR1<LWR2,4,5);
DRAWTEXT(ISLASTBAR=1,4,'.LW&R'),COLORFFFFFF;
A4:=LWR1>LWR2;
BBI:=(MA(CLOSE,N1)+MA(CLOSE,N2)+MA(CLOSE,N3)+MA(CLOSE,N4))/4;
DRAWICON(CLOSE>BBI,5,4);
DRAWICON(CLOSE<BBI,5,5);
DRAWTEXT(ISLASTBAR=1,5,'.BBI'),COLORFFFFFF;
A5:=CLOSE>BBI;
MTM:=CLOSE-REF(CLOSE,1);
MMS:=100*EMA(EMA(MTM,N2),N1)/EMA(EMA(ABS(MTM),N2),N1);
MMM:=100*EMA(EMA(MTM,N4),N3)/EMA(EMA(ABS(MTM),N4),N3);
DRAWICON(MMS>MMM,6,4);
DRAWICON(MMS<MMM,6,5);
DRAWTEXT(ISLASTBAR=1,6,'.ZLMM'),COLORFFFFFF;
A6:=MMS>MMM;
BIAS:=(C-MA(C,N2))/MA(C,N2);
DIF:=(BIAS-REF(BIAS,16));
DBCD:=SMA(DIF,76,1);
MM:=MA(DBCD,5);
DRAWICON(DBCD>MM ,7,4);
DRAWICON(DBCD<MM,7,5);
DRAWTEXT(ISLASTBAR=1,7,'.DBCD'),COLORFFFFFF;
A7:=DBCD>MM;持股:3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK,COLORRED;
支撑:LLV(持股,3),LINETHICK,COLOR00FFFF;
下跌:MA(持股,12),COLOR6B8E23,LINETHICK;
转向:=CROSS(持股,下跌){ AND 下跌<30};
MA1:=MA(持股,5);
向下:=CROSS(MA1,持股) AND MA1>80;
DRAWICON(持股>下跌 ,8,4);
DRAWICON(持股<下跌,8,5);
DRAWTEXT(ISLASTBAR=1,8,'.CGZ'),COLORFFFFFF;
A8:=持股>下跌;
mtm:=c-ref(c,1);
ZLGJ:=100*ema(ema(mtm,N3),N3)/ema(ema(abs(mtm),N3),N3);
MAZL:=MA(ZLGJ,5);
DRAWICON(ZLGJ>MAZL,9,4);
DRAWICON(ZLGJ<MAZL,9,5);
A9:=ZLGJ>MAZL;
DRAWTEXT(ISLASTBAR=1,9,'.ZLGJ'),COLORFFFFFF;PJJ:=DMA((HIGH+LOW+CLOSE*2)/4,0.9);
JJ:=REF(EMA(PJJ,3),1);
QJJ:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
XVL:=IF(CLOSE>OPEN,QJJ*(HIGH-LOW),IF(CLOSE<OPEN,QJJ*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-QJJ*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-QJJ*(HIGH-LOW),0-VOL/2));
HSL:=(XVL/20)/1.15;
攻击流量:=((HSL*0.55+(REF(HSL,1)*0.33))+(REF(HSL,2)*0.22));
GJJ:=EMA(攻击流量,8);
LLJX:=EMA(攻击流量,3);
资金流量:LLJX,LINETHICK0,COLOR0000FF;
DRAWICON(资金流量>0,10,4);
DRAWICON(资金流量<0,10,5);
A10:=资金流量>0;
DRAWTEXT(ISLASTBAR=1,10,'.ZJL'),COLORFFFFFF;指导线:(A1+A2+A3+A4+A5+A6+A7+A8+A9+A10),linethick2,COLORFFFF00;
选股:IF(指导线 >6 ,1,0),linethick3,ColorFF00FF;{
(A1 AND A2 AND A3 AND A4 AND A5 AND A6 AND A7 AND A8 AND A9 AND A10),COLORFFFF00;
买入:A1 AND A2 AND A3 AND A4 AND A5 AND A6 AND A7 AND A8 AND A9 AND A10=1
AND REF(A1 AND A2 AND A3 AND A4 AND A5 AND A6 AND A7 AND A8 AND A9 AND A10,1)=0,COLORFFFF00;}

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  有需要帮忙请点击这里留言!!!进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容