楚河汉界 改编-其他软件公式 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 股票公式>> 其他>> 其他软件公式>>正文内容

365bet送体验金

相关标签:楚河汉界成语 、 象棋楚河汉界 、 楚河汉界论坛 、 楚河汉界游戏 、 楚河汉界图片 、 楚河汉界小说 、 楚河汉界在哪 、 楚河汉界粤语 、 楚河汉界歌曲 、 楚河汉界国语 、 楚河汉界主图指标公式 、

 

改编的[楚河汉界]。

 

 

 

原理解析:


 

 来源:程序化99( WWW.grahamobil.com )

源码:

 

 

 

{楚河漢界引用公式}

{公称名称: CHUS}AAA:=1;TT:=1;

RC:=(REF(CLOSE,1) * AAA);
XA:=IF((RC > HIGH),RC,0);
XB:=IF(((HIGH >= RC) AND (RC > LOW)),HIGH,0);
XC:=IF((RC <= LOW),HIGH,0);
XD:=((XA + XB) + XC);
YA:=IF((RC > HIGH),LOW,0);
YB:=IF(((HIGH >= RC) AND (RC > LOW)),LOW,0);
YC:=IF((RC <= LOW),RC,0);
YD:=((YA + YB) + YC);
ATR:=SMA((XD - YD),20,1);
TT1: (EMA(CLOSE,20) + (2 * ATR)),LINETHICK0;
TT2: (EMA(CLOSE,20) - (2 * ATR)),LINETHICK0;
TT3: ((((TT1 + TT1) + TT1) + TT2) / 4),LINETHICK0;
TT4: ((((TT1 + TT2) + TT2) + TT2) / 4),LINETHICK0;
TT5: EMA(CLOSE,8),LINETHICK0;
TT6: EMA(CLOSE,20),LINETHICK0;

 

 


{西楚霸王}
DRAWutf-8(1,colorrgb(0,0,100),colorrgb(0,0,0),1);
TT:=1;
CHECK:=0;
CHECK1:=0;
AAA:=IF((((CHECK = 0) OR (CHECK1 = 0)) AND (TT = 1)),1,0);
TD:=DATATYPE;
TT5:=(IF((TD = 1),"CHUS.TT1#min5",IF((TD = 2),"CHUS.TT1#min15",IF((TD = 3),"CHUS.TT1#min60",IF((TD = 4),"CHUS.TT1#min60",IF((TD = 5),"CHUS.TT1#day",IF((TD = 6),"CHUS.TT1#week","CHUS.TT1#year")))))) * TT);
TT6:=(IF((TD = 1),"CHUS.TT2#min5",IF((TD = 2),"CHUS.TT2#min15",IF((TD = 3),"CHUS.TT2#min60",IF((TD = 4),"CHUS.TT2#min60",IF((TD = 5),"CHUS.TT2#day",IF((TD = 6),"CHUS.TT2#week","CHUS.TT2#year")))))) * TT);
A3:=(IF((TD = 1),"CHUS.TT3#min5",IF((TD = 2),"CHUS.TT3#min15",IF((TD = 3),"CHUS.TT3#min60",IF((TD = 4),"CHUS.TT3#min60",IF((TD = 5),"CHUS.TT3#day",IF((TD = 6),"CHUS.TT3#week","CHUS.TT3#year")))))) * TT);
A4:=(IF((TD = 1),"CHUS.TT4#min5",IF((TD = 2),"CHUS.TT4#min15",IF((TD = 3),"CHUS.TT4#min60",IF((TD = 4),"CHUS.TT4#min60",IF((TD = 5),"CHUS.TT4#day",IF((TD = 6),"CHUS.TT4#week","CHUS.TT4#year")))))) * TT);
XC:=(IF((TD = 1),"CHUS.TT5#min5",IF((TD = 2),"CHUS.TT5#min15",IF((TD = 3),"CHUS.TT5#min60",IF((TD = 4),"CHUS.TT5#min60",IF((TD = 5),"CHUS.TT5#day",IF((TD = 6),"CHUS.TT5#week","CHUS.TT5#year")))))) * TT);
XD:=(IF((TD = 1),"CHUS.TT6#min5",IF((TD = 2),"CHUS.TT6#min15",IF((TD = 3),"CHUS.TT6#min60",IF((TD = 4),"CHUS.TT6#min60",IF((TD = 5),"CHUS.TT6#day",IF((TD = 6),"CHUS.TT6#week","CHUS.TT6#year")))))) * TT);
FILLRGN(((XC >= XD) AND (AAA = 1)),EMA(TT5,4),EMA(TT6,4)),color9933cc;
FILLRGN(((XC < XD) AND (AAA = 1)),EMA(TT5,4),EMA(TT6,4)),colorFccF00;
FILLRGN(((EMA(CLOSE,8) >= EMA(CLOSE,20)) AND (AAA = 1)),EMA(A3,4),EMA(A4,4)),colorFF99CC;
FILLRGN(((EMA(CLOSE,8) < EMA(CLOSE,20)) AND (AAA = 1)),EMA(A3,4),EMA(A4,4)),colorccFF66;
FO:=IF(CHECKUSER(1),OPEN,0);
FH:=IF(CHECKUSER(1),HIGH,0);
FL:=IF(CHECKUSER(1),LOW,0);
FC:=IF(CHECKUSER(1),CLOSE,0);
<%vo=ffl.vardata("fo")
vh=ffl.vardata("fh")
vl=ffl.vardata("fl")
vc=ffl.vardata("fc")
last=ubound(vc)vc(0)=(vh(0)+vl(0)+2*vc(0))/4
for i=1 to last
vo(i)=(vo(i-1)+vc(i-1))/2
if vo(i)>vh(i) then vh(i)=vo(i) else vh(i)=vh(i)
if vo(i)<vl(i) then vl(i)=vo(i) else vl(i)=vl(i)
vc(i)=(2*vc(i)+vh(i)+vl(i))/4
nextffl.vardata("fo")=vo
ffl.vardata("fh")=vh
ffl.vardata("fl")=vl
ffl.vardata("fc")=vc
%>
KK:=IF(((FC >= FO) AND ((FC >= REF(FC,1)) OR (REF(FC,1) >= REF(FO,1)))),1,IF(((FC < FO) AND ((FC < REF(FO,1)) OR (REF(FC,1) < REF(FO,1)))),(0 - 1),0));
明日轉折:(ROUND(((FO + FC) / 2)) * AAA),SHIFT1,LINETHICK0,color0000FF;
今日轉折:=ROUND(IF((KK = 1),MIN(FC,FO),IF((KK = (0 - 1)),MAX(FC,FO),IF((REF(KK,1) = 1),MIN(FC,FO),IF((REF(KK,1) = (0 - 1)),MAX(FC,FO),((FC + FO) / 2))))));
DRAWNUMBER((ISLASTBAR AND (AAA = 1)),明日轉折,ROUND(明日轉折),2),SHIFT1,COLORRED;
STICKLINE((((FC > FO) AND (TT = 1)) AND (AAA = 1)),FH,FL,0.4,0),colorFF;
STICKLINE((((FO > FC) AND (TT = 1)) AND (AAA = 1)),FH,FL,0.4,0),colorFF0000;
STICKLINE(((((KK = 1) AND (FC >= FO)) AND (TT = 1)) AND (AAA = 1)),FO,FC,8,0),colorFF;
STICKLINE(((((KK = 1) AND (FC < FO)) AND (TT = 1)) AND (AAA = 1)),FO,FC,8,0),colorFF;
STICKLINE(((((KK = (0 - 1)) AND (FC >= FO)) AND (TT = 1)) AND (AAA = 1)),FO,FC,8,0),colorFF0000;
STICKLINE(((((KK = (0 - 1)) AND (FC < FO)) AND (TT = 1)) AND (AAA = 1)),FO,FC,8,0),colorFF0000;
STICKLINE(((((KK = 0) AND (FC >= FO)) AND (TT = 1)) AND (AAA = 1)),FO,FC,8,0),colorFF;
STICKLINE(((((KK = 0) AND (FC < FO)) AND (TT = 1)) AND (AAA = 1)),FO,FC,8,0),colorFF;
CC:=(CLOSE * TT);
DIFF:=(EMA(CC,26) - EMA(CC,52));
DEA:=EMA(DIFF,52);
MACD:=(2 * (DIFF - DEA));
DIF:=(EMA(CC,26) - EMA(CC,52));
ESS:=EMA(CC,26);
EGG:=EMA(CC,52);
RDIF:=REF(DIF,1);
RSS:=REF(ESS,1);
RGG:=REF(EGG,1);
RDEA:=REF(DEA,1);
RMACD:=REF(MACD,1);
RZZZ:=(RDEA + (((52 + 1) / (2 * (52 - 1))) * RMACD));
XDIF:=((((((52 - 1) * (26 + 1)) * RGG) - (((52 + 1) * (26 - 1)) * RSS)) + (((26 + 1) * (52 + 1)) * RDIF)) / ((2 * 52) - (2 * 26)));
XDEA:=((((((52 - 1) * (26 + 1)) * RGG) - (((52 + 1) * (26 - 1)) * RSS)) + (((26 + 1) * (52 + 1)) * RDEA)) / ((2 * 52) - (2 * 26)));
XMACD:=((((((52 - 1) * (26 + 1)) * RGG) - (((52 + 1) * (26 - 1)) * RSS)) + (((26 + 1) * (52 + 1)) * RZZZ)) / ((2 * 52) - (2 * 26)));
AA:=ISLASTBAR;
BB:=BACKSET((AA = 1),1);
Y:=BARSLAST((BB = 1));
X:=1;
TDIF:=(DIF * X);
TSS:=(ESS * X);
TGG:=(EGG * X);
TDEA:=(DEA * X);
TMACD:=(MACD * X);
TZZZ:=(TDEA + (((52 + 1) / (2 * (52 - 1))) * TMACD));
西楚霸王:(((((((((52 - 1) * (26 + 1)) * TGG) * AAA) - ((((52 + 1) * (26 - 1)) * TSS) * AAA)) + (((26 + 1) * (52 + 1)) * TDIF)) * AAA) / ((2 * 52) - (2 * 26))) * AAA);
PARTLINE(((西楚霸王 >= REF(西楚霸王,1)) AND (AAA = 1)),西楚霸王),LINETHICK3,colorFF;
PARTLINE(((西楚霸王 < REF(西楚霸王,1)) AND (AAA = 1)),西楚霸王),LINETHICK3,colorFF00;Q5:=MA(EMA(TT6,4),4);
Q6:=MA(EMA(A3,4),4);
Q7:=MA(EMA(A4,4),4);
Q8:=MA(EMA(TT5,4),4);
STICKLINE(CROSS(BACKSET(ISLASTBAR,10),1) AND AAA=1,EMA(EMA(TT6,4),4),EMA(EMA(TT6,4),4),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,9),1) AND AAA=1,REF(EMA(EMA(TT6,4),4),1),REF(EMA(EMA(TT6,4),4),1),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,8),1) AND AAA=1,REF(EMA(EMA(TT6,4),4),2),REF(EMA(EMA(TT6,4),4),2),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,7),1) AND AAA=1,REF(EMA(EMA(TT6,4),4),3),REF(EMA(EMA(TT6,4),4),3),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,6),1) AND AAA=1,REF(EMA(EMA(TT6,4),4),4),REF(EMA(EMA(TT6,4),4),4),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,5),1) AND AAA=1,REF(EMA(EMA(TT6,4),4),5),REF(EMA(EMA(TT6,4),4),5),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,4),1) AND AAA=1,REF(EMA(EMA(TT6,4),4),6),REF(EMA(EMA(TT6,4),4),6),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,3),1) AND AAA=1,REF(EMA(EMA(TT6,4),4),7),REF(EMA(EMA(TT6,4),4),7),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,2),1) AND AAA=1,REF(EMA(EMA(TT6,4),4),8),REF(EMA(EMA(TT6,4),4),8),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,1),1) AND AAA=1,REF(EMA(EMA(TT6,4),4),9),REF(EMA(EMA(TT6,4),4),9),10,0),LINETHICK3,color80;
DRAWNUMBER(CROSS(BACKSET(ISLASTBAR,1),1) AND AAA=1,REF(EMA(EMA(TT6,4),4),9),REF(EMA(EMA(TT6,4),4),9),1),SHIFT1;
STICKLINE(CROSS(BACKSET(ISLASTBAR,10),1) AND AAA=1,EMA(EMA(TT5,4),4),EMA(EMA(TT5,4),4),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,9),1) AND AAA=1,REF(EMA(EMA(TT5,4),4),1),REF(EMA(EMA(TT5,4),4),1),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,8),1) AND AAA=1,REF(EMA(EMA(TT5,4),4),2),REF(EMA(EMA(TT5,4),4),2),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,7),1) AND AAA=1,REF(EMA(EMA(TT5,4),4),3),REF(EMA(EMA(TT5,4),4),3),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,6),1) AND AAA=1,REF(EMA(EMA(TT5,4),4),4),REF(EMA(EMA(TT5,4),4),4),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,5),1) AND AAA=1,REF(EMA(EMA(TT5,4),4),5),REF(EMA(EMA(TT5,4),4),5),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,4),1) AND AAA=1,REF(EMA(EMA(TT5,4),4),6),REF(EMA(EMA(TT5,4),4),6),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,3),1) AND AAA=1,REF(EMA(EMA(TT5,4),4),7),REF(EMA(EMA(TT5,4),4),7),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,2),1) AND AAA=1,REF(EMA(EMA(TT5,4),4),8),REF(EMA(EMA(TT5,4),4),8),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,1),1) AND AAA=1,REF(EMA(EMA(TT5,4),4),9),REF(EMA(EMA(TT5,4),4),9),10,0),LINETHICK3,color80;
DRAWNUMBER(CROSS(BACKSET(ISLASTBAR,1),1) AND AAA=1,REF(EMA(EMA(TT5,4),4),9),REF(EMA(EMA(TT5,4),4),9),1),SHIFT1;
STICKLINE(CROSS(BACKSET(ISLASTBAR,10),1) AND AAA=1,EMA(EMA(A3,4),4),EMA(EMA(A3,4),4),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,9),1) AND AAA=1,REF(EMA(EMA(A3,4),4),1),REF(EMA(EMA(A3,4),4),1),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,8),1) AND AAA=1,REF(EMA(EMA(A3,4),4),2),REF(EMA(EMA(A3,4),4),2),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,7),1) AND AAA=1,REF(EMA(EMA(A3,4),4),3),REF(EMA(EMA(A3,4),4),3),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,6),1) AND AAA=1,REF(EMA(EMA(A3,4),4),4),REF(EMA(EMA(A3,4),4),4),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,5),1) AND AAA=1,REF(EMA(EMA(A3,4),4),5),REF(EMA(EMA(A3,4),4),5),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,4),1) AND AAA=1,REF(EMA(EMA(A3,4),4),6),REF(EMA(EMA(A3,4),4),6),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,3),1) AND AAA=1,REF(EMA(EMA(A3,4),4),7),REF(EMA(EMA(A3,4),4),7),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,2),1) AND AAA=1,REF(EMA(EMA(A3,4),4),8),REF(EMA(EMA(A3,4),4),8),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,1),1) AND AAA=1,REF(EMA(EMA(A3,4),4),9),REF(EMA(EMA(A3,4),4),9),10,0),LINETHICK3,color80;
DRAWNUMBER(CROSS(BACKSET(ISLASTBAR,1),1) AND AAA=1,REF(EMA(EMA(A3,4),4),9),REF(EMA(EMA(A3,4),4),9),1),SHIFT1;
STICKLINE(CROSS(BACKSET(ISLASTBAR,10),1) AND AAA=1,EMA(EMA(A4,4),4),EMA(EMA(A4,4),4),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,9),1) AND AAA=1,REF(EMA(EMA(A4,4),4),1),REF(EMA(EMA(A4,4),4),1),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,8),1) AND AAA=1,REF(EMA(EMA(A4,4),4),2),REF(EMA(EMA(A4,4),4),2),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,7),1) AND AAA=1,REF(EMA(EMA(A4,4),4),3),REF(EMA(EMA(A4,4),4),3),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,6),1) AND AAA=1,REF(EMA(EMA(A4,4),4),4),REF(EMA(EMA(A4,4),4),4),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,5),1) AND AAA=1,REF(EMA(EMA(A4,4),4),5),REF(EMA(EMA(A4,4),4),5),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,4),1) AND AAA=1,REF(EMA(EMA(A4,4),4),6),REF(EMA(EMA(A4,4),4),6),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,3),1) AND AAA=1,REF(EMA(EMA(A4,4),4),7),REF(EMA(EMA(A4,4),4),7),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,2),1) AND AAA=1,REF(EMA(EMA(A4,4),4),8),REF(EMA(EMA(A4,4),4),8),10,0),LINETHICK3,color80;
STICKLINE(CROSS(BACKSET(ISLASTBAR,1),1) AND AAA=1,REF(EMA(EMA(A4,4),4),9),REF(EMA(EMA(A4,4),4),9),10,0),LINETHICK3,color80;
DRAWNUMBER(CROSS(BACKSET(ISLASTBAR,1),1) AND AAA=1,REF(EMA(EMA(A4,4),4),9),REF(EMA(EMA(A4,4),4),9),1),SHIFT1;
JT:=(REF(EMA(EMA(A3,4),4),9)+REF(EMA(EMA(A4,4),4),9))/2;
STICKLINE(ISLASTBAR AND AAA=1,JT,JT,12,0);
DRAWNUMBER(CROSS(BACKSET(ISLASTBAR,1) AND AAA=1,1),JT,JT,1),SHIFT1;
A00:=MA(CLOSE,22);
A03:=(EMA(HIGH,5)+EMA(LOW,5)+EMA(CLOSE,5)*2)/4;
A04:=REF(A03,1);
A02:=FO>FC AND KK=0 AND FC<FO AND AAA=1;DRAWICON(CLOSE>O,LOW,4),ALIGN5;
DRAWICON(CLOSE<O,LOW,5),ALIGN5;
STICKLINE(FC>FO AND TT=1 AND AAA=1,FH,FL,0.4,0),colorFF;
STICKLINE(FO>FC AND TT=1 AND AAA=1,FH,FL,0.4,0),colorFF0000;
STICKLINE(KK=1 AND FC>=FO AND TT=1 AND AAA=1,FO,FC,8,0),colorFF;
STICKLINE(KK=1 AND FC<FO AND TT=1 AND AAA=1,FO,FC,8,0),colorFF;
STICKLINE(KK=-1 AND FC>=FO AND TT=1 AND AAA=1,FO,FC,8,0),colorFF0000;
STICKLINE(KK=-1 AND FC<FO AND TT=1 AND AAA=1,FO,FC,8,0),colorFF0000;
STICKLINE(KK=0 AND FC>=FO AND TT=1 AND AAA=1,FO,FC,8,0),colorFF;
STICKLINE(KK=0 AND FC<FO AND TT=1 AND AAA=1,FO,FC,8,0),colorFF;gj:=if(c=INDEXC,(INDEXC+INDEXh+INDEXl+INDEXO)/4,AMOUNT/(v+0.01)/100);
明日阻力:=l+(gj-l)+(c-l);
明日支撑:=l+(c-gj);
今日阻力:REF(明日阻力 , 1),LINETHICK0;
今日支撑:REF(明日支撑 , 1),LINETHICK0;
STICKLINE(BARSTATUS=2 and c>=今日阻力,今日阻力,今日阻力,20,0),Color0000FF;
STICKLINE(BARSTATUS=2 and c<今日阻力,今日阻力,今日阻力,20,0),Color00FF00;
STICKLINE(BARSTATUS=2 and c>=今日支撑,今日支撑,今日支撑,20,0),ColorFF00FF;
STICKLINE(BARSTATUS=2 and c<今日支撑,今日支撑,今日支撑,20,0),ColorFF0000;DRAWTEXTEX(1,1,200,30,STKLABEL+' '+STKNAME),LINETHICK6,ColorFFFF80;
wyy1:=WEEKDAY,LINETHICK0;
wWj:=' 星期';
wWjj:=IF(wyy1=5 ,wWj+'五',IF(wyy1=4 ,wWj+'四',
IF(wyy1=3 ,wWj+'三',IF(wyy1=2 ,wWj+'二',IF(wyy1=1 ,wWj+'1',wWj)))));
wyy2:=LMONTH;
wyy3:=LDAY;
wWw:=IF( BARSTATUS=2 ,' 农历 '+NUMTOSTR(wyy2,0)+'月 '+NUMTOSTR(wyy3,0)+'日',' ');
wWh:=IF( BARSTATUS=2 ,NUMTOSTR(date+1000000,0),' ' );
DRAWTEXTEX(1,1,120 ,30 ,' '+wWh+wWjj+wWw),LINETHICK3,Color00FFFF;
DRAWTEXTEX(1,1,20,30,'楚河*<^o^>*汉界'),LINETHICK6,Color0000ff;
HH:=DYNAINFO(39);
DD:=FINANCE( 1);
SS:=FINANCE( 7);
FF:=FINANCE(18);
GG:=FINANCE(33);
zz:=FINANCE(53);
JJ:=FINANCE(40);
MM:=JJ/SS;
TH:=DYNAINFO(39);
换手率:=100*v/capital,colorfffFff;
RH:=H-L;
R:=DYNAINFO(13)*100;
DRAWTEXTEX(1,1,20,840,'当日振幅:'+NUMTOSTR(R,2)+'% '+NUMTOSTR(RH,2)+'元 '+' 当前换手率:'+NUMTOSTR(换手率,2)+'% '),ColorFFFFFF;
var100:='所属板块:';
if inblock('电力')=1 then var100:=var100+' 电力';
if inblock('电脑')=1 then var100:=var100+' 电脑';
if inblock('电器')=1 then var100:=var100+' 电器';
if inblock('电子信息')=1 then var100:=var100+' 电子信息';
if inblock('房地产')=1 then var100:=var100+' 房地产';
if inblock('纺织服装')=1 then var100:=var100+' 纺织服装';
if inblock('钢铁')=1 then var100:=var100+' 钢铁';
if inblock('工程建筑')=1 then var100:=var100+' 工程建筑';
if inblock('供水供气')=1 then var100:=var100+' 供水供气';
if inblock('化工')=1 then var100:=var100+' 化工';
if inblock('化纤')=1 then var100:=var100+' 化纤';
if inblock('机械')=1 then var100:=var100+' 机械';
if inblock('建材')=1 then var100:=var100+' 建材';
if inblock('交通工具')=1 then var100:=var100+' 交通工具';
if inblock('交通设施')=1 then var100:=var100+' 交通设施';
if inblock('教育传媒')=1 then var100:=var100+' 教育传媒';
if inblock('金融')=1 then var100:=var100+' 金融';
if inblock('旅游酒店')=1 then var100:=var100+' 旅游酒店';
if inblock('煤炭石油')=1 then var100:=var100+' 煤炭石油';
if inblock('酿酒食品')=1 then var100:=var100+' 酿酒食品';
if inblock('农林牧渔')=1 then var100:=var100+' 农林牧渔';
if inblock('其他行业')=1 then var100:=var100+' 其他行业';
if inblock('汽车')=1 then var100:=var100+' 汽车';
if inblock('汽配')=1 then var100:=var100+' 汽配';
if inblock('商业连锁')=1 then var100:=var100+' 商业连锁';
if inblock('石化')=1 then var100:=var100+' 石化';
if inblock('通信')=1 then var100:=var100+' 通信';
if inblock('外贸')=1 then var100:=var100+' 外贸';
if inblock('医药')=1 then var100:=var100+' 医药';
if inblock('仪电仪表')=1 then var100:=var100+' 仪电仪表';
if inblock('有色金属')=1 then var100:=var100+' 有色金属';
if inblock('运输物流')=1 then var100:=var100+' 运输物流';
if inblock('造纸印刷')=1 then var100:=var100+' 造纸印刷';
if inblock('安徽')=1 then var100:=var100+' 安徽';
if inblock('北京')=1 then var100:=var100+' 北京';
if inblock('福建')=1 then var100:=var100+' 福建';
if inblock('甘肃')=1 then var100:=var100+' 甘肃';
if inblock('广东')=1 then var100:=var100+' 广东';
if inblock('广西')=1 then var100:=var100+' 广西';
if inblock('贵州')=1 then var100:=var100+' 贵州';
if inblock('海南')=1 then var100:=var100+' 海南';
if inblock('河北')=1 then var100:=var100+' 河北';
if inblock('河南')=1 then var100:=var100+' 河南';
if inblock('黑龙江')=1 then var100:=var100+' 黑龙江';
if inblock('湖北')=1 then var100:=var100+' 湖北';
if inblock('湖南')=1 then var100:=var100+' 湖南';
if inblock('吉林')=1 then var100:=var100+' 吉林';
if inblock('江苏')=1 then var100:=var100+' 江苏';
if inblock('江西')=1 then var100:=var100+' 江西';
if inblock('辽宁')=1 then var100:=var100+' 辽宁';
if inblock('内蒙古')=1 then var100:=var100+' 内蒙古';
if inblock('宁夏')=1 then var100:=var100+' 宁夏';
if inblock('青海')=1 then var100:=var100+' 青海';
if inblock('山东')=1 then var100:=var100+' 山东';
if inblock('山西')=1 then var100:=var100+' 山西';
if inblock('陕西')=1 then var100:=var100+' 陕西';
if inblock('上海')=1 then var100:=var100+' 上海';
if inblock('深圳')=1 then var100:=var100+' 深圳';
if inblock('四川')=1 then var100:=var100+' 四川';
if inblock('天津')=1 then var100:=var100+' 天津';
if inblock('***')=1 then var100:=var100+' ***';
if inblock('新疆')=1 then var100:=var100+' 新疆';
if inblock('云南')=1 then var100:=var100+' 云南';
if inblock('浙江')=1 then var100:=var100+' 浙江';
if inblock('重庆')=1 then var100:=var100+' 重庆';
if inblock('3G')=1 then var100:=var100+' 3G';
if inblock('H股')=1 then var100:=var100+' H股';
if inblock('QFII持股')=1 then var100:=var100+' QFII持股';
if inblock('ST')=1 then var100:=var100+' ST';
if inblock('奥运')=1 then var100:=var100+' 奥运';
if inblock('创投')=1 then var100:=var100+' 创投';
if inblock('次新股')=1 then var100:=var100+' 次新股';
if inblock('大盘')=1 then var100:=var100+' 大盘';
if inblock('股权改革')=1 then var100:=var100+' 股权改革';
if inblock('股权投资')=1 then var100:=var100+' 股权投资';
DRAWTEXTEX(1,1,20,960,var100),color00ffff;
DRAWTEXTEX(1,1,20,900,'总股本:'+NUMTOSTR(DD,0)+'万股' +' 流通A股:'+NUMTOSTR(SS,0)+'万股'+' 市盈率:'+NUMTOSTR(HH,2)+'%'+' 每股收益:'+NUMTOSTR(GG,3)),COLORbbffff;VAR1111:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);
VAR2222:=CROSS(VAR1111,0.9);
VAR3333:=BACKSET(REF(LOW,2)=LLV(LOW,5),3);
VAR4444:=CROSS(VAR3333,0.9);
压力: REF(HIGH,BARSLAST(Var2222)), POINTDOT,ColorEA91B5;
STICKLINE(CLOSE,REF(HIGH,BARSLAST(Var2222)),REF(HIGH,BARSLAST(Var2222)),5,0),ColorEA91B5;
支撑: REF(LOW,BARSLAST(Var4444)), POINTDOT,Color00b4ff;
STICKLINE(CLOSE,REF(LOW,BARSLAST(Var4444)),REF(LOW,BARSLAST(Var4444)),5,0),Color00b4ff;下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
aRSV:=SMA(下档线,3,1);
aK:=SMA(aRSV,3,1);
aD:=((3 * aRSV) - (2 * aK));
aJ12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
aRSV24:=SMA(aJ12,3,1);
aK24:=SMA(aRSV24,3,1);
aD24:=((3 * aRSV24) - (2 * aK24));
撑压位:=IF(CROSS(aD24,aD),HIGH,REF(HIGH,BARSLAST(CROSS(aD24,aD))));
底:=LLV(HIGH,30);
STICKLINE(BARSTATUS=2 ,撑压位,撑压位,40,1),LINETHICK1,COLORFFFFFF;
DRAWTEXT(BARSTATUS=2 ,撑压位,' 撑压'),COLORFFFFFF;
STICKLINE(BARSTATUS=2 ,底,底,40,1),COLOR00FF00,LINETHICK1;
DRAWTEXT(BARSTATUS=2 ,底,' 底线'),COLOR00FF00;
partline(c>0,c*2-ref(c,3)),SHIFT3,color005555;
partline(c>0,ref(c,1)*2-ref(c,4)),SHIFT2,color005500;
partline(c>0,ref(c,2)*2-ref(c,5)),SHIFT1,color55335;

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  有需要帮忙请点击这里留言!!!进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容