CCIRSIKD三线合一-其他软件公式 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 股票公式>> 其他>> 其他软件公式>>正文内容

365bet送体验金

相关标签:通达信cci指标公式 、 cci背离指标公式 、 cci指标选股公式 、 cci指标公式源码 、 极品cci指标公式 、 超级cci指标公式 、 双cci指标公式 、 cci指标公式优化 、 cci买入指标公式 、 布林cci指标公式 、 周线cci指标公式 、 自用cci指标公式 、 cci组合指标公式 、 高成功率股票指标公式 、

 

CCI,RSI,KD, 是大家常用的公式,三个公式整合在一起结合各自的买卖原则成功率更高。三线
底部共振为买入信号,三线高位共振为卖出信号。

原理解析:


 

 来源:程序化99( WWW.grahamobil.com )

源码:

 

{RSI-CCI-KD}input:N(9,2,100),M(14,1,100),N1(6,2,100);
100,LINEDOT;
-100,LINEDOT;
TYP := (HIGH + LOW + CLOSE)/3;
CC1:(TYP-MA(TYP,M))/(0.015*AVEDEV(TYP,M)),ColorFF00FF;
C1:=SMA(CC1,3,1);
C2:=SMA(C1,3,1);
C3:=3*C1-2*C2;
CB1:=EMA(C3,5);
CB2:=REF(CB1,1);
FILLRGN(CC1>100,CC1,100),Color38FF00;
FILLRGN(CC1<-100,CC1,-100),COLOR00AAFF;
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100;
RSI:(RSI1-50)*5,LINETHICK2,ColorFFFFFF;
R1:=SMA(RSI,3,1);
D1:=SMA(R1,3,1);
J1:=3*R1-2*D1;
RR1:=EMA(J1,5);
RR2:=REF(RR1,1);
RR:=RR1>RR2;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,3,1);
K1:(K-50)*5,ColorFFFF00;
K2:=SMA(K1,3,1);
D2:=SMA(K2,3,1);
J2:=3*K2-2*D2;
BB1:=EMA(J2,5);
BB2:=REF(BB1,1);
买入:RR AND NOT(REF(RR,1)) AND (RR1<-100 AND BB1<-100) AND CB1<-100,LINETHICK0;
DRAWICON(买入,-200,4),ALIGN0;
卖出:REF(RR,1)=1 AND NOT(RR) AND CB1>100,LINETHICK0;
DRAWICON(卖出,200,5),ALIGN0;

 

 

 

 

 

2008.11.1以后的测试:
测试结果(利润1:用目标周期内最高价计算的全部指示的平均利润,利润2:期末价平均利润)测试证券数:1388曾指示证券数:1009共发出指示:1553 成功指示:1296 失败指示:15 未完成指示:242平均成功率:98.86%, 成功率达到50%的股票有:67.7%利润1总平均:32.95% 利润1最大值:161.54% 利润1最小值:0.00%
最高利润达到2倍目标利润以上指示: 1158 (88.33%)
最高利润达到3倍目标利润以上指示: 892 (68.04%)利润2总平均: 28.33% 利润2最大值: 159.93% 利润2最小值: -12.30%
期末低于介入点指示: 24 (1.83%)
2008.1.1以后的测试:
测试结果(利润1:用目标周期内最高价计算的全部指示的平均利润,利润2:期末价平均利润)测试证券数:1388曾指示证券数:1294共发出指示:10375 成功指示:5742 失败指示:4387 未完成指示:246平均成功率:56.69%, 成功率达到50%的股票有:68.4%利润1总平均:16.43% 利润1最大值:48.47% 利润1最小值:0.00%
最高利润达到2倍目标利润以上指示: 3193 (31.52%)
最高利润达到3倍目标利润以上指示: 1745 (17.23%)利润2总平均: -0.36% 利润2最大值: 34.34% 利润2最小值: -45.26%
期末低于介入点指示: 5417 (53.48%)
1990.1.1以后的测试:
测试结果(利润1:用目标周期内最高价计算的全部指示的平均利润,利润2:期末价平均利润)测试证券数:1388曾指示证券数:1370共发出指示:79578 成功指示:32678 失败指示:46622 未完成指示:278平均成功率:41.21%, 成功率达到50%的股票有:14.9%利润1总平均:11.77% 利润1最大值:51.34% 利润1最小值:0.00%
最高利润达到2倍目标利润以上指示: 13629 (17.19%)
最高利润达到3倍目标利润以上指示: 6236 (7.86%)利润2总平均: 1.54% 利润2最大值: 33.73% 利润2最小值: -13.16%
期末低于介入点指示: 39272 (49.52%){程序化交易 www.grahamobil.com }

 

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  有需要帮忙请点击这里留言!!!进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容