个股大盘对比猛牛副图指标公式源码-同花顺公式 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 股票公式>> 同花顺>> 同花顺公式>>正文内容

365bet送体验金

相关标签:大盘副图k线指标源码 、 同花顺使用的副图指标 、 同花顺短线副图指标 、 同花顺主图指标公式 、 个股大盘分时对比副图 、 个股大盘强弱对比副图 、 同花顺分时指标源码 、 同花顺ddx指标源码 、 同花顺画线指标源码 、 同花顺筹指标源码 、 同花顺波段指标源码 、 同花顺cyc指标源码 、 同花顺cci指标源码 、 同花顺逃顶指标源码 、

 

原理解析:


 

 来源:程序化99( WWW.grahamobil.com )

源码:

 

EXPLAIN(Q1,'<>指数与个股的MSD同时处于20以下的低位,表明个股与大盘同步下跌,表明大盘与个股处于历史低位,密切关注对20试庄线的突破<>'),coloryellow;
EXPLAIN(Q2,'<>指数MSD处于低位,个股MSD脱离低位区并突破20,表明有庄先行介入,择机买入<>'),colorred;
EXPLAIN(Q3,'<>大盘反弹,个股已经突破分水岭,进入强势<>'),colorred;
EXPLAIN(Q4 ,'<>条件4:个股随大盘一起启动,赶快行动,切勿错过时机<>'),coloryellow;
EXPLAIN(Q5,'<>后来者居上,个股主升浪开始,买入<>'),coloryellow;
EXPLAIN(Q6,'<>个股逆市上涨,突破分水岭,择机介入,机者成交量,均线和K线的配合<>'),colorgreen;
EXPLAIN(Q7,'<>个股逆市下跌,关注对于20试庄线的突破<>'),colorred;
EXPLAIN(Q8 ,'<>个股随同大盘顺势下跌,个股行情结束,下跌刚刚开始.<>'),coloryellow;
EXPLAIN(Q9,'<>个股顺势继续下跌,个股行情仍没有见底迹象<>'),coloryellow;
EXPLAIN(Q10 ,'<>大盘下跌而个股上涨选择买入时机<>'),coloryellow;
EXPLAIN(Q11,'<>大盘与个股皆处强势拉升的未期,有可能转势,择机卖出<>'),colorgreen;
EXPLAIN(Q12,'<>大盘从高位下跌,而个股逆市上涨,有拉高出货的嫌疑,仔细分析,择机出局<>'),colorgreen;
EXPLAIN(Q13,'<>大盘与个股皆处强势拉升中期<>'),colorgreen;
EXPLAIN(Q14,'<>大盘与个股皆处强势拉升的初级阶段<>'),colorgreen;
EXPLAIN(Q15,'<>大盘处于超强势,个股拉渐渐进入强势<>'),colorgreen;
EXPLAIN(Q16,'<>大盘处于拉升未期,刚开始下跌,个股反而逆市上涨,寻找介入和出货点<>'),colorgreen;
EXPLAIN(Q17,'<>大盘处于拉升未期,刚开始下跌,个股也处拉升的未期,注意见顶<>'),colorgreen;
EXPLAIN(Q18,'<>大盘处于下跌未期,可能是最后一跌,个股可能还有一跌,现在不是介入时机,等待介入时机<>'),colorgreen;
EXPLAIN(Q19,'<>大盘刚突破底部又开始下跌,,寻找介入时机<>'),colorgreen;
EXPLAIN(Q20,'<>大盘刚突破底部,,个股仍处于底部,寻找介入时机<>'),colorgreen;
EXPLAIN(Q21,'<>个股率先起动,大盘后起动,有可能是领涨股龙头<>'),colorgreen;
EXPLAIN(Q22,'<>个股洗盘结束,再次起动,有可能是领涨股龙头<>'),colorgreen;TIPTEXT(ISNULL(REFX(&CLOSE,1)),0,' WWW.grahamobil.com '),colorred;
TIPTEXT(ISNULL(REF(CLOSE,1)),0,'同花顺程序化交易');

个股MSD:EMA(100*(C-LLV(LOW,N))/(HHV(H,N)-LLV(LOW,N)),X), coloryellow,linethick2;
大盘MSD:EMA(100*(INDEXC-LLV(INDEXL,N))/(HHV(INDEXH,N)-LLV(INDEXL,N)),X),colorgreen,linethick2;
强弱分水岭:50,POINTDOT;
天:80,colorblue,CIRCLEDOT;
试庄线:20,colorgreen,CIRCLEDOT;
0;100;
Q1:=个股MSD<=20 AND 大盘MSD<=20;
Q2:=个股MSD>=20 AND 大盘MSD<=20 AND RANGE(个股MSD,20,50) AND 个股MSD> REF(个股MSD,2);
Q3:=RANGE(个股MSD,50,80) AND RANGE(大盘MSD,20,50) AND 个股MSD>=REF(个股MSD,1) AND 大盘MSD>REF(大盘MSD,1);
Q4:=EXIST(CROSS(个股MSD,20),4) AND 大盘MSD>20 AND 大盘MSD>REF(大盘MSD,1)AND 大盘MSD>个股MSD ;
Q5:=RANGE(大盘MSD,80,100) AND CROSS(个股MSD,50) AND 个股MSD<80 AND 个股MSD>=REF(个股MSD,2);
Q6:=大盘MSD<20 AND CROSS(个股MSD,50) ;
Q7:=RANGE(大盘MSD,50,20 ) AND 个股MSD<=20 AND 个股MSD<REF(个股MSD,2);
Q8:=大盘MSD< REF(大盘MSD,2) AND 个股MSD< REF(个股MSD,2) AND 大盘MSD<80 AND 个股MSD <80 AND 大盘MSD>50 AND 个股MSD>50;
Q9:=大盘MSD< REF(大盘MSD,2) AND 个股MSD< REF(个股MSD,2) AND 大盘MSD<50 AND 个股MSD <50 AND 大盘MSD>20 AND 个股MSD>20;
Q10:=大盘MSD< REF(大盘MSD,2) AND RANGE(个股MSD,20,50) AND RANGE(大盘MSD,20,50) AND 个股MSD>REF(个股MSD,1)AND CROSS(个股MSD,大盘MSD);
Q11:=RANGE(个股MSD,80,100) AND RANGE(大盘MSD,80,100)AND 大盘MSD<=REF(大盘MSD,2)AND 个股MSD<=REF(个股MSD,1);
Q12:=RANGE(个股MSD,50,80) AND RANGE(大盘MSD,50,80)AND 大盘MSD<=REF(大盘MSD,2)AND 个股MSD>=REF(个股MSD,1) AND CROSS(个股MSD,大盘MSD);
Q13:=RANGE(个股MSD,80,100) AND RANGE(大盘MSD,80,100)AND 大盘MSD>=REF(大盘MSD,1)AND 个股MSD>=REF(个股MSD,1);
Q14:=RANGE(个股MSD,50,80) AND RANGE(大盘MSD,50,80)AND 大盘MSD>=REF(大盘MSD,1)AND 个股MSD>=REF(个股MSD,1);
Q15:=RANGE(个股MSD,50,80) AND RANGE(大盘MSD,80,100)AND 个股MSD>=REF(个股MSD,1);
Q16:=RANGE(个股MSD,80,100) AND RANGE(大盘MSD,50,80)AND 个股MSD>=REF(个股MSD,1) AND 大盘MSD<=REF(大盘MSD,1);
Q17:=RANGE(个股MSD,80,100) AND RANGE(大盘MSD,50,80)AND 个股MSD<=REF(个股MSD,1)AND 大盘MSD<=REF(大盘MSD,1);
Q18:=RANGE(个股MSD,20,50) AND RANGE(大盘MSD,0,20)AND 个股MSD<=REF(个股MSD,1)AND 大盘MSD<=REF(大盘MSD,1);
Q19:=RANGE(个股MSD,20,50) AND RANGE(大盘MSD,0,20)AND 个股MSD<=REF(个股MSD,1)AND 大盘MSD<=REF(大盘MSD,1)AND REF(大盘MSD,1)>20 AND REF(大盘MSD,2)>20 AND REF(大盘MSD,3)<20;
Q20:=RANGE(个股MSD,0,20) AND RANGE(大盘MSD,20,50) AND 大盘MSD>=REF(大盘MSD,1);
Q21:=EXIST(CROSS(个股MSD,20),3) AND 大盘MSD>20 AND 大盘MSD>REF(大盘MSD,1)AND 个股MSD>大盘MSD;
Q22:=RANGE(个股MSD,50,80) AND RANGE(大盘MSD,20,50) AND 个股MSD>REF(个股MSD,1) AND REF(个股MSD,1)<REF(个股MSD,2) ;
天顶:STICKLINE(个股MSD>80 AND 大盘MSD>80 ,80 ,75 , 10, 0),colorred,CIRCLEDOT;
地底:STICKLINE(个股MSD<20 AND 大盘MSD<20 ,22,15, 10, 0),colorred,CIRCLEDOT;
RSV:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
W1:=MA(V,5)>MA(V,34);
W2:="KDJ.K"(9,3,3);
W3:=MA(V,5)<MA(V,10);
Y1:=C>MA(C,5)AND C>MA(C,10)AND O<MA(C,5)AND O<MA(C,10);//一阳穿二线
Y2:=C<MA(C,5)AND C<MA(C,10)AND O>MA(C,5)AND O>MA(C,10);//一阴穿二线
海底火山:=Y1 AND W1 AND CROSS( K,D )AND K<=20 AND W2 <25;
天险绝壁:=Y2 AND W3 AND 大盘MSD<80 AND 个股MSD>80;
DRAWTEXT(海底火山,HIGH,'海底火山'),colorgreen;
DRAWTEXT(天险绝壁,70,'天'),coloryellow;
DRAWTEXT(天险绝壁,60,'险'),coloryellow;
DRAWTEXT(天险绝壁,50,'绝'),coloryellow;
DRAWTEXT(天险绝壁,40,'壁'),coloryellow;
DRAWTEXT(Q4,78,'紫'),colormagenta;
DRAWTEXT(Q4,66,'气'),colormagenta;
DRAWTEXT(Q4,54,'东'),colormagenta;
DRAWTEXT(Q4,42,'来'),colormagenta;
DRAWTEXT(Q12,65,'黄色警告'),coloryellow;
DRAWTEXT(Q12,75,''),coloryellow;
DRAWICON(Q8,75,5);
a1:IF(Q5,85,50),COLORff00ff;
a2:IF(Q6,50,20),colorred;TIPTEXT(ISNULL(REFX(&CLOSE,1)),0,' WWW.grahamobil.com '),colorred;
TIPTEXT(ISNULL(REF(CLOSE,1)),0,'同花顺程序化交易');

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 1145508240  点击这里给我发消息进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容