号称年收益超300% LQ3AIN公式-其他软件公式 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 股票公式>> 其他>> 其他软件公式>>正文内容

365bet送体验金

相关标签:涨幅5%指标公式 、 年化收益12% 、 年收益20%的方法 、 100%抓涨停板指标公式 、 90%以上胜率指标公式 、 指标公式成功率85% 、 年化收益5% 、 年化收益15% 、 w%r指标公式 、 100%获利指标公式 、 100%胜率短线指标公式 、 100%绝密指标公式 、 年化收益10% 、

 

名称: LQ3AIN 类别:技术指标
说明: 自动交易系统(视图指标)

 

 

原理解析:


 

 来源:程序化99( WWW.grahamobil.com )

源码:

 


KSX:=DATE<1090631;
KN:=BARSTATUS=2;
X:=1;
RSV1:=(CLOSE-LLV(LOW,X*9))/(HHV(HIGH,X*9)-LLV(LOW,X*9))*100;
KX1:=SMA(RSV1,X*3,1);
DX1:=SMA(KX1,X*3,1);
JX1:=3*KX1-2*DX1;
LC1:=REF(CLOSE,2);
RX1:=(SMA(MAX(CLOSE-LC1,0),X*6,1))/(SMA(ABS(CLOSE-LC1),X*6,1))*170-30;
JRX1:=(JX1+RX1)/2;
KR1:=SMA(JRX1,X*3,1);
DR1:=SMA(KR1,X*3,1);
JR1:=3*KR1-2*DR1*KSX;
JRE1:=EMA(JR1,3)*KSX;
JR1M:=(JR1+40)*KSX;
M0:=CLOSE;
M1:=EMA(M0,N)*KSX;
M3:=EMA(M0,P)*KSX;
M4:=EMA(M0,45)*KSX;
M5:=EMA(M0,225)*KSX;
QDM1:(M1-REF(M1,1))/REF(M1,1)*100,LINETHICK0,colorFFFFFF;
QDM3:(M3-REF(M3,1))/REF(M3,1)*100,LINETHICK0,colorFFFF;
QDM4:(M4-REF(M4,1))/REF(M4,1)*100,LINETHICK0,colorFFFF00;
QDJR:(JR1M-REF(JR1M,1))/REF(JR1M,1)*100,LINETHICK0,colorFFFFFF;
MO1:="MX.MX1#day";
MO2:="MX.MX1#week";
MO:=(IF(成本选择=0,MO1,MO2))*KSX;
J:=(1+本周盈利/100)*MO*KSX;
R:=(1+本周亏损/100)*MO*KSX;
GD:=(1+高点下跌)*HHV(HIGH,极限天数);
DS:=(1+低点上涨)*LLV(LOW,极限天数);
BMC:=LLV(LOW,极限天数)<R AND CLOSE>=DS AND QDM1>=买短强度 AND QDM3>=买中强度 AND QDM4>=买长强度 AND QDJR>=买势强度;
SMC:=HHV(HIGH,极限天数)>J AND CLOSE<=GD AND QDM1<=卖短强度 AND QDM3<=卖中强度;
BTS:=BARSLAST(BMC);
STS:=BARSLAST(SMC);
KBS:=IF(BTS<STS,2,0);
BKO:=CROSS(KBS,1);
SKO:=CROSS(1,KBS);
MRTS:=BARSLAST(BKO)+1;
MDJG:=IF(MRTS=1,LOW,REF(LOW,MRTS-1));
MHZG:=HHV(HIGH,MRTS+1);
MHZF:=(HHV(HIGH,MRTS)-MDJG)/MDJG;
ZSW:(1+MHZF+止损比率)*MDJG,LINETHICK0,colorFF;
ZY:=HIGH>(1+止盈比率)*REF(LOW,BARSLAST(BKO));
ZS:=CLOSE<ZSW;
BKTS:=BARSLAST(BKO);
SKTS:=BARSLAST(SKO);
KNBS:=IF(BKTS<SKTS,2,0);
BK:CROSS(KNBS,1)*KSX,LINETHICK0;
SK:CROSS(1,KNBS)*KSX,LINETHICK0;
ZYS:(ZY+ZS AND SK)*KSX,LINETHICK0,colorFF;
JYK:BK+SK,LINETHICK0;
DRAWICON(BK=1,LOW,1),ALIGN1;
DRAWICON(SK=1 OR ZYS=1,1.012*HIGH,2),ALIGN1;
DRAWICON(ZYS=1,1.03*HIGH,5),ALIGN1;
DRAWTEXT(BK=1,1.021*LOW,'-----'),colorFFFF;
DRAWTEXT(SK=1,0.991*HIGH,'-----'),colorFFFF;
PARTLINE(M5>=REF(M5,1),M5),LINETHICK4,color99FF;
PARTLINE(M5<REF(M5,1),M5),LINETHICK4,colorFF3300;
PARTLINE(M4>=REF(M4,1),M4),LINETHICK4,color99FF;
PARTLINE(M4<REF(M4,1),M4),LINETHICK4,colorFF3300;
PARTLINE(M3>=REF(M3,1),M3),LINETHICK3,color99FF;
PARTLINE(M3<REF(M3,1),M3),LINETHICK3,colorFF3300;
PARTLINE(M1>=REF(M1,1),M1),LINETHICK2,color99FF;
PARTLINE(M1<REF(M1,1),M1),LINETHICK2,colorFF3300;
M1,LINETHICK0,colorFFFFFF;
M3,LINETHICK0,colorFFFFFF;
M4,LINETHICK0,colorFFFFFF;
MO,LINETHICK1,colorDDDDDD;
J,colorAA00AA;
R,colorAA00;
名称: MX 类别:技术指标
说明: 均价(自动交易指标引用)
MX1:(HIGH+LOW)/2;
MXH:HIGH;
MXL:LOW;
MX2:REF(MX1,1);
MX3:REF(MX1,2);
MX4:MX2-MX3+MX3;
MXH2:MX2*1.0618;
MXL2:MX2*0.9382;名称: 买入LS3B 类别:条件选股
说明: 自动交易系统买入(选股)
KSX:=DATE<1090631;
X:=1;
RSV1:=(CLOSE-LLV(LOW,X*9))/(HHV(HIGH,X*9)-LLV(LOW,X*9))*100;
KX1:=SMA(RSV1,X*3,1);
DX1:=SMA(KX1,X*3,1);
JX1:=3*KX1-2*DX1;
LC1:=REF(CLOSE,2);
RX1:=(SMA(MAX(CLOSE-LC1,0),X*6,1))/(SMA(ABS(CLOSE-LC1),X*6,1))*170-30;
JRX1:=(JX1+RX1)/2;
KR1:=SMA(JRX1,X*3,1);
DR1:=SMA(KR1,X*3,1);
JR1:=3*KR1-2*DR1;
JRE1:=EMA(JR1,3);
JR1M:=JR1+40;
M0:=CLOSE;
M1:=EMA(M0,N);
M3:=EMA(M0,P);
M4:=EMA(M0,45);
M5:=EMA(M0,225);
QDM1:=(M1-REF(M1,1))/REF(M1,1)*100;
QDM3:=(M3-REF(M3,1))/REF(M3,1)*100;
QDM4:=(M4-REF(M4,1))/REF(M4,1)*100;
QDJR:=(JR1M-REF(JR1M,1))/REF(JR1M,1)*100;
MO1:="MX.MX1#day";
MO2:="MX.MX1#week";
MO:=(IF(成本选择=0,MO1,MO2))*KSX;
J:=(1+本周盈利/100)*MO;
R:=(1+本周亏损/100)*MO;
GD:=(1+高点下跌)*HHV(HIGH,极限天数);
DS:=(1+低点上涨)*LLV(LOW,极限天数);
BMC:=LLV(LOW,极限天数)<R AND CLOSE>=DS AND QDM1>=买短强度 AND QDM3>=买中强度 AND QDM4>=买长强度 AND QDJR>=买势强度;
SMC:=HHV(HIGH,极限天数)>J AND CLOSE<=GD AND QDM1<=卖短强度 AND QDM3<=卖中强度;
BTS:=BARSLAST(BMC);
STS:=BARSLAST(SMC);
KBS:=IF(BTS<STS,2,0);
BKO:=CROSS(KBS,1);
SKO:=CROSS(1,KBS);
MRTS:=BARSLAST(BKO)+1;
MDJG:=IF(MRTS=1,LOW,REF(LOW,MRTS-1));
MHZG:=HHV(HIGH,MRTS+1);
MHZF:=(HHV(HIGH,MRTS)-MDJG)/MDJG;
ZSW:=(1+MHZF+止损比率)*MDJG;
ZY:=HIGH>(1+止盈比率)*REF(LOW,BARSLAST(BKO));
ZS:=CLOSE<ZSW;
BKTS:=BARSLAST(BKO);
SKTS:=BARSLAST(SKO);
KNBS:=IF(BKTS<SKTS,2,0);
BK:=CROSS(KNBS,1);
SK:=CROSS(1,KNBS);
ZYS:=ZY+ZS AND SK;
JYK:BK*KSX;
名称: 卖出LS3S 类别:条件选股
说明: 自动交易系统卖出(选股)
KSX:=DATE<1090631;
X:=1;
RSV1:=(CLOSE-LLV(LOW,X*9))/(HHV(HIGH,X*9)-LLV(LOW,X*9))*100;
KX1:=SMA(RSV1,X*3,1);
DX1:=SMA(KX1,X*3,1);
JX1:=3*KX1-2*DX1;
LC1:=REF(CLOSE,2);
RX1:=(SMA(MAX(CLOSE-LC1,0),X*6,1))/(SMA(ABS(CLOSE-LC1),X*6,1))*170-30;
JRX1:=(JX1+RX1)/2;
KR1:=SMA(JRX1,X*3,1);
DR1:=SMA(KR1,X*3,1);
JR1:=3*KR1-2*DR1;
JRE1:=EMA(JR1,3);
JR1M:=JR1+40;
M0:=CLOSE;
M1:=EMA(M0,N);
M3:=EMA(M0,P);
M4:=EMA(M0,45);
M5:=EMA(M0,225);
QDM1:=(M1-REF(M1,1))/REF(M1,1)*100;
QDM3:=(M3-REF(M3,1))/REF(M3,1)*100;
QDM4:=(M4-REF(M4,1))/REF(M4,1)*100;
QDJR:=(JR1M-REF(JR1M,1))/REF(JR1M,1)*100;
MO1:="MX.MX1#day";
MO2:="MX.MX1#week";
MO:=(IF(成本选择=0,MO1,MO2))*KSX;
J:=(1+本周盈利/100)*MO;
R:=(1+本周亏损/100)*MO;
GD:=(1+高点下跌)*HHV(HIGH,极限天数);
DS:=(1+低点上涨)*LLV(LOW,极限天数);
BMC:=LLV(LOW,极限天数)<R AND CLOSE>=DS AND QDM1>=买短强度 AND QDM3>=买中强度 AND QDM4>=买长强度 AND QDJR>=买势强度;
SMC:=HHV(HIGH,极限天数)>J AND CLOSE<=GD AND QDM1<=卖短强度 AND QDM3<=卖中强度;
BTS:=BARSLAST(BMC);
STS:=BARSLAST(SMC);
KBS:=IF(BTS<STS,2,0);
BKO:=CROSS(KBS,1);
SKO:=CROSS(1,KBS);
MRTS:=BARSLAST(BKO)+1;
MDJG:=IF(MRTS=1,LOW,REF(LOW,MRTS-1));
MHZG:=HHV(HIGH,MRTS+1);
MHZF:=(HHV(HIGH,MRTS)-MDJG)/MDJG;
ZSW:=(1+MHZF+止损比率)*MDJG;
ZY:=HIGH>(1+止盈比率)*REF(LOW,BARSLAST(BKO));
ZS:=CLOSE<ZSW;
BKTS:=BARSLAST(BKO);
SKTS:=BARSLAST(SKO);
KNBS:=IF(BKTS<SKTS,2,0);
BK:=CROSS(KNBS,1);
SK:=CROSS(1,KNBS);
ZYS:=ZY+ZS AND SK;
JYK:SK*KSX;
名称: 止损LS3R 类别:条件选股
说明: 自动交易系统止损止盈(选股)
KSX:=DATE<1090631;
X:=1;
RSV1:=(CLOSE-LLV(LOW,X*9))/(HHV(HIGH,X*9)-LLV(LOW,X*9))*100;
KX1:=SMA(RSV1,X*3,1);
DX1:=SMA(KX1,X*3,1);
JX1:=3*KX1-2*DX1;
LC1:=REF(CLOSE,2);
RX1:=(SMA(MAX(CLOSE-LC1,0),X*6,1))/(SMA(ABS(CLOSE-LC1),X*6,1))*170-30;
JRX1:=(JX1+RX1)/2;
KR1:=SMA(JRX1,X*3,1);
DR1:=SMA(KR1,X*3,1);
JR1:=3*KR1-2*DR1;
JRE1:=EMA(JR1,3);
JR1M:=JR1+40;
M0:=CLOSE;
M1:=EMA(M0,N);
M3:=EMA(M0,P);
M4:=EMA(M0,45);
M5:=EMA(M0,225);
QDM1:=(M1-REF(M1,1))/REF(M1,1)*100;
QDM3:=(M3-REF(M3,1))/REF(M3,1)*100;
QDM4:=(M4-REF(M4,1))/REF(M4,1)*100;
QDJR:=(JR1M-REF(JR1M,1))/REF(JR1M,1)*100;
MO1:="MX.MX1#day";
MO2:="MX.MX1#week";
MO:=(IF(成本选择=0,MO1,MO2))*KSX;
J:=(1+本周盈利/100)*MO;
R:=(1+本周亏损/100)*MO;
GD:=(1+高点下跌)*HHV(HIGH,极限天数);
DS:=(1+低点上涨)*LLV(LOW,极限天数);
BMC:=LLV(LOW,极限天数)<R AND CLOSE>=DS AND QDM1>=买短强度 AND QDM3>=买中强度 AND QDM4>=买长强度 AND QDJR>=买势强度;
SMC:=HHV(HIGH,极限天数)>J AND CLOSE<=GD AND QDM1<=卖短强度 AND QDM3<=卖中强度;
BTS:=BARSLAST(BMC);
STS:=BARSLAST(SMC);
KBS:=IF(BTS<STS,2,0);
BKO:=CROSS(KBS,1);
SKO:=CROSS(1,KBS);
MRTS:=BARSLAST(BKO)+1;
MDJG:=IF(MRTS=1,LOW,REF(LOW,MRTS-1));
MHZG:=HHV(HIGH,MRTS+1);
MHZF:=(HHV(HIGH,MRTS)-MDJG)/MDJG;
ZSW:=(1+MHZF+止损比率)*MDJG;
ZY:=HIGH>(1+止盈比率)*REF(LOW,BARSLAST(BKO));
ZS:=CLOSE<ZSW;
BKTS:=BARSLAST(BKO);
SKTS:=BARSLAST(SKO);
KNBS:=IF(BKTS<SKTS,2,0);
BK:=CROSS(KNBS,1);
SK:=CROSS(1,KNBS);
ZYS:=ZY+ZS AND SK;
JYK:ZYS*KSX;
注意未来函数

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  有需要帮忙请点击这里留言!!!进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容