交易师操盘线指标公式-其他软件公式 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 股票公式>> 其他>> 其他软件公式>>正文内容

365bet送体验金

相关标签:殷保华操盘论指标公式 、 交易师操盘线指标公式 、 军师操盘指标公式 、 操盘要点指标公式 、 汇盈操盘决策指标公式 、 操盘出击指标公式 、 敢死队操盘指标公式 、 操盘bs点指标公式 、 通达信操盘线指标公式 、 操盘论势指标公式 、 益盟操盘线指标公式 、 操盘论势指标源码公式 、

 

名称: 经典操盘主图 类别:技术指标
 

原理解析:


 

 来源:程序化99( WWW.grahamobil.com )

源码:

 

 

VAR10:=100*(CLOSE-COST(10))/COST(10);
VAR1:=(CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))*100;
VAR2:=SMA(VAR1,4,1);
VAR3:=SMA(VAR2,2,1);
VAR4:=VOL/CAPITAL*34;
VAR5:=REF(VAR4,1);
主力建仓:IF(VAR3<8.5 AND VAR2<11,10,0),colorFF;
建仓力度:IF(VAR10<0,VAR10,1),LINETHICK1,colorFF00;
A:=IF(VAR10<0,VAR10,1);
B:=VAR10;
最低买:A>B,LINETHICK0,colorFFFF;
DRAWICON(A>B,2,4);
DRAWTEXT(A>B,5,'买'),ALIGN0,colorFFFF;
PPP:=MA(CLOSE,13);
KKK:=MA(CLOSE,34);
UUU:=MA(CLOSE,55);
JJJ:=PPP>KKK AND KKK>UUU;
二次攻击:=CLOSE>UUU AND JJJ AND CROSS(PPP,KKK);
DRAWICON(CLOSE>UUU AND JJJ AND CROSS(PPP,KKK),2,10);
DRAWTEXT(CLOSE>UUU AND JJJ AND CROSS(PPP,KKK),5,'二次攻击'),ALIGN0,color9100FA;
DRAWTEXTEX(1,1,210,650,' '),colorFF;
DRAWTEXTEX(1,1,252,650,' 【'),color80;
DRAWTEXTEX(1,1,270,650,' 最低买为1时关注,并且最低买变为0'),colorFF00FF;
DRAWTEXTEX(1,1,515,650,' 〓'),colorFFFF00;
DRAWTEXTEX(1,1,550,650,'次日空跌幅度仍然为1,可大胆买入'),colorFFFF;
DRAWTEXTEX(1,1,775,650,' 】'),color80;
DRAWTEXTEX(1,1,220,800,' '),color80;
DRAWTEXTEX(1,1,252,800,' 【'),color80;
DRAWTEXTEX(1,1,270,800,' 空跌幅度持续为0时,突然变为负值'),colorFFFF;
DRAWTEXTEX(1,1,515,800,' 〓'),colorFFFF00;
DRAWTEXTEX(1,1,550,800,'次日空跌幅度又变为正值,可短线买入'),colorFF;
DRAWTEXTEX(1,1,790,800,' 】'),color80;
DRAWTEXTEX(2,1,220,950,' '),colorFF00;
DRAWTEXTEX(2,1,252,950,' 【'),color80;
DRAWTEXTEX(2,1,270,950,' 主力建仓提醒为10,可关注此股'),colorFF;
DRAWTEXTEX(2,1,495,950,' 〓'),colorFFFF00;
DRAWTEXTEX(2,1,530,950,'只要数据为0时,可参照均线信号谨慎买入'),colorFFFFFF;
DRAWTEXTEX(2,1,810,950,' 】'),color80;
KK:=DYNAINFO(3);
GGC:=KK*0.1;
Y:=KK+GGC;
U:=KK-GGC;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,150,1,'▲涨停价:'+NUMTOSTR(Y,2)),colorFF;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,1,150,100,'▼跌停价:'+NUMTOSTR(U,2)),colorFF00;
预测最高:=MA(REF(HIGH,1)/REF(CLOSE,2),27)*REF(CLOSE,1);
预测最低:=MA(REF(LOW,1)/REF(CLOSE,2),27)*REF(CLOSE,1);
A5:=预测最高[SYSPARAM(1)];
RA5:=预测最低[SYSPARAM(1)-1];
A10:=预测最高[SYSPARAM(1)];
RA10:=预测最高[SYSPARAM(1)-1];
JT5:=IF(A5>RA5,'↑','↓');
JT10:=IF(A10>RA10,'↑','↓');
SZ1:=' 预测最高:'+NUMTOSTR(预测最高[SYSPARAM(1)],2)+JT10;
SZ2:='\n \n 预测最低:'+NUMTOSTR(预测最低[SYSPARAM(1)],2)+JT5;
DRAWTEXT(BARPOS=SYSPARAM(2),CLOSE,SZ1),ALIGN4,colorFFFF00;
DRAWTEXT(BARPOS=SYSPARAM(2),CLOSE,SZ2),ALIGN4,colorFF00;
AA:=(CLOSE*2+HIGH+LOW+OPEN)/5;
A0:=MA(CLOSE,5);
A1:=(EMA(AA,4)+MA(AA,8)+MA(AA,16))/3;
A2:=(EMA(AA,9)+MA(AA,18)+MA(AA,36))/3;
A3:=(EMA(AA,13)+MA(AA,26)+MA(AA,52))/3;
A4:=(EMA(AA,24)+MA(AA,48)+MA(AA,96))/3;
A5:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),5);
A6:=A5/4;
A7:=MAX(MAX(A1,A2),MAX(A3,A4));
A8:=MIN(MIN(A1,A2),MIN(A3,A4));
A9:=MIN(MIN(A1,A2),A3);
A10:=MAX(MAX(A1,A2),A3);
DRAWICON(A6>22.5 AND REF(A0,1)>REF(A0,2) AND A0<REF(A0,1),HIGH+0.2,2),colorFF00;
DRAWICON(CROSS(A2,A4) AND A3>REF(A3,1) AND A0>REF(A0,2) AND (A1-A4)/A4<0.02,A2,1);
DRAWTEXT((A1-A2)/A2>0.04 AND A2>A3 AND LOW>A1 AND OPEN>CLOSE AND OPEN=HIGH,HIGH+0.4,'顶'),ALIGN0,colorF6BE0A;
DRAWTEXT(FILTER(A4>REF(A4,2) AND REF(A1,3)<REF(A3,3) AND CLOSE>OPEN AND (A10-A9)/A9<0.005,5),A8-0.05,'三\n线\n粘\n合'),ALIGN0,colorFF;
大胆买:FILTER(A4>REF(A4,2) AND REF(A1,3)<REF(A3,3) AND CLOSE>OPEN AND (A10-A9)/A9<0.005,5),colorFF;
大顶:A6>22.5 AND REF(A0,1)>REF(A0,2) AND A0<REF(A0,1),colorFF00;
短顶:(A1-A2)/A2>0.04 AND A2>A3 AND LOW>A1 AND OPEN>CLOSE AND OPEN=HIGH,colorFFFF00;
XS:=MA(LOW,5)*(1-5/100);
XS1:=MA(HIGH,5)*(1+5/100);
开盘逃:CROSS(XS1,CLOSE),colorFF00;
DRAWTEXT(CROSS(XS1,CLOSE),10,'开\n盘\n逃'),ALIGN0,colorFFFFFF;
A:=MA(WINNER(CLOSE),9)*100;
B:=CROSS(A,1.8);
D:=B>0;
DRAWICON(D,LOW-0.1,15),ALIGN0;
DRAWTEXT(D,LOW-0.09,'底\n方'),ALIGN0,colorFFFF00;
LC:=REF(CLOSE,1);
RSI:=(SMA(MAX(CLOSE-LC,0),6,1))/(SMA(ABS(CLOSE-LC),6,1))*100;
E:=CROSS(83,RSI);
DRAWICON(E,1,13),ALIGN0,colorFFFF;
DRAWTEXT(E,1,'顶\n圆'),ALIGN0,colorFF00;
顶圆:E,colorFF00;
主筹估算:=EMA(WINNER(CLOSE)*70,3);
散筹估算:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*70,3);
顶预警:主筹估算>55 AND 散筹估算<30,LINETHICK2,colorFFFF;
底预警:主筹估算<5 AND 散筹估算>10,colorFFFFFF;
DRAWTEXTEX(2,1,1,900,'出现顶预警时小心,信号消失卖出'),colorFFFF;
SAT:=IF(AMOUNT/CLOSE/(HHV(AMOUNT,20)/HHV(CLOSE,20))*100>100,100,AMOUNT/CLOSE/(HHV(AMOUNT,20)/HHV(CLOSE,20))*100);
红:=SAT>40 AND DAY=2;
晶:=SAT>20 AND SAT<=40 AND DAY=2;
黄:=SAT>5 AND SAT<=20 AND DAY=2;
绿:=SAT<=5 AND DAY=2;
VAR2:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR3:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR5:=(VAR2+2*VAR3+3*VAR4)/6;
VAR6:=MA(VAR5,3);
一号警:=IF(VAR6<一号,-20,0);
二号警:=IF(VAR6<=-8,-30,0);
VAR7:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
VAR8:=(CLOSE-VAR7)/VAR7*100;
VAR9:=REF(VAR8,1)<-40 AND VAR8>REF(VAR8,1) AND REF(VAR8,1)<REF(VAR8,2) AND VAR8-REF(VAR8,1)>2.5;
VARA:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VARB:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VARC:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VARD:=REF(CLOSE,1);
VARE:=(SMA(MAX(CLOSE-VARD,0),5,1))/(SMA(ABS(CLOSE-VARD),5,1))*100;
VARF:=(HIGH+LOW+CLOSE)/3;
VAR10:=(VARF-MA(VARF,14))/(0.015*AVEDEV(VARF,14));
VAR11:=(MA(AMOUNT,5)/MA(VOL,5)/100-MA(AMOUNT,110)/MA(VOL,110)/100)/(MA(AMOUNT,5)/MA(VOL,5)/100)<-0.273;
VAR12:=(CLOSE-MA(CLOSE,30))/MA(CLOSE,30)<-0.125;
VAR13:=VAR11 AND VAR12;
VAR14:=VARA>=-45 AND VARA<=-10 AND VARB<=-15 AND VARC<=-20;
VAR15:=COUNT(VAR14,1)>=1;
VAR16:=VAR13 AND VAR15;
VAR17:=1;
VAR18:=CLOSE*VOL;
VAR19:=EMA((MA(VAR18,4)/MA(VOL,4)+MA(VAR18,6)/MA(VOL,6)+MA(VAR18,13)/MA(VOL,13)+MA(VAR18,24)/MA(VOL,24))/4,1);
VAR1A:=1*VAR19;
VAR1B:=VAR19*0.92;
VAR1C:=EMA(CLOSE,34);
VAR1D:=MA(VAR1C*1.12,5);
VAR1E:=MA(VAR1C*0.82,5);
VAR1F:=CLOSE<VAR1E;
VAR20:=(MA(AMOUNT,5)*VAR17/MA(VOL,5)/100-MA(AMOUNT,125)/MA(VOL,125)/100)/(MA(AMOUNT,5)/MA(VOL,5)/100)<(-0.4)*VAR17;
VAR21:=HHV(HIGH,500);
VAR22:=LLV(LOW,500);
VAR23:=HHV(HIGH,250);
VAR24:=LLV(LOW,250);
VAR25:=HHV(HIGH,125);
VAR26:=LLV(LOW,125);
VAR27:=MA((VAR21*0.45+VAR23*0.5+VAR22+VAR24+VAR26)/5,35);
VAR28:=MA((VAR23*0.62+VAR26)/2,35);
VAR29:=MA((VAR23*0.75+VAR26)/2,18);
VAR2A:=MA((VAR23*0.93+VAR27*2+VAR28*1.8+VAR29*1.5)/4,18);
VAR2B:=MA((VAR21*0.95+VAR27*3+VAR28*2)/3,35);
VAR2C:=VAR27;
VAR2D:=VAR28;
VAR2E:=VAR29;
VAR2F:=VAR2A;
VAR30:=VAR2B;
VAR31:=CLOSE-REF(MA(CLOSE,20),11)<-2;
VAR32:=INDEXA/100000000;
VAR33:=INDEXADV;
VAR34:=INDEXDEC;
VAR35:=VAR18/(VAR18+VAR19)*VAR17;
VAR36:=VAR19/(VAR18+VAR19)*VAR17;
VAR37:=EMA(VAR35,10);
VAR38:=EMA(VAR36,10);
VAR39:=EMA(VAR37,10);
VAR3A:=EMA(VAR38,20);
VAR3B:=EMA(VAR37,3);
VAR3C:=EMA(VAR39,6);
VAR3D:=EMA(VAR3A,2);
VAR3E:=VAR3C-VAR3D;
VAR3F:=VAR3C-REF(VAR3C,1)>0 AND REF(VAR3C,1)-REF(VAR3C,2)<0;
VAR40:=IF(CROSS(VAR3B,VAR3C) AND VAR3C<=20,30,0);
VAR41:=VAR40;
VAR42:=SMA(AMOUNT/VOL/100,13,1)*1.15;
VAR43:=SMA(AMOUNT/VOL/100,13,1)*0.85;
VAR44:=CLOSE-REF(MA(CLOSE,20),11);
VAR45:=CLOSE<VAR1E AND VAR20 AND CLOSE<VAR43 OR CLOSE<VAR1E AND VAR31 AND VAR20 OR CLOSE<VAR1E AND CLOSE<VAR43 OR CLOSE<VAR1E AND VAR20 AND CLOSE<VAR43 OR VAR20 AND CLOSE<VAR2C OR VAR20 AND VAR31 AND VAR44<-1.5 OR VAR20 AND CLOSE<VAR1E OR VAR20 AND VAR44<-1.5 OR VAR31 AND CLOSE<VAR43 OR CLOSE<VAR2C AND VAR44<-1.5 OR CLOSE<VAR1E AND VAR31;
VAR46:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR47:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR48:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR49:=REF(CLOSE,1);
VAR4A:=(SMA(MAX(CLOSE-VAR49,0),5,1))/(SMA(ABS(CLOSE-VAR49),5,1))*100;
VAR4B:=(HIGH+LOW+CLOSE)/3;
VAR4C:=(VAR4B-MA(VAR4B,14))/(0.015*AVEDEV(VAR4B,14));
VAR4D:=(MA(AMOUNT,5)/MA(VOL,5)/100-MA(AMOUNT,110)/MA(VOL,110)/100)/(MA(AMOUNT,5)/MA(VOL,5)/100)<-0.273;
VAR4E:=(CLOSE-MA(CLOSE,30))/MA(CLOSE,30)<-0.125;
VAR4F:=VAR11 AND VAR12;
VAR50:=VAR2>=-45 AND VAR2<=-7 AND VAR3<=-11 AND VAR4<=-14;
VAR51:=COUNT(VAR50,1)>=1;
VAR52:=VAR4F AND VAR51;
VAR53:=VAR20 AND CLOSE<VAR1E AND VAR31 AND CLOSE<VAR2C AND VAR45 AND VAR52;
VAR54:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR55:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR56:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR57:=REF(CLOSE,1);
VAR58:=(SMA(MAX(CLOSE-VAR57,0),5,1))/(SMA(ABS(CLOSE-VAR57),5,1))*100;
VAR59:=(HIGH+LOW+CLOSE)/3;
VAR5A:=(VAR59-MA(VAR59,14))/(0.015*AVEDEV(VAR59,14));
VAR5B:=VAR54>=-15.8 AND VAR54<=-12.2 AND VAR55<=-20.8 AND VAR56<=-27.5 AND VAR58<=11.7 AND VAR5A<=-145;
VAR5C:=9.999999884842e+026;
VAR5D:=COST(10)*0;
VAR5E:=(MA(AMOUNT,5)/MA(VOL,5)/100-MA(AMOUNT,125)/MA(VOL,125)/100)/(MA(AMOUNT,5)/MA(VOL,5)/100);
VAR5F:=MA((LLV(LOW,45)-CLOSE)/(HHV(HIGH,45)-LLV(LOW,45))*100,5);
VAR60:=CROSS(-5,VAR5F) AND VAR5E<-0.4 AND (CLOSE-MA(CLOSE,30))/MA(CLOSE,30)<-0.19;
VAR61:=MA(CLOSE,3);
VAR62:=REF(CLOSE,2)*0.865;
VAR63:=REF(CLOSE,13)*0.772;
VAR64:=MIN(VAR62,VAR63);
VAR65:=100*VOL/CAPITAL;
VAR66:=MA(CLOSE,13);
VAR67:=IF((CLOSE-VAR64)/CLOSE<0.03 AND SUM(VAR65,5)/5<1.8,1,0);
出击:=IF(VAR9 OR VAR16 OR VAR53 OR VAR5B OR (CLOSE-VAR64)/CLOSE<0.03 AND SUM(VAR65,5)/5<1.8,10,0);
猎鹰柱线:红 OR 晶 OR 黄 OR 绿 OR 二次攻击 OR 出击,colorFF;
次日价格预测:=OPEN+(CLOSE-OPEN)/2;
今日价格:=REF(次日价格预测,1);
P:=SYSPARAM(1);
DRAWTEXTEX(CLOSE,1,850,10,'【今日价格预测】'+NUMTOSTR(今日价格[P],2)+''),colorFF00FF;
DRAWTEXTEX(CLOSE,1,850,100,'【次日价格预测】'+NUMTOSTR(次日价格预测[P],2)+''),colorFFFF;
DRAWTEXTEX(2,1,850,220,'前收阳预测价格为买入价'),colorFF;
DRAWTEXTEX(2,1,850,320,'前收阴预测价格为买出价'),colorFF00;

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  有需要帮忙请点击这里留言!!!进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容