平台横盘突破指标-通达信公式 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 股票公式>> 通达信>> 通达信公式>>正文内容

365bet送体验金

相关标签:通达信横盘突破指标 、 通达信向下突破指标 、 通达信箱体突破指标 、 通达信龙腾突破指标 、 通达信单峰突破指标 、 通达信量价突破指标 、 通达信指标公式源码 、 通达信指标公式大全 、 通达信中枢指标公式 、 通达信选股指标公式 、 通达信突破预警公式 、 通达信分时指标公式 、

 

 

原理解析:


 

 来源:程序化99( WWW.grahamobil.com )

源码:

 

 

平台突破VAR1AA:=((2)*(CLOSE)+OPEN+HIGH+LOW)/(5);
VAR2AA:=VOL;
上升价格线:(SUM((VAR1AA)*(VAR2AA),8))/(SUM(VAR2AA,8)),COLOR0000FF;
下降价格线:LLV(上升价格线,8),COLOR00FF00;
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
DRAWTEXT(FILTER((VAR4AA>90),34),(LOW)*(0.94999998),'加仓'),COLOR00FFFF;
DRAWTEXT(FILTER((VAR4AA>90),34),(LOW)*(0.99000001),''),COLOR00FFFF;
A1AA:=9;
A2AA:=(REF(CLOSE,A1AA+1)<CLOSE);
DRAWTEXT(FILTER((A2AA>0),34),(HIGH)*(1.02),''),COLORGREEN;
VAR1:=REF(CLOSE,1);
VAR2:=MA(CLOSE,5);
VAR3:=SMA(MAX(CLOSE-VAR1,0),6,1)/SMA(ABS(CLOSE-VAR1),6,1)*100;
VAR4:=SMA(MAX(CLOSE-VAR1,0),12,1)/SMA(ABS(CLOSE-VAR1),12,1)*100;
VAR5:=SMA(MAX(CLOSE-VAR1,0),24,1)/SMA(ABS(CLOSE-VAR1),24,1)*100;
VAR6:=IF(CROSS(VAR3,VAR5),LOW,REF(LOW,BARSLAST(CROSS(VAR3,VAR5))));
VAR7:=IF(CROSS(VAR5,VAR3),HIGH,REF(HIGH,BARSLAST(CROSS(VAR5,VAR3))));
VAR8:=IF(CLOSE>=MA(CLOSE,20),80,50);
VAR9:=IF(CLOSE>=MA(CLOSE,20),50,20);
VARA:=IF(VAR3<VAR8 AND REF(VAR3,1)>=VAR8,HHV(REF(HIGH,1),BARSLAST(VAR3>=VAR8 AND REF(VAR3,1)<VAR8)-1),REF(HHV(REF(HIGH,1),BARSLAST(VAR3>=VAR8 AND REF(VAR3,1)<VAR8)-1),BARSLAST(VAR3<VAR8 AND REF(VAR3,1))));
VARB:=IF(HIGH>VARA,LOW,REF(LOW,BARSLAST(HIGH>VARA)));
VARC:=IF(HIGH>VARA,VAR3,REF(VAR3,BARSLAST(HIGH>VARA)));
VARD:=IF(HIGH>VARB AND VAR3<VARC AND VAR3<VAR5,HIGH,REF(HIGH,BARSLAST(HIGH>VARB AND VAR3<VARC AND VAR3<VAR5)));
VARE:=IF(VAR3>VAR9 AND REF(VAR3,1)<=VAR9,LLV(REF(LOW,1),BARSLAST(VAR3<=VAR9 AND REF(VAR3,1)>VAR9)-1),REF(LLV(REF(LOW,1),BARSLAST(VAR3<=VAR9 AND REF(VAR3,1)>VAR9)-1),BARSLAST(VAR3>VAR9 AND REF(VAR3,1))));
VARF:=IF(LOW<VARE,HIGH,REF(HIGH,BARSLAST(LOW<VARE)));
VAR10:=IF(LOW<VARE,VAR3,REF(VAR3,BARSLAST(LOW<VARE)));
VAR11:=IF(LOW<VARF AND VAR3>VAR10 AND VAR3>VAR5,LOW,REF(LOW,BARSLAST(LOW<VARF AND VAR3>VAR10 AND VAR3>VAR5)));
支撑线: VAR11,COLORFF00FF ,LINETHICK2 ;
压力线: VARD, COLORBLUE,LINETHICK2 ;
DING:=MAX(O,C);{实顶}
DI:=MIN(O,C);{实底}
YANG:=(DI>=REF(DING,1)) OR (C>O AND NOT(DING<=REF(DI,1))) OR (C>REF(C,1) AND C=O) OR (C=REF(C,1) AND C=O AND REF(DING,1)=C);{阳线}
YIN:=NOT(YANG);
{YIN:=(C<O AND NOT(DI>=REF(DING,1))) OR (C>O AND DING<=REF(DI,1)) OR (C<REF(C,1) AND C=O) OR (C=REF(C,1) AND C=O AND REF(DI,1)=C);{阴线}}
YANGSHENG:YANG AND C>=REF(DING,BARSLAST(YIN)) AND (V>REF(V,BARSLAST(YIN)) OR (BETWEEN(V,REF(V,BARSLAST(YIN))*0.95,REF(V,BARSLAST(YIN))*1.05))),NODRAW;
LIANGJIABI:V/C,NODRAW;
MALIANGJIABI:MA(LIANGJIABI,3),NODRAW;
LIANGJIABIXISHU:=1.5;
BLZ:=V>REF(V,1)*1.5;

PLZ:=BETWEEN(V,REF(V,1)*0.95,REF(V,1)*1.05) OR BETWEEN(V,REFX(V,1)*0.95,REFX(V,1)*1.05) OR
(BETWEEN(V,REF(V,2)*0.95,REF(V,2)*1.05) AND V>REF(V,1)*1.2) OR
(BETWEEN(V,REF(V,3)*0.95,REF(V,3)*1.05) AND V>REF(MA(V,2),1)*1.2 AND V>REF(HHV(V,2),1)) OR
(BETWEEN(V,REF(V,4)*0.95,REF(V,4)*1.05) AND V>REF(MA(V,3),1)*1.2 AND V>REF(HHV(V,3),1)) OR
(BETWEEN(V,REF(V,5)*0.95,REF(V,5)*1.05) AND V>REF(MA(V,4),1)*1.2 AND V>REF(HHV(V,4),1)) OR
(BETWEEN(V,REF(V,6)*0.95,REF(V,6)*1.05) AND V>REF(MA(V,5),1)*1.2 AND V>REF(HHV(V,5),1)) OR
(BETWEEN(V,REF(V,7)*0.95,REF(V,7)*1.05) AND V>REF(MA(V,6),1)*1.2 AND V>REF(HHV(V,6),1)) OR
(BETWEEN(V,REF(V,8)*0.95,REF(V,8)*1.05) AND V>REF(MA(V,7),1)*1.2 AND V>REF(HHV(V,7),1)) OR
(BETWEEN(V,REF(V,9)*0.95,REF(V,9)*1.05) AND V>REF(MA(V,8),1)*1.2 AND V>REF(HHV(V,8),1)) OR
(BETWEEN(V,REF(V,10)*0.95,REF(V,10)*1.05) AND V>REF(MA(V,9),1)*1.2 AND V>REF(HHV(V,9),1)) OR
(BETWEEN(V,REF(V,11)*0.95,REF(V,11)*1.05) AND V>REF(MA(V,10),1)*1.2 AND V>REF(HHV(V,10),1)) OR
(BETWEEN(V,REF(V,12)*0.95,REF(V,12)*1.05) AND V>REF(MA(V,11),1)*1.2 AND V>REF(HHV(V,11),1));
GLZ:=V=HHV(V,3) AND V=REFX(HHV(V,3),2);
TLZ:=(V*1.1<REFX(V,1) AND REFX(V,1)*1.1<REFX(V,2)) OR (V>REF(V,1)*1.1 AND V*1.1<REFX(V,1)) OR (V>REF(V,1)*1.1 AND REF(V,1)>REF(V,2)*1.1);
JSLS:=C<=REFX(C,1) AND REFX(C,1)<=REFX(C,2) AND LIANGJIABI>REFX(LIANGJIABI,1) AND REFX(LIANGJIABI,1)>REFX(LIANGJIABI,2);
JZ:=BLZ OR GLZ OR PLZ OR TLZ,NODRAW;
JJZ:=CURRBARSCOUNT>=4 AND YANG AND (YANGSHENG) AND JZ AND REFX(LLV(DI,3),3)>=DI AND (REFX(MA(LIANGJIABI,3),3)<=LIANGJIABIXISHU*LIANGJIABI OR REFX(JSLS,1)) AND REFX(C,3)>=DING,NODRAW;
HJZ1:=JJZ AND REFX(MA(C,3),3)>=DING AND REFX(MA(LIANGJIABI,3),3)<=LIANGJIABI AND REFX(YANG,3);
HJZ2:=YANG AND YANGSHENG AND JZ AND REFX(DI,1)>=DI AND REFX(JJZ,2) AND REFX(C,2)>DING AND REFX(LIANGJIABI,1)<LIANGJIABI;
HJZ3:=YANG AND YANGSHENG AND JZ AND REFX(LLV(DI,2),2)>=DI AND REFX(JJZ,3) AND REFX(C,3)>DING AND REFX(MA(LIANGJIABI,2),2)<LIANGJIABI;
HJZ4:=JJZ AND REFX(LLV(DI,3),3)>=DING AND REFX(MA(LIANGJIABI,3),3)<=LIANGJIABI AND REFX(YANG,3) AND (REFX(YANG,1) OR REFX(YANG,2));
WP:JJZ OR HJZ1 OR HJZ4 OR HJZ2 OR HJZ3,NODRAW;
CONDJJZ:=JJZ AND REF(NOT(WP),1);
CONDHJZ1:=(HJZ1 OR HJZ2 OR HJZ3) AND REF(NOT(WP),1);
STICKLINE(CONDJJZ,C,O,1,0),COLORYELLOW;
STICKLINE(CONDHJZ1,C,O,1,0),COLORMAGENTA;
DRAWTEXT(HJZ4 AND REF(NOT(HJZ4),1),L*0.98,'H'),COLORRED;
DRAWLINE(CONDJJZ,DING,REF(CONDJJZ,1),REF(DING,1),1),COLORBROWN;
DRAWLINE(CONDJJZ,DI,REF(CONDJJZ,1),REF(DI,1),1),COLORBROWN;
DRAWLINE(CONDHJZ1,DING,REF(CONDHJZ1,1),REF(DING,1),1),COLORBROWN;
DRAWLINE(CONDHJZ1,DI,REF(CONDHJZ1,1),REF(DI,1),1),COLORBROWN;
VOL5:=MA(VOL,5),COLORWHITE;
VOL10:=MA(VOL,10),COLORYELLOW;
VOL40:=MA(VOL,40),COLORFF00FF ;
MA5:=MA(CLOSE,5),COLORWHITE;
MA10:=MA(CLOSE,10),COLORYELLOW;
MA20:=MA(CLOSE,20),COLORMAGENTA;
MA60:=MA(CLOSE,60),COLORGREEN;
MA120:=MA(CLOSE,120),COLORLIMAGENTA;
MA240:=MA(CLOSE,240),COLORBLUE,NODRAW;
量托:=VOL5>=VOL40 AND CROSS(VOL10,VOL40) AND REF(VOL10,1)<REF(VOL40,1);
DRAWTEXT(量托,L-0.012,'量托'),COLORWHITE;
AA1:=BARSLAST(MA60>MA20 AND (MA20=MA10 OR MA20>MA10));
BB1:=REF(COUNT(C<MA60,AA1)=AA1,1);
CC1:=CROSS(C,MA60) AND VOL>MA(VOL,5) AND (C-REF(C,1))/REF(C,1)*100>3;
芙蓉出水:=BB AND CC1,COLOR00FF00;
DRAWTEXT(芙蓉出水,H+0.12,'芙蓉出水'),COLORFF00FF;
STICKLINE(芙蓉出水,H,L,0.5,1),COLORFF00FF;
STICKLINE(芙蓉出水,O,C,3,1),LINETHICK2,COLORFF00FF;
MA1:=MA(CLOSE,14);
MA2:=MA(CLOSE,25);
MA3:=MA(CLOSE,99);
ZJ:=AMOUNT/10000;{资金}
TM:=V-MA(V,10);{量填满}
一穿三:=MA1>O AND MA2>O AND MA3>O AND MA1<C AND MA2<C AND MA3<C AND CLOSE>OPEN ;
DRAWTEXT(一穿三,L-0.012,'穿'),COLORFF00FF;
TY:=C;
A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);
前期高位:=REF(C,BARSLAST(HD)),COLOR00FF00,POINTDOT;
STICKLINE(C,前期高位,前期高位,8,0),COLORRED;
STICKLINE((HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667,H,C,0.8,0),COLORBLUE;
三日不破:=MIN(MIN(L,REF(L,1)),REF(L,2))>=REF(L,3);
三日量缩:=(MAX(MAX(V,REF(V,1)),REF(V,2))<REF(V,3));
三日价涨A:=C>=REF(C,1);
三日价涨B:=C<REF(C,1);
三日价涨C:=MIN(MIN(C,REF(C,1)),REF(C,2))>=REF(L,3);
TIM:=IF(DATE<1140214,1,0);
缩倍柱:=(VOL*1.95<=REF(VOL,1))*TIM;
百日低量:=(VOL=LLV(VOL,100))*TIM;
倍量柱:=C>REF(C,1)*1.04 AND (VOL>=1.9*REF(VOL,1))*TIM;
四日前倍量柱:=(REF(VOL,3)>1.9*REF(VOL,4))*TIM;
四日前高量柱:=(REF(VOL,3)>=REF(VOL,4) AND REF(VOL,3)<1.9*REF(VOL,4) AND 三日量缩)*TIM;
前三引用不成立:=COUNT(REF(四日前倍量柱,1) AND (REF(三日不破,1) OR REF(三日价涨C,1)),3)=0 AND COUNT(REF(四日前高量柱,1) AND (REF(三日不破,1) OR REF(三日价涨C,1)),3)=0;
倍量黄金柱:=四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
高量黄金柱:=四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
黄金柱:=倍量黄金柱 OR 高量黄金柱;
次倍量黄金柱:=NOT(黄金柱) AND 四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次高量黄金柱:=NOT(黄金柱) AND 四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次黄金柱:=次倍量黄金柱 OR 次高量黄金柱;
准倍量黄金柱:=NOT(黄金柱 OR 次黄金柱) AND 四日前倍量柱 AND ((三日量缩 AND 三日价涨C) OR (COUNT(倍量柱,3)>=1 AND 三日不破)) AND 前三引用不成立;
准高量黄金柱:=NOT(黄金柱 OR 次黄金柱) AND 四日前高量柱 AND (三日量缩 AND 三日价涨C) AND 前三引用不成立;
准黄金柱:=准倍量黄金柱 OR 准高量黄金柱;
倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱) AND 四日前倍量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱) AND 四日前高量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
将军柱:=倍量将军柱 OR 高量将军柱;
次倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱) AND 四日前倍量柱 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱) AND 四日前高量柱 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次将军柱:=次倍量将军柱 OR 次高量将军柱;
准倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱) AND 四日前倍量柱 AND 三日价涨C AND 前三引用不成立;
准高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱) AND 四日前高量柱 AND 三日价涨C AND 前三引用不成立;
准将军柱:=准倍量将军柱 OR 准高量将军柱;
BACKSET100:=BACKSET(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱 OR 准将军柱,4);
FILTER100:=FILTER(BACKSET100,3),NODRAW;
BACKSET101:=BACKSET(黄金柱,4);
FILTER101:=FILTER(BACKSET101,3);
BACKSET102:=BACKSET(次黄金柱,4);
FILTER102:=FILTER(BACKSET102,3);
BACKSET103:=BACKSET(准黄金柱,4);
FILTER103:=FILTER(BACKSET103,3);
BACKSET104:=BACKSET(将军柱,4);
FILTER104:=FILTER(BACKSET104,3);
BACKSET105:=BACKSET(次将军柱,4);
FILTER105:=FILTER(BACKSET105,3);
BACKSET106:=BACKSET(准将军柱,4);
FILTER106:=FILTER(BACKSET106,3);
黄金线下影线:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<=REF(L,3);
黄金线实体下端:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<=MIN(REF(C,3),REF(O,3)) AND MIN(MIN(L,REF(L,1)),REF(L,2))>REF(L,3),LINETHICK0;
黄金线上影线:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>=REF(H,3);
黄金线实体上端:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>=MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<REF(H,3);
黄金线实体中间:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3));
黄金线实体中间1:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3)) AND REF(L,2)=MIN(MIN(L,REF(L,1)),REF(L,2));
黄金线实体中间2:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3)) AND REF(L,1)=MIN(MIN(L,REF(L,1)),REF(L,2));
黄金线实体中间3:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3)) AND L=MIN(MIN(L,REF(L,1)),REF(L,2));
BACKSET201:=BACKSET(黄金线下影线,4);
FILTER201:=FILTER(BACKSET201,3),NODRAW;
BACKSET202:=BACKSET(黄金线实体下端,4);
FILTER202:=FILTER(BACKSET202,3),NODRAW;
BACKSET203:=BACKSET(黄金线上影线,4);
FILTER203:=FILTER(BACKSET203,3),NODRAW;
BACKSET204:=BACKSET(黄金线实体上端,4);
FILTER204:=FILTER(BACKSET204,3),NODRAW;
BACKSET205:=BACKSET(黄金线实体中间,4);
FILTER205:=FILTER(BACKSET205,3),NODRAW;
BACKSET2051:=BACKSET(黄金线实体中间1,4);
FILTER2051:=FILTER(BACKSET2051,3),NODRAW;
BACKSET2052:=BACKSET(黄金线实体中间2,4);
FILTER2052:=FILTER(BACKSET2052,3),NODRAW;
BACKSET2053:=BACKSET(黄金线实体中间3,4);
FILTER2053:=FILTER(BACKSET2053,3),NODRAW;
BT201:=IF(BARSLAST(FILTER201)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER201));
BT202:=IF(BARSLAST(FILTER202)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER202));
BT203:=IF(BARSLAST(FILTER203)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER203));
BT204:=IF(BARSLAST(FILTER204)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER204));
BT205:=IF(BARSLAST(FILTER205)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER205));
BT2051:=IF(BARSLAST(FILTER2051)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER2051));
BT2052:=IF(BARSLAST(FILTER2052)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER2052));
BT2053:=IF(BARSLAST(FILTER2053)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER2053));
最近黄金线:=MIN(MIN(MIN(MIN(MIN(MIN(BT201,BT202),BT203),BT204),BT2051),BT2052),BT2053);
DAY1:=SUMBARS(FILTER100,1),NODRAW;
HJX1_1:=IF(SUMBARS(FILTER201,1)=DAY1,IF(DAY1=1,LOW,REF(LOW,DAY1-1)),0),NODRAW;
HJX1_2:=IF(SUMBARS(FILTER202,1)=DAY1,IF(DAY1=1,MIN(C,O),MIN(REF(C,DAY1-1),REF(OPEN,DAY1-1))),0),NODRAW;
HJX1_3:=IF(SUMBARS(FILTER203,1)=DAY1,IF(DAY1=1,HIGH,REF(HIGH,DAY1-1)),0),NODRAW;
HJX1_4:=IF(SUMBARS(FILTER204,1)=DAY1,IF(DAY1=1,MAX(C,O),MAX(REF(C,DAY1-1),REF(OPEN,DAY1-1))),0),NODRAW;
HJX1_51:=IF(SUMBARS(FILTER2051,1)=DAY1,IF(DAY1=2,LOW,IF(DAY1<2,DRAWNULL,REF(LOW,DAY1-2))),0),NODRAW;
HJX1_52:=IF(SUMBARS(FILTER2052,1)=DAY1,IF(DAY1=3,LOW,IF(DAY1<3,DRAWNULL,REF(LOW,DAY1-3))),0),NODRAW;
HJX1_53:=IF(SUMBARS(FILTER2053,1)=DAY1,IF(DAY1=4,LOW,IF(DAY1<4,DRAWNULL,REF(LOW,DAY1-4))),0),NODRAW;
黄金线:HJX1_1+HJX1_2+HJX1_3+HJX1_4+HJX1_51+HJX1_52+HJX1_53,COLORYELLOW,NODRAW;
立桩量:=VOL=HHV(VOL,40) AND VOL>1.9*REF(VOL,1);
立桩量三日突破:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));
立桩量三日不破:=BARSLAST(立桩量)=3 AND REF(LOW,3)<=MIN(MIN(C,REF(C,1)),REF(C,2));
BACKSET300:=BACKSET(立桩量三日不破,4);
BACKSET301:=BACKSET(立桩量三日突破,4);
立桩量成立:=FILTER(BACKSET300,3) AND BACKSET301 AND 立桩量;
DRAWTEXT(立桩量成立,HIGH*1.01,'↙立桩量'),COLORRED;
DRAWTEXT(FILTER101,LOW*0.986,'↖黄金柱'),COLORYELLOW;
DRAWTEXT(FILTER102,LOW*0.986,'↖次黄金柱'),COLORYELLOW;
DRAWTEXT(FILTER104,LOW*0.986,'↖将军柱'),COLORYELLOW;{STICKLINE(CLOSE/REF(C,1)>=1.09,O,C,2.7,0),COLORYELLOW;};DRAWICON(CROSS(C,前期高位),前期高位,1);{突破前期高位};N1:=20;
N2:=10;
N3:=5;LAA:=REF(H,N2)=HHV(H,2*N2+1);
LQY:=BACKSET(LAA,N2+1);
LCC:=FILTER(LQY,N2) AND H=HHV(H,N2+1);
LDDD:=BARSLAST(LCC);
LGDTS:=IF(LCC,CURRBARSCOUNT,0);
LDINGBU:=IF(LDDD,REF(H,LDDD),H);{顶部}
LDINGBUTS:=IF(LDDD,REF(LGDTS,LDDD),LGDTS);
LDINGBU1:=REF(LDINGBU,LDDD+1);
LGDCS1:=CONST(LDINGBUTS);
LDINGBUTS1:=REF(LDINGBUTS,LDDD+1);
LGDCS2:=CONST(LDINGBUTS1);
LDINGBU2:=REF(LDINGBU1,LDDD+1);
LMM:=IF(CURRBARSCOUNT>LGDCS2,0,1);
压力:DRAWLINE(CURRBARSCOUNT=LGDCS2,H,CURRBARSCOUNT=LGDCS1,H,1) COLORWHITE;
DRAWLINE(CURRBARSCOUNT=LGDCS2,H,ISLASTBAR,REF(H,LGDCS2-1),1),COLOR0055FF,POINTDOT;
DRAWLINE(CURRBARSCOUNT=LGDCS1,H,ISLASTBAR,REF(H,LGDCS1-1),1),COLORYELLOW,POINTDOT;

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  有需要帮忙请点击这里留言!!!进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容