简化指标自动化编辑谢谢老师-365bet送体验金财经知识 -程序化交易(grahamobil.com) - 365bet送体验金

365bet送体验金

  • 咨询内容:  开多

    一小时均线多头排列10大于20大于40大于60大于80大于120  

    20均线斜率持续加大  

     

    加载五分钟  

    五分钟20大于40大于60  

    5分钟开盘价格下行到前一K线的二分之一以下,未到前一K线最低价,开始反向上行到二分之一处(前K线二分之一到下行终点的距离一半)开多单一手,过前一K线高点后设止盈为前一K线高点,下穿布林线上轨平仓,止损价为前一K线低点  

     

    开空  

    小时均线空头排列10小于20小于30小于40小于50小于60小于80小于100小于120  

    加载五分钟  

     

    20均线斜率持续缩小  

    五分钟均线20小于40小于60  

    五分钟开票价上行到前K线二分之一以上,未到前一K线最高价,开始反向下行二分之一处(前K线二分之一到上行行终点的距离一半)开空单一手,过前一K线的低点后设为止盈价,上窜布林线下轨平仓,止损为前K线高点
    <!--[if !supportLineBreakNewLine]-->
    <!--[endif]-->

     

     来源:程序化99

  • 365bet送体验金技术人员: 核实一下:
    前一K线的二分之一,是指K线实体部分的二分之一,还是整根K线包括影线的二分之一?

     

     来源: WWW.grahamobil.com

  • 365bet送体验金客服: 回复老师,都不是。
    是收盘价到整根K线的最高点或是最低点,如果是多就是收盘价到最低点,如果空就是收盘价到最高点
    谢谢您老师,节日快乐!

     

  • 网友回复: 参考:
    以下部分需单独保存为指标,并命名为ZB:

    MA10:MA(C,10);  

    MA20:MA(C,20);  

    MA40:MA(C,40);  

    MA60:MA(C,60);  

    MA80:MA(C,80);  

    MA100:MA(C,100);  

    MA120:MA(C,120);  

    AA:=MA10>MA20&&MA20>MA40&&MA40>MA60&&MA60>MA80&&MA80>MA120;  

    BB:=MA10<MA20&&MA20<MA40&&MA40<MA60&&MA60<MA80&&MA80<MA100&&MA100<MA120;  

    CC:=(MA20-REF(MA20,1))/(REF(MA20,1))>(REF(MA20,1)-REF(MA20,2))/REF(MA20,2);  


     

    以下模型加载到5分钟周期上:  

    MID:MA(CLOSE,26);  

    TMP2:=STD(CLOSE,26);  

    TOP:MID+2*TMP2;//布林通道上轨  

    BOTTOM:MID-2*TMP2;//布林通道下轨  

    MA20:MA(C,20);  

    MA40:MA(C,40);  

    MA60:MA(C,60);  

    DD:=(MA20-REF(MA20,1))/(REF(MA20,1))<(REF(MA20,1)-REF(MA20,2))/REF(MA20,2);  

    #IMPORT[HOUR,1,ZB] AS TJ  

    TJ1:=TJ.AA;  

    TJ2:=TJ.CC;  

    TJ3:=TJ.BB;  

    TJ4:=MA20>MA40&&MA40>MA60;  

    TJ5:=MA20<MA40&&MA40<MA60;  

    QT1:=(REF(C,1)+REF(H,1))/2;  

    QT2:=(REF(C,1)+REF(L,1))/2;  

    TJ1&&TJ2&&TJ4&&O<QT2&&O>REF(L,1)&&C>=(QT2+REF(L,1))/2,BK(1);  

    BKVOL>0&&(C>REF(H,1)||CROSSDOWN(C,TOP)||C<REF(L,1)),SP(BKVOL);  

    TJ3&&DD&&TJ5&&O>QT1&&O<REF(H,1)&&C<=(REF(H,1)+QT1)/2,SK(1);  

    SKVOL>0&&(C<REF(L,1)||CROSS(C,BOTTOM)||C>REF(H,1)),BP(SKVOL);   


    关于跨周期模型,您可以参考该贴,了解跨周期模型的编写方法:【编写技巧】:wh8 跨周期编写方法介绍


    另外,该模型需要在WH8当中使用,WH8下载地址:https://www.wenhua.com.cn/


     

  • 网友回复:  老师帮我改进一下,好吗?谢谢老师
  • 加载五分钟K线 五分钟K线的60均线线斜率缓慢持平或加大中 5分钟K线价格到达到前一K线(最高价到最低价)的二分之一以下,未到前一五分钟K线最低价,开始反向上运行到(前K线收盘价到反向上行起点的距离)二分之一处,开多单一手,符合条件连续开仓,所有K线过前一K线高点后设止损为前一K线高点价,连续两个五分钟K线收盘价大于布林线上轨后五分钟K线收盘价下穿布林线上轨五分钟多单全部平仓,所有多单止损价为每根K线前一K线低点, 加载五分钟K线五分钟K线的60均线线斜率缓慢持平或缩小

    五分钟K线价格达到前K线(最高价到最低价)二分之一以上,未到前一K线最高价,开始反向下行到(前K线收盘价到反向下行起点的距离)二分之一处,开空单一手,符合条件连续开仓,所有K线过前一K线的低点后设为止损价,连续两个五分钟K线收盘价小于布林线下轨后五分钟K线收盘价上窜布林线下轨全部空单平仓,所有空单K线止损为前K线高点   

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  点击这里给我发消息进行 有偿 编写!不贵!点击查看价格!


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容