生命线通道主图指标公式源码-大智慧公式 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 股票公式>> 大智慧>> 大智慧公式>>正文内容

365bet送体验金

相关标签:通达信生命线主图源码 、 大智慧股票指标生命线 、 大智慧指标公式源码 、 大智慧主升浪公式源码 、 搏杀生命线指标源码 、 大智慧l2主图指标公式 、 搏杀生命线主图指标 、 主力主图指标公式源码 、 超宏主图指标公式源码 、 macd主图指标源码公式 、 操盘线生命线公式源码 、 趋势通道指标公式源码 、 神龙通道指标公式源码 、 大智慧分时通道源码 、 大智慧ddx指标源码 、

 

 

 

原理解析:


 

 来源:程序化99( WWW.grahamobil.com )

源码:

 

 

VAR1:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100;
VAR2:=CLOSE>OPEN AND OPEN-LOW>HIGH-CLOSE;
VAR3:=REF(VAR1,1)<-34 AND VAR2;
VAR4:=REF(VAR1,1)<-34 AND CLOSE>OPEN AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*1000>20;
VAR5:=FILTER(VAR3 OR VAR4,3);
VAR6:=OPEN>CLOSE AND HIGH-(IF(CLOSE>OPEN,CLOSE,OPEN))>IF(OPEN<CLOSE,OPEN,CLOSE)-LOW;
VAR7:=REF(VAR1,1)>ABS(-34) AND VAR6;
VAR8:=REF(VAR1,1)>ABS(-34) AND CLOSE<OPEN AND (REF(CLOSE,1)-CLOSE)/REF(CLOSE,1)*1000>20;
VAR9:=FILTER(VAR7 OR VAR8,3);
VARA:=REF(VAR1,1)<-13 AND VAR2;
VARB:=REF(VAR1,1)<-13 AND CLOSE>OPEN AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*1000>20;
VARC:=FILTER(VARA OR VARB,3);
VARD:=REF(VAR1,1)>ABS(-13) AND VAR6;
VARE:=REF(VAR1,1)>ABS(-13) AND CLOSE<OPEN AND (REF(CLOSE,1)-CLOSE)/REF(CLOSE,1)*1000>20;
VARF:=FILTER(VARD OR VARE,3);
DRAWICON(VAR5*VAR1>0,LOW,1);
DRAWICON(VAR9*VAR1>0,HIGH,2);
VAR10:=(2*CLOSE+HIGH+LOW+OPEN)/5;
A1:(EMA(VAR10,8)+EMA(VAR10,13)+EMA(VAR10,34)+EMA(VAR10,55))/4;
A2:EMA(A1,3);
A3:EMA(A2,8);
A4:EMA(A3,13);
生命线:EMA(CLOSE,60),CROSSDOT;
VAR11:=LLV(LOW,13);
VAR12:=HHV(HIGH,8);
VAR13:=EMA((VAR10-VAR11)/(VAR12-VAR11)*100,13);
VAR14:=EMA(0.667*REF(VAR13,1)+0.333*VAR13,8);
VAR15:=EMA(VAR10,13)-EMA(VAR10,34);
VAR16:=EMA(VAR15,5);
VAR17:=(-2)*(VAR15-VAR16)*3.8;
VAR18:=(2*CLOSE+LOW+HIGH)/4;
顶线:EMA(VAR18,34)*1.1,colorFFFF10;
底线:EMA(VAR18,34)*0.866;
顶偏离:=(CLOSE-MA(顶线,2))/MA(CLOSE,3)*1000;
底偏离:=(CLOSE-MA(底线,2))/MA(CLOSE,3)*1000;
DRAWTEXT(ABS(底偏离)<15 AND MA(CLOSE,1)<底偏离,LOW,'底'),color10FF10;
DRAWTEXT(ABS(顶偏离)<15 AND MA(CLOSE,1)>顶偏离,HIGH,'顶'),color10FFFF;CXH:=STRTONUM(STRRIGHT(DATESTR(CURRENTDATE),1));
WARNING('http://www.grahamobil.com',CURRENTTIME>180000 and (CXH=1 OR CXH=6));
DRAWTEXTREL(10 ,10 ,'指标公式');

 

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  有需要帮忙请点击这里留言!!!进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容