机构吃货趋势强度公式源码-大智慧公式 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 股票公式>> 大智慧>> 大智慧公式>>正文内容

365bet送体验金

相关标签:大智慧自编公式 、 大智慧的机构吃货准吗 、 大智慧机构吃货和吐货 、 大智慧指标公式 、 大智慧公式编写语法 、 球大智慧公式编写 、 昊子大智慧公式编写教程 、 自编大智慧公式 函数 、 大智慧公式编辑器 、 大智慧app 编辑指标公式 、 大智慧指标编写 、 大智慧公式生成器 、

 

 

原理解析:


 

 来源:程序化99( WWW.grahamobil.com )

源码:

 

 

INPUT:N1(5,2,100),N2(26,2,100),N3(45,2,100),N4(7,2,100),换手率(5,1,20);
gIFF :=EMA(CLOSE,5) - EMA(CLOSE,26);
gEA := EMA(gIFF,4);
DIF1:=EMA(CLOSE,N1)-EMA(CLOSE,N2);
DEA1:=EMA(DIF1,N3);
MACD:=2*(DIF1-DEA1);
MACDMA:=MA(MACD,N1);
持股:STICKLINE(MACD>MACDMA AND MACD>0,MACD,MACDMA,8,0),COLOR9800FF;
零下 :0,COLORGREEN;
压力:MA(REF(HHV(MACD,63),1),2),COLORWHITE,LINETHICK1;
短压:MA(REF(HHV(MACD,1),1),1),COLORRED;多:=EMA(C*5,7) - EMA(C*5,13);
空:=EMA(多,2);
Vd:=CROSS(空,多);
DRAWTEXT(Vd,短压,'跌'),coloryellow;
上趋势:=MA(LOW,20)*1.2;
次上趋势:=MA(LOW,20)*1.1;
次下趋势:=MA(HIGH,20)*0.9;
下趋势:=MA(HIGH,20)*0.8;
ZD:=(C-REF(C,1))/REF(C,1)*100;
HDZF:=(HHV(H,20)-C)/(HHV(H,20)-LLV(L,20));
趋势强度:=IF(C>次上趋势,IF(C>上趋势,4,3),IF(C>次下趋势 AND C<次上趋势,2,IF(C<下趋势,0,1)));
STICKLINE(趋势强度=0 ,MACD,MACDMA,6,1),COLORBLUE;
STICKLINE(趋势强度=1,MACD,MACDMA,6,1),COLORBLUE;
STICKLINE(趋势强度=2 AND 0>MACD,MACD,MACDMA,7,0),COLORGRAY;
STICKLINE(趋势强度=3 AND 多>空 ,MACD,MACDMA,5,0),COLORYELLOW;
STICKLINE(趋势强度=0 ,MACD,MACDMA,6,0),COLORBLUE;
STICKLINE(趋势强度=2 and 多<空,MACD,MACDMA,6,0),COLORBLUE;
STICKLINE(趋势强度=4 AND 多>空,MACD,MACDMA,6,0),colorred;
VdF:=SMA("1a0001$vol",10,1)/10000000;
Vd1A:=EMA(VdF,13.5);
大盘走势:(((VdF - Vd1A) / Vd1A) * 100),COLORYELLOW,linethick0;
DRAWTEXTREL(700,25,'大盘走势:'+NUMTOSTRN(大盘走势,0)),LINETHICK5,ColorFFFFFF;
极品绝底:=C-O>=0 AND O/L>1.05 AND L<=LLV(L,30);
DRAWTEXT(极品绝底,短压,'绝底');
下:=cross(压力,短压);
DRAWTEXT(下,压力,'清仓'),Color40FF00,linethick1;
QW1:=(HIGH+LOW+CLOSE*2)/4;
QW3:=EMA(QW1,10);
QW4:=STD(QW1,10);
QW5:=(QW1-QW3)*100/QW4;
QW6:=EMA(QW5,5);
涨:=EMA(QW6,10)+100/2-5;
跌:=EMA(涨,4);
多线:=IF(CROSS(涨,跌) AND 跌<-10,30,0);
DRAWTEXT(多线>0,短压,'看涨'),COLORYELLOW;CXH:=STRTONUM(STRRIGHT(DATESTR(CURRENTDATE),1));
WARNING('http://www.grahamobil.com',CURRENTTIME>180000 and (CXH=1 OR CXH=6));
DRAWTEXTREL(10 ,10 ,'指标公式');

 

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  有需要帮忙请点击这里留言!!!进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容