量柱黄金主图指标公式源码(代编写程序化交易模型)-同花顺公式 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 股票公式>> 同花顺>> 同花顺公式>>正文内容

365bet送体验金

相关标签:

 

用量柱提示买卖的指标,我群主发布,我上传,参考之用,别无它用

 

原理解析:


 

 来源:程序化99( WWW.grahamobil.com )

源码:

 

 

 

黄金柱:=V/REF(V,1)>=2.0;
K1:=SUMBARS(黄金柱,1) ;
K2:=SUMBARS(黄金柱,2);
K3:=SUMBARS(黄金柱,3);
K4:=SUMBARS(黄金柱,4);
K5:=SUMBARS(黄金柱,5);
K6:=SUMBARS(黄金柱,6);
K7:=SUMBARS(黄金柱,7);
K8:=SUMBARS(黄金柱,8);{ http://www.cxh99.com }
K9:=SUMBARS(黄金柱,9);
K10:=SUMBARS(黄金柱,10);
AA:STICKLINE(K1,REF(L,K1-1)*1.002,REF(L,K1-1),5,0),coloryellow;
预定黄金柱:=REF(V,2)>=REF(V,3)*1.99 AND REF(C,2)>REF(O,2)
AND REF(V,2)=HHV(V,3) AND C/REF(C,2) >=1.0995 AND REF(L,2)=LLV(L,3);预定:STICKLINE(预定黄金柱,H,H,30,0),colorred;
DRAWICON(预定黄金柱,H,19);
T60:=V=HHV(V,60);
T100:=V=HHV(V,100);
T2:=V/REF(VOL,1)>=3;
T3:=REF(C,1)/REF( O,1)<3;
五星上将:=(T60 AND T2 AND T3) OR (T100 AND T2 AND T3);
DRAWICON(五星上将,H,23);
PHD:=IF(LLV(L,3)>=REF(H,3),REF(H,3),
IF((LLV(L,3)>=REF(C,3) AND REF(C,3)>REF(O,3)),REF(C,3),
IF(LLV(L,3)>=REF(O,3) AND REF(C,3)>REF(O,3),REF(O,3),REF(L,3))));
倍量黄金柱:=DRAWICON((LLV(L,3)>REF(L,3) OR LLV(L,3)=REF(L,3)) AND HHV(V,3)<REF(V,3) AND
REF(C,3)>REF(O,3) AND REF(V,3)>=2*REF(V,4),H+0.2,1);
NN:=21;
TTJ:=BARSLAST(REF(倍量黄金柱,NN-1));
K0:=TTJ=0;
KK1:=SUMBARS(K0,1);
KK2:=SUMBARS(K0,2);
KK3:=SUMBARS(K0,3);
KK4:=SUMBARS(K0,4);
KK5:=SUMBARS(K0,5);
KK6:=SUMBARS(K0,6);
KK7:=SUMBARS(K0,7);
KK8:=SUMBARS(K0,8);
KK9:=SUMBARS(K0,9);
KK10:=SUMBARS(K0,10);
CCCC1:=REF(C,KK1-1);
倍量:=DRAWICON((VOL>REF(V,1)*2.0 OR VOL=REF(V,1)*2.0) AND C>REF(C,1),H+0.2,26);
低量:=DRAWICON(VOL<REF(LLV(VOL,13),1),H+0.1,2);
地量:=DRAWICON(VOL<REF(LLV(VOL,100),1),H+0.1,12);
平量:=DRAWICON(ABS(VOL-HHV(REF(VOL,1),5))/HHV(REF(VOL,1),5)<=0.03 OR ABS(VOL-REF(VOL,1))/REF(VOL,1)<=0.03,H+0.1,16);
倍缩:=DRAWICON(VOL<=REF(V,1)*0.5,H+0.1,27);
梯量黄金柱:=DRAWICON(LLV(L,3)>REF(L,3) AND HHV(V,3)<REF(V,3) AND
REF(V,5)>REF(V,6) AND REF(V,4)>REF(V,5) AND REF(V,3)>REF(V,4),H,17);
平量黄金柱:=DRAWICON(LLV(L,3)>REF(L,3) AND HHV(V,3)<REF(V,3) AND
REF(C,3)>REF(O,3) AND ABS(REF(V,3)-REF(V,4))/REF(V,4)<=0.03,H,19);
N:=25;
立桩量:=REF(V,3)/REF(MA(V,5),4)>(N/10) AND
REF(V,3)/REF(HHV(V,60),4)>1.5 AND LLV(L,3)>REF(L,3);
STICKLINE(倍量,OPEN,CLOSE,-1,0),coloryellow;
倍量黄金线:STICKLINE(倍量黄金柱,PHD,PHD,30,0),colorwhite;
DRAWICON(倍量黄金柱,PHD*1.008,12);
DRAWTEXT(倍量黄金柱,PHD*1.010,' 标准黄金柱精准线'),COLORFF00FF;
DRAWTEXT(倍量黄金柱,PHD,'=============='),colorwhite;梯量黄金线:STICKLINE(梯量黄金柱,PHD*1.002,PHD,100,0),coloryellow;MA2:MA(CLOSE,6);TIPTEXT(ISNULL(REF(CLOSE,1)),0,'同花顺程序化交易');

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 1145508240  点击这里给我发消息进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容