.401历史行情公式排序不能引用昨天分时数据吗?-通达信知识 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 股票公式>> 通达信>> 通达信知识>>正文内容

365bet送体验金

  • 咨询内容: 我编写了一个今天开盘量与昨天开盘量比值公式,用.401排序,结果非常不准确,最大比值也只有1,事实上比值大于1的股票大把大把的。公式在两日分时图中很正常,但用.401排序不行。公式要用到昨天开盘第1分钟的成交量: REF(V,BARSCOUNT(V)+1), 是不是涉及的昨天分时量的原因,这个排序指标无法正常使用?

    此主题相关图片如下快照63.png:


     

     来源:C X H 9 9 .C O M )

  • 通达信技术部:

    .401指标排序是基于日线,不能对一分钟周期排序。

    REF(V,BARSCOUNT(V)+1)  如果盘后数据足够的话,这个数据指的是上市第一天的成交量。

     

  • 通达信客服:
    这个公式是我从网上抄别人的,我也没搞懂他为什么这什么写:
    前一量:=REF(V,BARSCOUNT(V)+1)COLORCYAN,NODRAW;{用两日分时 第一分钟量}
    日前第一量:=IF(前一量=0,10,前一量),NODRAW;{300371昨日首量为0,给它10手吧,否则不好看}
    今日第一量:=IF(BARSCOUNT(V)>=240,REF(V,BARSCOUNT(V)-240),DRAWNULL),NODRAW;
    今昨比:=IF(BARSCOUNT(V)>=240,今日第一量/日前第一量,DRAWNULL),NODRAW;
    DRAWTEXT_FIX(ISLASTBAR=1,0,0,0,'第一量今昨比:')COLORCYAN;
    DRAWNUMBER_FIX(ISLASTBAR=1,0.085,0,0,今昨比)COLORYELLOW;

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  点击这里给我发消息或微信:cxhjy888 进行 有偿 编写!不贵!点击查看价格!


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容