跨指标修改-365bet送体验金财经知识 -程序化交易(grahamobil.com) - 365bet送体验金

365bet送体验金

  • 咨询内容: 改成365bet送体验金可用,谢谢
    A:=MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1));

    B:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);

    分水岭:IF(MA(CLOSE,17)<B,B,MA(CLOSE,17)),COLORFF00FF,LINETHICK2;

    操作线:分水岭-(EMA(C,3)-分水岭),COLOR00FFFF,LINETHICK2;

    PM:MA(C,5),COLORWHITE,LINETHICK2;

    IF(PM>REF(PM,1),PM,DRAWNULL),COLORRED,LINETHICK2;

    IF(PM=REF(PM,1),PM,DRAWNULL),COLORRED;

    IF(PM<REF(PM,1),PM,DRAWNULL),COLORFF9900,LINETHICK2;

    S:=(PM>操作线);

    DD:=分水岭<REF(分水岭,1);

    IF(DD,分水岭,DRAWNULL),COLOR00FF00,LINETHICK2;

    IF(S,分水岭,DRAWNULL),COLOR00FF00,POINTDOT,LINETHICK4;

    DRAWICON(CROSS(分水岭,操作线),分水岭-0.1,1);{买入红箭头}

    A1:=BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1));

    B1:=REF(C,A1+1)>C AND REF("MACD.DIF",A1+1)<"MACD.DIF" AND CROSS("MACD.DIF","MACD.DEA");

    DRAWTEXT(B1>0,L-0.02,'★M'),COLOR00FFFF;{MACD底背离}

    A2:=BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1));

    B2:=REF(C,A2+1)>C AND REF("KDJ.K",A2+1)<"KDJ.K" AND CROSS("KDJ.K","KDJ.D");

    DRAWTEXT(B2,L-0.10,'◎K'),COLORFF00FF;{KDJ底背离}

    A3:=BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1));

    B3:=REF(C,A3+1)>C AND REF("RSI.RSI1",A3+1)<"RSI.RSI1" AND CROSS("RSI.RSI1","RSI.RSI2");

    DRAWTEXT(B3>0,L-0.18,'◆R'),COLOR0000FF;{RSI底背离}

    C1:=BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1));

    D1:=REF(C,C1+1)<C AND REF("MACD.DIF",C1+1)>"MACD.DIF" AND CROSS("MACD.DEA","MACD.DIF");

    DRAWTEXT(D1>0,H+0.16,'★M'),COLOR00FF00;{MACD顶背离}

    C2:=BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1));

    D2:=REF(C,C2+1)<C AND REF("KDJ.K",C2+1)>"KDJ.K" AND CROSS("KDJ.D","KDJ.K");

    DRAWTEXT(D2>0,H+0.08,'◎K'),COLORFFFFCC;{KDJ顶背离}

    C3:=BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1));

    D3:=REF(C,C3+1)<C AND REF("RSI.RSI1",C3+1)>"RSI.RSI1" AND CROSS("RSI.RSI2","RSI.RSI1");

    DRAWTEXT(D3>0,H+0.04,'◆R'),COLORFF9900;{RSI顶背离}; 

     

     来源:程序化99

  • 365bet送体验金技术人员:  改写需要时间,周一给您回复

     

     来源: WWW.grahamobil.com

  • 365bet送体验金客服: 谢谢

     

  • 网友回复:   A:=MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1)); B:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1); 分水岭:IF(MA(CLOSE,17)<B,B,MA(CLOSE,17)),COLORFF00FF,LINETHICK2; 操作线:分水岭-(EMA(C,3)-分水岭),COLOR00FFFF,LINETHICK2; PM:MA(C,5),COLORWHITE,LINETHICK2; IF(PM>REF(PM,1),PM,NULL),COLORRED,LINETHICK2; IF(PM=REF(PM,1),PM,NULL),COLORRED; IF(PM<REF(PM,1),PM,NULL),COLORFF9900,LINETHICK2; S:=(PM>操作线); DD:=分水岭<REF(分水岭,1); IF(DD,分水岭,NULL),COLOR00FF00,LINETHICK2; IF(S,分水岭,NULL),COLOR00FF00,POINTDOT,LINETHICK4; DRAWICON(CROSS(分水岭,操作线),分水岭-0.1,1); LC := REF(CLOSE,1); RSI1:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100; RSI2:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;
    DIFF := EMA(CLOSE,12) - EMA(CLOSE,26); DEA  : =EMA(DIFF,9); MACD:=2*(DIFF-DEA),COLORSTICK; RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;//收盘价与N周期最低值做差,N周期最高值与N周期最低值做差,两差之间做比值。 K:=SMA(RSV,3,1);//RSV的移动平均值 D:=SMA(K,3,1);//K的移动平均值 J:=3*K-2*D; A1:=BARSLAST(REF(CROSS(DIFF,DEA),1)); B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA); DRAWTEXT(B1>0,L-0.02,'M',COLOR00FFFF; A2:=BARSLAST(REF(CROSS(K,D),1)); B2:=REF(C,A2+1)>C AND REF(K,A2+1)<K AND CROSS(K,D); DRAWTEXT(B2,L-0.10,'K',COLORFF00FF; A3:=BARSLAST(REF(CROSS(RSI1,RSI2),1)); B3:=REF(C,A3+1)>C AND REF(RSI1,A3+1)<RSI1 AND CROSS(RSI1,RSI2); DRAWTEXT(B3>0,L-0.18,'R',COLOR0000FF; C1:=BARSLAST(REF(CROSS(DEA,DIFF),1)); D1:=REF(C,C1+1)<C AND REF(DIFF,C1+1)>DIFF AND CROSS(DEA,DIFF); DRAWTEXT(D1>0,H+0.16,'M',COLOR00FF00; C2:=BARSLAST(REF(CROSS(D,K),1)); D2:=REF(C,C2+1)<C AND REF(K,C2+1)>K AND CROSS(D,K);
    DRAWTEXT(D2>0,H+0.08,'K',COLORFFFFCC;
    C3:=BARSLAST(REF(CROSS(RSI2,RSI1),1));
    D3:=REF(C,C3+1)<C AND REF(RSI1,C3+1)>RSI1 AND CROSS(RSI2,RSI1);
    DRAWTEXT(D3>0,H+0.04,'R',COLORFF9900;

     

  • 网友回复: 老师,能否帮助我把上面的指标每一句加个翻译备注一下,谢谢

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  点击这里给我发消息或微信:cxhjy888 进行 有偿 编写!不贵!点击查看价格!


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容