逃顶抄底副图指标公式源码-通达信公式 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 股票公式>> 通达信>> 通达信公式>>正文内容

365bet送体验金

相关标签:

 

 

原理解析:


 

 来源:程序化99( WWW.grahamobil.com )

源码:

 

 

VAR1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2:=SMA(VAR1,9,1)+100;
VAR3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4:=SMA(VAR3,3,1);
VAR5:=SMA(VAR4,3,1)+100;
VAR6:=VAR5-VAR2;
趋势: IF(VAR6>45,VAR6-45,0),COLOR00FFFF;
VAR2Q:=REF(LOW,1);
VAR3Q:=SMA(ABS(LOW-VAR2Q),3,1)/SMA(MAX(LOW-VAR2Q,0),3,1)*100;
VAR4Q:=EMA(IF(CLOSE*1.3,VAR3Q*10,VAR3Q/10),3);
VAR5Q:=LLV(LOW,30);
VAR6Q:=HHV(VAR4Q,30);
VAR7Q:=IF(MA(CLOSE,58),1,0);
VAR8Q:=EMA(IF(LOW<=VAR5Q,(VAR4Q+VAR6Q*2)/2,0),3)/999*VAR7Q;
火焰山:=IF(VAR8Q>100,100,VAR8Q);
STICKLINE(火焰山>0,0 ,火焰山*1.2,3.2,0 ),COLOR4444FF;
STICKLINE(火焰山>0,0 ,火焰山*1.2,2.7,0 ),COLOR5555FF;
STICKLINE(火焰山>0,0 ,火焰山*1.2,2.1,0 ),COLOR6666FF;
STICKLINE(火焰山>0,0 ,火焰山*1.2,1.5,0 ),COLOR7777FF;
STICKLINE(火焰山>0,0 ,火焰山*1.2,0.9,0 ),COLOR8888FF;
STICKLINE(火焰山>0,0 ,火焰山*1.2,0.3,0 ),COLOR9999FF;
STICKLINE(REF(趋势,1)< 趋势, 趋势,REF(趋势,1),3.2,0),COLOR000033;
STICKLINE(REF(趋势,1)< 趋势, 趋势,REF(趋势,1),2.7,0),COLOR000055;
STICKLINE(REF(趋势,1)< 趋势, 趋势,REF(趋势,1),2.1,0),COLOR000077;
STICKLINE(REF(趋势,1)< 趋势, 趋势,REF(趋势,1),1.5,0),COLOR000099;
STICKLINE(REF(趋势,1)< 趋势, 趋势,REF(趋势,1),0.9,0),COLOR0000BB;
STICKLINE(REF(趋势,1)< 趋势, 趋势,REF(趋势,1),0.3,0),COLOR0000DD;
STICKLINE(REF(趋势,1)> 趋势, 趋势,REF(趋势,1),3.2,0),COLOR003300;
STICKLINE(REF(趋势,1)> 趋势, 趋势,REF(趋势,1),2.7,0),COLOR005500;
STICKLINE(REF(趋势,1)> 趋势, 趋势,REF(趋势,1),2.1,0),COLOR007700;
STICKLINE(REF(趋势,1)> 趋势, 趋势,REF(趋势,1),1.5,0),COLOR009900;
STICKLINE(REF(趋势,1)> 趋势, 趋势,REF(趋势,1),0.9,0),COLOR00BB00;
STICKLINE(REF(趋势,1)> 趋势, 趋势,REF(趋势,1),0.3,0),COLOR00DD00;
逃顶:=CROSS(82,RSI);
STICKLINE( 逃顶,逃顶,20,8,0),COLORFF5500;
STICKLINE( 逃顶,逃顶,20,7,0),COLORFF6600;
STICKLINE( 逃顶,逃顶,20,6,0),COLORFF7700;
STICKLINE( 逃顶,逃顶,20,5,0),COLORFF8800;
STICKLINE( 逃顶,逃顶,20,4,0),COLORFF9900;
STICKLINE( 逃顶,逃顶,20,3,0),COLORFFAA00;
STICKLINE( 逃顶,逃顶,20,2,0),COLORFFBB00;
STICKLINE( 逃顶,逃顶,20,1,0),COLORFFCC00;
VAR11:=3;
VAR21:=(3)*(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1)) - (2)*(SMA(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1),3,1));
IF(CROSS(VAR21,VAR11),20,-1),COLORRED,COLOR0000FF,LINETHICK3;
D1:=(C+L+H)/3;
D2:=EMA(D1,6);
D3:=EMA(D2,5);
BBUY:=CROSS(D2,D3);
DRAWICON(BBUY,(LOW *1),17);
VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,VARR1),HIGH,15);
DRAWTEXT(CROSS(82,VARR1),HIGH,' 逃'),COLORYELLOW;
DRAWTEXT_FIX(C>O,0.01,0.9,0,' WWW.grahamobil.com '),COLORRED;
DRAWTEXT_FIX(C>O,1,1,0,'程序化交易模型'),COLORRED;

 

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  有需要帮忙请点击这里留言!!!或微信:cxhjy888 进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容