GLL乖离率副图指标公式源码(代编写程序化交易模型)-同花顺公式 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 股票公式>> 同花顺>> 同花顺公式>>正文内容

365bet送体验金

相关标签:

 

1. 指标说明
乖离率,是移动平均原理派生的一项技术指标,其功能主要是通过测算股价在波动过程中与移动平均线出现偏离的程度,从而得出股价在剧烈波动时因偏离移动平均趋势而造成可能的回档或反弹,以及股价在正常波动范围内移动而形成继续原有势的可信度。
乖离度的测市原理是如果股价偏离移动平均线太远,不管股份在移动平均线之上或之下,都有可能趋向平均线。而乖离率则表示股价偏离趋向指标的百分比值。2. 运用原则
乖离率分正乖离和负乖离。当股价在移动平均线之上时,其乖离率为正,反之则为负,当股价与移动平均线一致时,乖离率为0。随着股价走势的强弱和升跌,乖离率周而复始地穿梭于0点的上方和下方,其值的高低对未来走势有一定的测市功能。一般而言,正乖离率涨至某一百分比时,表示短期间多头获利回吐可能性也越大,呈卖出讯号;负乖离率降到某一百分比时,表示空头回补的可能性也越大,呈买入讯号。对于乖离率达到何种程度方为正确之买入点或卖出点,目前并没有统一原则,使用者可凭观图经验对行情强弱的判断得出综合结论。一般来说,在大势上升市场,如遇负乘离率,可以行为顺跌价买进,因为进场风险小;在大势下跌的走势中如遇正乖离,可以待回升高价时,出脱持股。
由于股价相对于不同日数的移动平均线有不同的乖离率,除去暴涨或暴跌会使乖离率瞬间达到高百分比外,短、中、长线的乖离率一般均有规律可循。
下面是国外不同日数移动平均线达到买卖讯事号要求的参考数据:
6日平均值乖离:-3%是买进时机,+3.5是卖出时机;
12日平均值乖离:-4.5%是买进时机,+5%是卖出时机;
24日平均值乖离:-7%是买进时机,+8%是卖出时机;
72日平均值乖离:-11%是买进时机,+11%是卖出时机;

 

原理解析:


 

 来源:程序化99( WWW.grahamobil.com )

源码:

 


B6:(CLOSE-WMA(CLOSE,6))/WMA(CLOSE,6)*100;
B12:(CLOSE-WMA(CLOSE,12))/WMA(CLOSE,12)*100;
B24:(CLOSE-WMA(CLOSE,24))/WMA(CLOSE,24)*100;
B72:(CLOSE-WMA(CLOSE,72))/WMA(CLOSE,72)*100;
STICKLINE(B6>=3.5,8,0,4,0),colorred;
卖6日:IF(B6>=3.5,1,0),linethick2,colorred;
STICKLINE(B12>=5,12,8,4,0),colorlime;
卖12日:IF(B12>=5,1,0),linethick2,colorlime;
STICKLINE(B24>=8,16,12,4,0),colorwhite;
卖24日:IF(B24>=8,1,0),linethick2,colorwhite;
STICKLINE(B72>=11,20,16,4,0),coloryellow;
卖72日:IF(B72>=11,1,0),linethick2,coloryellow;
STICKLINE(B6<=-3,-8,0,4,0),colorred;
买6日:IF(B6<=-3,-1,0),linethick2,colorred;
STICKLINE(B12<=-4.5,-12,-8,4,0),colorlime;
买12日:IF(B12<=-4.5,-1,0),linethick2,colorlime;
STICKLINE(B24<=-7,-16,-12,4,0),colorwhite;
买24日:IF(B24<=-7,-1,0),linethick2,colorwhite;
STICKLINE(B72<=-11,-20,-16,4,0),coloryellow;
买72日:IF(B72<=-11,-1,0),linethick2,coloryellow;TIPTEXT(ISNULL(REFX(&CLOSE,1)),0,' WWW.grahamobil.com '),colorred;
TIPTEXT(ISNULL(REF(CLOSE,1)),0,'同花顺程序化交易');

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 1145508240  点击这里给我发消息进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容