快抢短线副图指标公式源码(代编写程序化交易模型)-同花顺公式 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 股票公式>> 同花顺>> 同花顺公式>>正文内容

365bet送体验金

相关标签:

 

软件炒股高手绝技》指标,欢迎大家试用看看。

 

 

原理解析:


 

 来源:程序化99( WWW.grahamobil.com )

源码:

 

 

N:=26;
//{DRAWutf-8(CLOSE>0,STRIP(RGB(0,150,130),RGB(0,0,0),1));}
RSVp:=(C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100-50;
Kv:=SMA(RSVp,3,1);
Dv:=SMA(Kv,3,1);
Jv:=3*Kv-2*Dv;
zdzk1:=EMA(Jv,6);
zdzk2:=REF(zdzk1,1);
做多:IF(zdzk1>=zdzk2,zdzk1+2,zdzk2),PRECIS2,colorred;
做空:IF(zdzk2-zdzk1,zdzk2,zdzk1),PRECIS2,colorgreen;
xw1:=IF(O<=REF(O,1),0,MAX((H-O),(O-REF(O,1))));
xw2:=IF(O>=REF(O,1),0,MAX((O-L),(O-REF(O,1))));
xw3:=SUM(xw1,21);
xw4:=SUM(xw2,21);
xw5:=IF(xw3>xw4,(xw3-xw4)/xw3,IF(xw3=xw4,0,(xw3-xw4)/xw4));
//14天强弱
RS:=SMA(MAX(C-REF(C,1),0),14,1)/SMA(ABS(C-REF(C,1)),14,1)*100;
ZD:= EMA(EMA(EMA(RS,7),3),3);
ZD1:=(ZD-REF(ZD,1))/REF(ZD,1)*15;
STICKLINE(ZD1>=0,0,ZD1*50,4,0),Color0000BE;
STICKLINE(ZD1<=0,0,ZD1*50,4,0),colorcyan;
y1:=AMOUNT/V/100;
y2:=(3*H+L+O+2*C)/7;
y3:=100*(WINNER(1.1*C)-WINNER(0.9*C));
y4:=SUM(AMOUNT,13)/y1/100;
y5:= DMA(y2,V/y4);
y6:=(C-y5)/y5*100;
y7:=(y3<10) AND (y6<=-10);
y8:=SMA(MAX(C-REF(C,1.5),0),6,1)/SMA(ABS(C-REF(C,1.5)),6,1)*100;
重亏:STICKLINE(y6<=-10 AND ZD1<0,ZD1*55,ZD1*45,6,0),ColorFF89B2;
全亏:STICKLINE(y6<=-16 AND ZD1<0,ZD1*60,ZD1*55,6,1),colorblue;
超跌:STICKLINE(y7 AND ZD1<0,ZD1*65,ZD1*60,6,0),color399c7f;
Jct:=100*(C-COST(10))/COST(10);
PARTLINE(C,IF(Jct<0,Jct,0)*3,color399c7f);
//{备战区1}
ZDD1:=(HHV(H,21)-C)/(HHV(H,21)-LLV(L,21))*100-10;
ZDD2:=(C-LLV(L,21))/(HHV(H,21)-LLV(L,21))*100;
ZDD3:=SMA(ZDD2,13,8);
ZDD4:=CEILING(SMA(ZDD3,13,8));
ZDD5:=SMA(ZDD1,21,8);
Xh1:=SMA(MAX(C-REF(C,2),0),7,1)/SMA(ABS(C-REF(C,2)),7,1)*100;
Xh2:=ZDD4-ZDD5<-65 AND Xh1<12;
备战区:DRAWICON(Xh2,0,12),Color006EFF;
STICKLINE(Xh2,0,ZD1*20,4,0),Color006EFF;
//{备战区2}
Xx1:=MA(LOW,2)*0.96;
Xx2:=MA(LOW,26)*0.85;
Xx3:= REF(Xx1,1)<Xx2 AND REF(Xx1,1)<Xx1 AND REF(Xx1,1)<REF(Xx1,2);
STICKLINE(Xx3,0,ZD1*16,4,0),Color006EFF;
DRAWICON(Xx3,0,12);
//{备战区3}
C0:=REF(C,2)*0.865;
C1:=REF(C,13)*0.772;
DSY:=100*VOL/CAPITAL;
STICKLINE((C-MIN(C0,C1))/C<0.1 AND SUM(DSY,5)/5<1.8,0,ZD1*25,4,0),Color006EFF;
DRAWICON((C-MIN(C0,C1))/C<0.1 AND SUM(DSY,5)/5<1.8,0,12);
//{备战区4}
Ww1:= SUM( MA(C,10),9)/10.110;
Ww2:=CROSS(C,Ww1);
STICKLINE(Ww2,0,ZD1*26,4,0),Color006EFF;
DRAWICON(Ww2,0,12);
//{买1}
Vw1:=DMA(EMA(C,12),SUM(V,5)/3/CAPITAL);
Vw2:=REF(H,10)/C>1.35;
Vw3:=(COST(20)-C)/C>0.15;
Vw4:=H>L*1.051;
Vw5:=Vw4 AND COUNT(Vw4,5)>1;
Vw6:=(((C-Vw1)/Vw1*100<-30) OR Vw2) AND Vw3 AND Vw5;
STICKLINE(Vw6,0,ZD1*40,4,0),Color0000FF;
//{买2}
XL1:=MA(LOW,2)*0.96;
XL2:=MA(LOW,26)*0.85;
XL3:=REF(XL1,1)<XL2 AND REF(XL1,1)<XL1 AND REF(XL1,1)<REF(XL1,2);
STICKLINE(XL3,0,15,4,0),colorred;
DRAWTEXT(XL3,15,'←买'),colorred;
//{井喷}
jjp1:=REF(INDEXC,1);
jjp2:=FILTER((INDEXC-jjp1)/jjp1>0.03 AND zdzk1>=zdzk2,7);
STICKLINE(jjp2,0,-15,4,0),colorred;
DRAWTEXT(jjp2,-15,'←买'),colorred;
//{//数据源}
x1:=EMA(HHV(H,500),21);
x2:=EMA(HHV(H,250),21);
x3:=EMA(HHV(H,90),21);
x4:=EMA(LLV(L,500),21);
x5:=EMA(LLV(L,250),21);
x6:=EMA(LLV(L,90),21);
x7:=EMA((x1*0.558+x2*0.558+x3*0.558+x4*0.96+x5*0.96+x6*0.96)/6,21);
x8:=EMA((x1*0.55 +x2*0.55+ x3*0.65+ x4*1.25+x5*1.23+x6*1.2 )/6,21);
x9:=EMA((x1*0.68+ x2*0.68+ x3*0.68+ x4*1.3 +x5*1.3+ x6*1.3 )/6,21);
VARA:=EMA((x7*3+x8*2+x9)/6*1.738,21);
VARB:=REF(LOW,1);
VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100;
VARD:=EMA(IF(C*1.35<=VARA,VARC*10,VARC/10),3);
//{//C*1.35小于等于数据源取低价强弱线*10的3日均线,否则取低价强弱线/10的3日均线}
VARE:=LLV(L,30);
VARF:=HHV(VARD,30);
VAR10:=IF(MA(C,58),1,0);
VAR11:=EMA(IF(LOW<=VARE,(VARD+VARF*2)/2,0),3)/618*VAR10;
MID:=REF(H+L,1)/2;
CR:=SUM(MAX(0,H-MID),N)/SUM(MAX(0,MID-L),N)*100;
出击:IF(CR<60 AND VAR11>10,35,0),colorgreen;
攻击:IF (VAR11>20,30,0),COLOR0033ff;
//{加仓}
xc1:=(MA(C,80)-MA(C,13)/3);
xc2:= MA((C-xc1)/xc1,1);
xc3:=EMA(xc2,12)*0.7;
xc4:=EMA(xc2,3);
xc5:=IF(LLV(xc4-xc3,12)>0,0,-10);
xc6:=EMA(C,12)-EMA(C,26);
xc7:=EMA(xc6,9);
xc8:=2*(xc6-xc7);
加仓:IF(xc5<0 AND CROSS(xc8,0),50,0),LINETHICK1,colorblue;
DRAWTEXT(加仓,35,'←加仓'),colorblue;TIPTEXT(ISNULL(REFX(&CLOSE,1)),0,' WWW.grahamobil.com '),colorred;
TIPTEXT(ISNULL(REF(CLOSE,1)),0,'同花顺程序化交易');

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 1145508240  点击这里给我发消息进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容