千万要当心买选股指标公式-其他软件公式 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 股票公式>> 其他>> 其他软件公式>>正文内容

365bet送体验金

相关标签:

 

千万要当心这种指标使用未来函数检测软件检查不到有未来函数,但是信号会漂移

 

 

原理解析:


 

 来源:程序化99( WWW.grahamobil.com )

源码:

 

 

TJ:=WEEKDAY-REF(WEEKDAY,1)<>DATEDIFF(REF(DATE,1),DATE) OR BARPOS=1;
IF DATACOUNT>1 THEN
FOR I=1 TO DATACOUNT-1 DO BEGIN
TJ1[I]:=TJ[I+1];
END;
TJ1[DATACOUNT]:=1;
FC:=CLOSE;
FH:=HIGH;
FL:=LOW;
FO:=OPEN;
POS:=0*CLOSE;
FOR I=1 TO DATACOUNT DO BEGIN
IF TJ[I] THEN BEGIN
HH:=FH[I];
LL:=FL[I];
OO:=FO[I];
P:=I;
END;ELSE BEGIN
FO[I]:=OO;
HH:=MAX(HH,FH[I]);
LL:=MIN(LL,FL[I]);
END;
IF TJ1[I] THEN BEGIN
POS[(I+P)/2]:=1;
IF I>1 THEN BEGIN
FOR J=I DOWNTO 1 DO BEGIN
FC[J]:=FC[I];
FH[J]:=HH;
FL[J]:=LL;
IF TJ[J] THEN
BREAK;
END;
END;
END;
END;
HP:=FH;
LP:=FL;
CP:=FC;
LC:=REF(CP,1);
RSI1:=(SMA(MAX(CP-LC,0),6,1))/(SMA(ABS(CP-LC),6,1))*100;
RSI2:=(SMA(MAX(CP-LC,0),12,1))/(SMA(ABS(CP-LC),12,1))*100;
A:IF(CROSS(RSI1,RSI2),LOW,REF(LOW,BARSLAST(CROSS(RSI1,RSI2)))),LINETHICK2,colorFFFF;
B:IF(CROSS(RSI2,RSI1),HIGH,REF(HIGH,BARSLAST(CROSS(RSI2,RSI1)))),LINETHICK2,colorFF00FF;
买选股:IF(CROSS(RSI1,RSI2) OR CROSS(CLOSE,A),88,0),LINETHICK0,colorFF00FF;
卖选股:IF(REF(CROSS(RSI2,RSI1),1),99,0),LINETHICK0,colorFFFF;
DRAWICON(买选股=88,LOW*0.998,1);
DRAWICON(卖选股=99,HIGH*1.01,2);

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  有需要帮忙请点击这里留言!!!或微信:cxhjy888 进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容