精确打击副图指标公式源码(代编写程序化交易模型)-同花顺公式 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 股票公式>> 同花顺>> 同花顺公式>>正文内容

365bet送体验金

相关标签:

 

顶底指标,买入分批,卖出参考BIAS,废话不多说。

 

 

原理解析:


 

 来源:程序化99( WWW.grahamobil.com )

源码:

 

 

n:=10;
f:=25;
Var1:=HHV(HIGH,9)-LLV(LOW,9);
Var2:=HHV(HIGH,9)-CLOSE;
Var3:=CLOSE-LLV(LOW,9);
Var4:=Var2/Var1*100-70;
Var5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
Var6:=(HIGH+LOW+OPEN+CLOSE)/4;
Var7:=SMA(Var3/Var1*100,3,1);
Var8:=LLV(LOW,34);
Var9:=SMA(Var7,3,1)-SMA(Var4,9,1);
VarA:=IF(Var9>100,Var9-100,0);
VarB:=HHV(HIGH,34);
VarC:=EMA((Var6-Var8)/(VarB-Var8)*100,13);
VarD:=EMA(0.667*REF(VarC,1)+0.333*VarC,2);
VarE:=SMA(MAX(CLOSE-REF(CLOSE,1),0)/CLOSE,8,1)/SMA(ABS(INDEXC-REF(INDEXC,1))/INDEXC,8,1)*100-25;
VarF:=MA(VarE,3);
Var10:=REF(VarF,1);
生命线:EMA(VarD,N), colorFFAA00;
Var11:=(CLOSE-LLV(LOW,F))/(HHV(HIGH,F)-LLV(LOW,F))*100;
K:=SMA(Var11,3,1);
D:=SMA(K,3,1);
红灯亮买: STICKLINE(CROSS(VarC,VarD) AND VarC>VarD AND VarC<18,36,0,1,0), colorred;
见红:IF(VarC>18,0,IF(CROSS(VarC,VarD) AND VarC>VarD AND VarC<18,37,0)),COLOR3355FF;
浪尖: STICKLINE(CROSS(VarD,VarC) AND VarC<VarD AND VarC>60,90,100,12,1),colorblue;
IF(VarC<79,100,IF(CROSS(VarD,VarC) AND VarD>79 AND VarC>79,70,100)),COLOR00ff00;//{灯塔脉冲}
//{
//卖: STICKLINE(FILTER(CROSS(VarD,VarC),10) AND VarD>79 AND VarC>79,100,95,4,0),colorgreen;{画绿色倒灯桩}
//{
STICKLINE(VarC-VarD>0,VarC,VarD,8,1),COLOR0000FF;//{多头行情显出红柱状}
STICKLINE(VarC-VarD<0,VarC,VarD,8,0),COLOR00FF00;//{空头行情显出绿色柱状}
kar1:=3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
kar2:=(CLOSE-LLV(LOW,26))/(HHV(HIGH,26)-LLV(LOW,26))*100;
kar3:=SMA(SMA(kar2,3,1),3,1);
kar4:=EMA(kar3,5);
kar5:=LLV(LOW,26);
kar6:=HHV(HIGH,34);
kar7:=EMA((CLOSE-kar5)/(kar6-kar5)*4,4)*25;
kar8:=100-kar1;
kar9:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
kar10:=SMA(kar9,3,1);
kar11:=SMA(kar10,3,1);
kar12:=EMA(3*kar10-2*kar11,3);
kar13:=(-1)*(EMA(kar8,1)-50)+50;
kar14:=EMA(100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14)),6);
底部:STICKLINE(CROSS(kar4,10) AND kar4>10,50,0,10,0),coloryellow;
建仓: IF((kar7<10),18,0), colorcc00ff;
TIPTEXT(ISNULL(REFX(&CLOSE,1)),0,' WWW.grahamobil.com '),colorred;
TIPTEXT(ISNULL(REF(CLOSE,1)),0,'同花顺程序化交易');


 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 1145508240  点击这里给我发消息进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容