趋势操盘线-其他软件公式 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 股票公式>> 其他>> 其他软件公式>>正文内容

365bet送体验金

相关标签:趋势波段指标公式 、 突破趋势指标公式 、 趋势线怎么显示公式 、 主图自动画趋势线公式 、 趋势买卖通达信指标 、 趋势线指标哪个最好 、 神仙大趋势指标公式 、 通达信生命线指标公式 、 通达信主图自动趋势线 、 精准线主图指标公式 、 excel图表趋势线公式 、 mt4自动画趋势线指标 、

 

 

原理解析:


 

 来源:程序化99( WWW.grahamobil.com )

源码:

 

 

{趋势操盘线}
VAR1:=(EMA(C,12)-EMA(C,26))*100+50;
VAR2:=EMA(VAR1,9);
VAR3:=((HHV(H,21)-C)/(HHV(H,21)-LLV(L,21)))*100-10;
VAR4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
VAR5:=SMA(VAR4,13,8);
VAR6:=SMA(VAR3,21,8);
VAR7:=MA(C,80)-MA(C,10)/7;
VAR8:=EMA(C,5);
VAR9:=MA((LLV(C,9))*1.1,14);
VAR10:=2*VAR9-VAR8-C*0.1;
VAR11:=IF(((VAR8-VAR10)*5>0),(POW((VAR8-VAR10)*5,2))/10,(-1*(POW((VAR8-VAR10)*(5),2)))/(10));
VAR12:=IF((VAR11>0),VAR11-0,12);
VAR13:=SMA(MAX(C-REF(C,2),0),7,1)/SMA(ABS(C-REF(C,2)),7,1)*100;
趋势线:CEILING(SMA(VAR5,13,8)),LINETHICK2,COLOR0000FF;
操盘线: MA(3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*
SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1),5),LINETHICK2,COLORBLUE;
STICKLINE(FILTER(CROSS(趋势线,VAR12)AND 趋势线>REF(C,1) OR
CROSS(趋势线,操盘线) AND 趋势线<20 OR 趋势线>REF(趋势线,1)
AND 趋势线<35 AND C>REF(C,1),5),5,20,2,2),COLOR00FF00;
底部:IF((趋势线-VAR6<(-65)),1,12),COLORF0F000;
顶部:IF((趋势线-VAR6>85),95,100),COLORF0F000;
黄金区: DRAWICON(IF(VAR13<15,15,0),13,1),COLOR000000;
强弱分界:50,POINTDOT,COLORaabbdd,linethick2;

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 511411198  有需要帮忙请点击这里留言!!!或微信:cxhjy888 进行 有偿 编写!

怎么收费,代编流程等详情请点击阅读,或QQ微信联系我们!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容