波段王指标抄底工具指标源码(代编写程序化交易模型)-365bet送体验金财经公式 -程序化交易(grahamobil.com) - 365bet送体验金

365bet送体验金

波段王指标源码:


HH:=HHV(HIGH,40);
LL:=LLV(LOW,40); 
HH1:=BARSLAST((HH > REF(HH,1))); 
LL1:=BARSLAST((LL < REF(LL,1))); 
PARTLINE((HH1 < LL1),LL,COLORYELLOW); 
PARTLINE((HH1 > LL1),HH,COLORBLUE); 
STICKLINE((HH1 < LL1),CLOSE,OPEN,COLORRED,0); 
DRAWLINE((HH1 < LL1),HIGH,(HH1 < LL1),LOW,COLORRED); 
STICKLINE((HH1 > LL1),CLOSE,OPEN,COLORGREEN,0); 
DRAWLINE((HH1 > LL1),HIGH,(HH1 > LL1),LOW,COLORGREEN); 
DRAWTEXT(CROSS(HH1,LL1),HH,'空'); DRAWTEXT(CROSS(LL1,HH1),LL,'多'); //信号显示
DRAWTEXT(((HH1 < REF(HH1,1)) && (HH1 < LL1)),LOW,'♂加多'); //显示加多信号
DRAWTEXT(((LL1 < REF(LL1,1)) && (HH1 > LL1)),HIGH,'♀加空'); //显示加空

 

抄底工具源码:


参数:
[N1,5.000000,250.000000,125.000000]  //参数为125
[N2,1.000000,20.000000,5.000000]//参数为5
[N3,5.000000,60.000000,20.000000]//参数为20


HX:=HHV(HIGH,3); LX:=LLV(LOW,3);
H1:=IFELSE(HX<REF(HX,1)&&HX<REF(HX,2)&&HX<REF(HX,4)&&LX<REF(LX,1)&&LX<REF(LX,3)&&LX<REF(LX,5)&&OPEN>CLOSE&&(HHV(OPEN,0)-CLOSE)>0,REF(HX,4),0);
L1:=IFELSE(LX>REF(LX,1)&&LX>REF(LX,3)&&LX>REF(LX,5)&&HX>REF(HX,1)&&HX>REF(HX,2)&&HX>REF(HX,4)&&OPEN<CLOSE&&(CLOSE-LLV(OPEN,0))>0,REF(LX,4),0);
H2:=VALUEWHEN(H1>0,H1); L2:=VALUEWHEN(L1>0,L1);
K1:=IFELSE(CLOSE>H2,-3,IFELSE(CLOSE<L2,1,0));
K2:=VALUEWHEN(K1<>0,K1);G:=IFELSE(K2=1,H2,L2); 
G1:=VALUEWHEN(ISLASTBAR,G);DRAWNUMBER(LX>0,G1,G1,0,COLORCYAN); 
TMP:=K2;W1:=K2; W2:=OPEN-CLOSE; 
HT:=IFELSE(OPEN>CLOSE,OPEN,CLOSE); 
LT:=IFELSE(OPEN<CLOSE,OPEN,CLOSE); 
DRAWLINE(W1=1,HIGH,W1=1,HT,COLORCYAN); 
DRAWLINE(W1=1,LOW,W1=1,LT,COLORCYAN); 
DRAWLINE(W1=-3,HIGH,W1=-3,HT,COLORRED); 
DRAWLINE(W1=-3,LOW,W1=-3,LT,COLORRED); 
STICKLINE(W1>0,OPEN,CLOSE,COLORCYAN,1); 
STICKLINE(W1<=0,OPEN,CLOSE,COLORRED,1); 
STICKLINE(W2>0&&W1<=0,OPEN,CLOSE,COLORRED,0); 
STICKLINE(W2>0&&W1>0,OPEN,CLOSE,COLORCYAN,0); 
DRAWLINE(TMP=1&&REF(TMP,1)=1,G,TMP=1&&REF(TMP,1)=1,REF(G,1),COLORCYAN);DRAWLINE(TMP=-3&&REF(TMP,1)=-3,G,TMP=-3&&REF(TMP,1)=-3,REF(G,1),COLORRED);
DRAWSL(K2=1,G,0,1,0,COLORCYAN);DRAWSL(K2=-3,G,0,1,0,COLORRED); DRAWTEXT(CROSS(TMP,0),HX,'卖'); DRAWTEXT(CROSS(0,TMP),LX,'买'); MA55:=MA(CLOSE,55); DRAWTEXT(CROSS(TMP,0)&&CLOSE<=MA55,HX,'卖↓'); DRAWTEXT(CROSS(0,TMP)&&CLOSE>=MA55,LX,'买↑');

 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 1145508240  点击这里给我发消息进行 有偿 编写!不贵!点击查看价格!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容