趋势线彩带趋势主图指标公式源码-通达信公式 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 股票公式>> 通达信>> 通达信公式>>正文内容

365bet送体验金

相关标签:

 

原理解析:


 

 来源:程序化99( WWW.grahamobil.com )

源码:

 

 

MA14:=MA(C,14);
STICKLINE(H<MA14 ,H,L,10,0),COLOR000000;
STICKLINE(H<MA14 ,H,L,0.1,0),COLOR666666;
STICKLINE(H<MA14 ,O,C,8,0),COLOR666666;
STICKLINE(H<MA14 AND C>O,O,C,8,0),COLOR8F8F8F;
CC:=(3*C+H+L+O)/6;
MA6:=EMA(MA(IF(MA(CC,3)>MA(CC,4),MA((CC+3*H)/4,3),
REF(MA((CC+3*L)/4,3),1)),3),5);
REF(MA6,1), COLOR8A8A8A;
REF(MA6,2), COLOR898989;
REF(MA6,3), COLOR888888;
REF(MA6,4), COLOR878787;
REF(MA6,5), COLOR868686;
REF(MA6,6), COLOR858585;
REF(MA6,7), COLOR848484;
REF(MA6,8), COLOR838383;
REF(MA6,9), COLOR828282;
REF(MA6,10), COLOR818181;
REF(MA6,11), COLOR808080;
REF(MA6,12), COLOR7A7A7A;
REF(MA6,13), COLOR797979;
REF(MA6,14), COLOR787878;
REF(MA6,15), COLOR777777;
REF(MA6,16), COLOR767676;
REF(MA6,17), COLOR757575;
REF(MA6,18), COLOR747474;
REF(MA6,19), COLOR737373;
REF(MA6,20), COLOR727272;
REF(MA6,21), COLOR717171;
REF(MA6,22), COLOR707070;
REF(MA6,23), COLOR6A6A6A;
REF(MA6,24), COLOR696969;
STICKLINE(L<MA14 AND C>O AND H>MA14 ,H,L,0.1,0),COLORDD66CC;
STICKLINE(L<MA14 AND C<O AND H>MA14,H,L,0.1,0),COLORFFCC66;
STICKLINE(L<MA14 AND C>O AND H>MA14 ,O,C,8,0),COLORDD66CC;
STICKLINE(L<MA14 AND C<O AND H>MA14,O,C,8,0),COLORFFCC66;
STICKLINE(L>MA14 AND C>O AND H>MA14,H,L,0.1,0),COLOR0066FF;
STICKLINE(L>MA14 AND C<O AND H>MA14,H,L,0.1,0),COLOR66FF66;
STICKLINE(L>MA14 AND C>O AND H>MA14,O,C,8,0),COLOR0066FF;
STICKLINE(L>MA14 AND C<O AND H>MA14,O,C,8,0),COLOR66FF66;
A0:=FROMOPEN;
P:=PERIOD ;
A:=IF(P=1,A0,IF(P=2,A0/5,IF(P=3,A0/15,IF(P=4,A0/30,
IF(P=5,A0/60,IF(P=0,0,1))))));
均价线:=IF(CAPITAL>0,SUM(AMOUNT,A)/100/SUM(VOL,A),
SUM(CLOSE*VOL,A)/SUM(VOL,A));
额势:=IF(CAPITAL>0,均价线,1);
取势:=IF(SMA(额势,3,2)>SMA(额势,5,3),(O+2*HHV(H,2))/3,(O+2*LLV(L,2))/3);
短1:=(EMA(取势,1)+MA(取势,3)+MA(取势,5))/3;
短2:=(EMA(取势,3)+MA(取势,6)+MA(取势,9))/3;
短01:=EMA((短1+短2+MA(短2,5))/3,2.637),COLORFFC0F0,LINETHICK2;
趋势线1:=SMA(FORCAST(CLOSE,13),5,1),COLORFFFF00,LINETHICK1;
趋势线2:(EMA(SMA(FORCAST(取势,12),4,1),4)+趋势线1)/2,COLORFFFF00,
LINETHICK1;
趋势线3:(EMA(SMA(FORCAST(取势,12),20,1),4)+趋势线1)/2,COLORFFFF00,
LINETHICK1;
IF(趋势线1>REF(趋势线1,1),趋势线2,DRAWNULL),COLORFFAA00,LINETHICK2;
IF(趋势线1<REF(趋势线1,1),趋势线2,DRAWNULL),COLOR0088FF,LINETHICK2;
A00:="RSI.RSI1"(6,12,24);
ZF:=(C-REF(C,1))/REF(C,1)*100;
DRAWICON(CROSS(A00,50) AND ZF>3,L*0.98,1);
MA20:=MA(C,20),COLORWHITE,LINETHICK2;
乖离线:=((C-REF(MA20,1))/20+MA20)*1.20;
卖点:=CROSS(C,乖离线);
X6:=REF(CLOSE,1);
X7:=((SMA(MAX((CLOSE - X6),0),7,1) / SMA(ABS((CLOSE - X6)),7,1)) * 100);
X8:=CROSS(79,X7) ;
X9:=FILTER(X8,4) ;
出货:=X9;www.grahamobil.com'出货'),COLOR9000F5;{卖点跟出货在5天内同时出现的时候,
不让出货显示}
允许出现卖点:DRAWTEXT(条件A ,H+0.13,'卖点'),COLOR00FF00;
STICKLINE(显示A_B,O,C,8,0),COLORFF9933;
DRAWTEXT(显示A_B,(H+L)/2,''),COLORDD99FF;
:DRAWTEXT(C>MA(C,20) AND (MA(C,5)>MA(C,10) AND MA(C,5)<MA(C,20))
OR (C>MA(C,20) AND MA(C,5)>MA(C,10) AND MA(C,10)<MA(C,20))
OR(C>MA(C,20) AND MA(C,5)>MA(C,10) AND MA(C,10)<MA(C,20)),MA(C,20),'')
,COLORFFFFFF;DRAWTEXT_FIX(C>O,0.01,0.9,0,' WWW.grahamobil.com '),COLORRED;
DRAWTEXT_FIX(C>O,1,1,0,'程序化交易模型'),COLORRED;

 

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 262069696  点击在线交流或微信:cxhjy888 进行 有偿 编写!

怎么收费,代编流程等详情请点击阅读,或QQ微信联系我们!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容