麒麟周线主图指标公式公式、源码详解-通达信公式 -程序化交易(grahamobil.com) - 365bet送体验金
您现在的位置:程序化交易>> 股票公式>> 通达信>> 通达信公式>>正文内容

365bet送体验金

相关标签:

 

 

原理解析:


 

 来源:程序化99( WWW.grahamobil.com )

源码:

 

 

EMA13:=EMA(C,13),COLORWHITE;
EMA21:=EMA(C,21),COLORYELLOW;
EMA34:=EMA(C,34),COLORFF00FF;
EMA60:=MA(C,60),COLORFFCC66;
VAR2:=(2*CLOSE+HIGH+LOW)/4;
VAR3:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR4:=LLV(LOW,5); VAR5:=HHV(HIGH,4);
散户:=EMA((VAR2-VAR4)/(VAR5-VAR4)*100,4)*VAR3;
庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3;
DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.05,'←低吸'),COLORLIRED;
DRAWTEXT(CROSS(庄家,散户) AND 散户>70,H+0.05,'←高抛'),COLORGREEN;
DRAWICON(CROSS(散户,庄家) AND 散户<30,L-0.05,1);
DRAWICON(CROSS(庄家,散户) AND 散户>70,H+0.05,2);
VAR9:=CLOSE-REF(CLOSE,5);
VARA:=EMA(EMA(VAR9,5),5)/EMA(EMA(ABS(VAR9),5),5);
VARC:=EMA(EMA(VAR9,20),20)/EMA(EMA(ABS(VAR9),20),20);
卖出:=IF(VARA>0 AND CROSS(VARC,VARA),90,100);
DRAWICON(卖出<0,H+0.05,15); 买线:=EMA(CLOSE,2);
卖线:=EMA(SLOPE(CLOSE,21)*20+CLOSE,42);
B1:IF(CROSS(买线,卖线),L-0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLORMAGENTA;
S1:IF(CROSS(80,RSI)*30,H+0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
VC:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA (CLOSE,32))/MA(CLOSE,32)*100)/3;
S2:=IF(VC>20 AND FILTER(VC< REF(VC,1),5),H+0.02,DRAWNULL),CIRCLEDOT,LINETHICK3,COLORGREEN;
A0:=(L+H+C*2)/4;{www.grahamobil.com'http://www.grahamobil.com' title='趋势' target='_blank'>趋势:=LLV(MA(H,13),1),COLORRED,LINETHICK1;
VARAZ:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
VARBZ:=EMA(0.667*REF(VARAZ,1)+0.333*VARAZ,5);
VARCZ:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
VAR1Z:=(HIGH+LOW+OPEN+2*CLOSE)/5;
VAR2Z:=REF(VAR1Z,1);
VAR3Z:=SMA(MAX(VAR1Z-VAR2Z,0),10,1)/SMA(ABS(VAR1Z-VAR2Z),10,1)*100;
VAR4Z:=FILTER(IF(COUNT(VAR3Z<20,5)>=1 AND COUNT(VAR1Z=LLV(VAR1Z,10),10)>=1 AND
CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0),5);
DRAWICON(VAR4Z,LOW,25);
VAR5Z:=FILTER(均衡>REF(均衡,1)AND 中轨<REF(中轨,1)AND C>REF(C,1),11);
DRAWTEXT(VAR5Z,LOW*0.985,'进'),COLORYELLOW;
DRAWTEXT(VAR5Z,LOW*0.995,'^' ),COLORYELLOW;
{买}
VARMACD1:=3;
VARMACD3:=(3)*(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1)) - (2)*
(SMA(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1),3,1));
DRAWICON(CROSS(VARMACD3,VARMACD1),L*0.95,25);
ZA1:=C*2-REF(C,8.5/2);
ZA2:=REF(C,19/3)*2-C;
短期对称:=(ZA1+ZA2)/2;
关键点:=HHV(短期对称,27/2);
M1:=L*2-REF(H,27/2);
M2:=REF(H,27/2)*2-L;
M3:=(M1+M2)/2;
中期对称:=FORCAST(M3,21);
趋势判断:=MA(M3,27*2),COLOR0000FF,NODRAW;
ZA5:=趋势判断-REF(趋势判断,1);
{通达信版}
IF(ZA5<0,趋势判断,DRAWNULL),COLOR00FF00,POINTDOT,LINETHICK4;
IF(ZA5>0,趋势判断,DRAWNULL),COLOR0000FF,POINTDOT,LINETHICK4;
IF(ZA5=0,趋势判断,DRAWNULL),COLOR00FFFF,POINTDOT,LINETHICK4;
DRAWTEXT_FIX(C>O,0.01,0.9,0,' WWW.grahamobil.com '),COLORRED;
DRAWTEXT_FIX(C>O,1,1,0,'程序化交易模型'),COLORRED;

 

 

公式导入教程: 【通达信公式源码导入方法教程】 【同花顺公式源码导入方法教程】 【大智慧新一代公式源码导入方法教程

 

 

有思路,想编写各种指标公式,程序化交易模型,选股公式,预警公式的朋友

可联系技术人员 QQ: 262069696  点击在线交流或微信:cxhjy888 进行 有偿 编写!

怎么收费,代编流程等详情请点击阅读,或QQ微信联系我们!

 


【字体: 】【打印文章】【查看评论

相关文章

    没有相关内容